Word processing– OpenOffice.org Writer

This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.

http://creativecommons.org/licenses/by-sa/3.0

This document has been produced with the financial assistance of the European Union. The views expressed herein are those of the author and can in no way be taken to reflect the official opinion of the European Union. The material prepared for ECDL certification in accordance with Sylabus 5 requirements.
# Table of Contents

## WORD PROCESSING

<table>
<thead>
<tr>
<th>The Basics of Creating a Text Document</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to the Application</td>
<td>4</td>
</tr>
<tr>
<td>Text Documents</td>
<td>4</td>
</tr>
<tr>
<td>Application</td>
<td>5</td>
</tr>
<tr>
<td>Actions</td>
<td>6</td>
</tr>
<tr>
<td>Saving</td>
<td>7</td>
</tr>
</tbody>
</table>

## Basic Actions in Working with Text

<table>
<thead>
<tr>
<th>Entering Text</th>
<th>7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Removing Characters</td>
<td>8</td>
</tr>
<tr>
<td>Over-typing</td>
<td>9</td>
</tr>
</tbody>
</table>

## OpenOffice.org Writer Interface

| Creating a Simple Document              | 13 |

## Formatting a Document

| Selecting Text                          | 15 |
| Commands for Selecting Text             | 16 |
| Formatting Characters                   | 17 |

## Working with Paragraphs

| Selecting a Paragraph                   | 24 |
| Formatting a Paragraph                  | 24 |

## Opening a Writer File

| Inserting Tables in a Document          | 35 |
| Changing Basic Settings of an Application | 35 |
| Tables                                  | 38 |
| Tabs                                    | 41 |

## Inserting Pictures and Other Objects

| Pictures                                | 48 |
| Drawn Objects                           | 50 |
| Charts                                  | 51 |

## Copying

| Mail Merge                              | 57 |
| Mail Merge by Using a Wizard            | 58 |
| Mail Merge with Inserting Fields        | 59 |
| Labels                                  | 61 |

## Spellchecking

| Document Formatting                      | 70 |
| Document Page Settings                  | 70 |
| Document Pages                          | 72 |
| Automatic Hyphenation                   | 72 |
| Footer and Header                       | 73 |
MODULE 3

WORD PROCESSING

In this module, you will learn how to:

- Create a simple text document in the Writer application;
- Format text and paragraphs;
- Insert tables in a document;
- Insert other objects in a document;
- Perform mail merge;
- Perform spell check;
- Prepare a document for printing;
- Save documents in a different format.

The Basics of Creating a Text Document

Introduction to the Application

Creating, editing and processing documents is one of the most typical usages of computer programmes. Word processing applications are very helpful in creating small articles and large book-volume texts. Word processors allow creating a document in any sequence, e. g., a text can be started from the end, followed by the beginning and proceeded by the middle of the text. Any time, a document can be edited, supplemented and its content can be deleted by removing text or images. The user has a large choice of additional elements, such as tables, images, drawings and charts which can be inserted into a text, unlike typing by a typewriter. Characters used in a text can be of various sizes, colours and styles and various fonts can be applied.

Text Documents

Now, to view a page of a simple text document:
Margins – free spaces around the content of a document. Width of each margin can be separately set, e. g., the width of the right, the left, the top and the bottom margin. Symmetrical margin width can be set for odd and even pages in a document, e.g., for a book intended for duplex printing.

Text consists of separate letters called characters.

Paragraphs – text areas made by pressing the Enter key on the keyboard. Specific formatting properties and potential are applied to a paragraph. A paragraph in a document is created by special non-printing formatting marks.

Application

In the OpenOffice.org application suite, the Writer application is used for creating text. It is a comprehensive application for creating both small and large book-volume text documents. Various elements can be supplemented to a document, such as tables, images and charts.
The OpenOffice.org suite also includes an application for creating presentations, a spreadsheet application, a database management programme, a drawing programme and several other additional programmes and modules. These programmes are interrelated. In several cases, the Writer is used by other programmes of the OpenOffice.org suite, for example, the database programme Base creates reports with the word processor and provides an automatic activation of the Writer.

These programmes are developed and maintained by an online community with the support of software company Oracle. The software is free and is included with the Linux operating system.

**Actions**

A computer programme does not think; it is always the user who has to give an exact command to be carried out, specify the location where to perform an action. Similarly, the user must have an idea about the whole structure of a document and the components of a document. The programme will create a text document according to the user’s commands which let the programme know what the user wishes to accomplish.

For example, if a table must be inserted:

- Specify the insertion place of a table;
- Perform the table insertion command **Insert Table** in the application;
- Specify the number of rows and columns in a table;
- Confirm the action.

Programmes often feature several hundreds and even thousands of possible commands for a range of various actions and commands are normally arranged in logical menus and submenus. For example, the File menu in any application will contain commands referring to the entire file – such as save, print, and export. Similarly, the Insert menu will include commands for inserting various elements, such as images, charts or page numbers. If the layout of the programme needs to be changed, or adding or removing certain elements of the workspace, this will most likely be done through the View menu.

If additional input is required for the execution of a command, the programme opens a dialogue box in which the user has to make a choice and adjust settings.

Triangles indicate submenus in a menu:

An ellipsis indicates that a dialogue box will open:
Commands are presented like this:

*Insert* --> *Picture* --> *From File*

**Saving**

At this stage, the user saves a created document. A folder structure has already been created and prepared on the computer’s operating system. Users can use the existing folder structure or create their own. If a different save location is not specified, the programme saves the file in the default location which in the case of OpenOffice.org applications, including **Writer**, is the Documents folder created by the operating system in the user’s account. The default settings of the programme can be changed and adjusted to suit each user’s needs.

**Basic Actions in Working with Text**

Although entering characters seems first easy, there are some features to be observed. Word processors and other applications feature many automatic functions that enhance the user’s work and a correct operation of this potential depends on the way text is entered in a document, especially this is very important with working with larger texts. Unlike a typewriter, when the text layout should be planned before typing, the computer programmes allow arranging, editing and correcting the entered text after it has already been inserted.

**Entering Text**

In **Writer**, the user has to specify the place of the text to be entered and the same action must be performed in other programmes – f. e., prior to entering an address in a web browser, the user has to left-click in the address field.

The insertion point shows the insertion place of the text and other objects – the insertion point is a text cursor in the form of a vertical flashing line. The cursor can be freely moved over existing text by placing the mouse pointer at the needed location and left-clicking:
The text cursor can be easily moved also by the cursor keys of the keyboards Up, Down, Left, right, and moving to the previous page can be done by the PgUp key, to the next page by the PgDn key, respectively:

![Keyboard with cursor keys](image)

**Note!**

In **Writer**, by left-clicking, the insertion point cannot be positioned in any free space.

To enter text:

1. Place the mouse pointer in the required location;
2. Left-click;
3. Enter the text (if text has to be copied, paste it).

Useful actions:

- The **Enter** key on the keyboard should not be pressed at the end of a text line; the programme will automatically move the insertion point, e. g., the insertion point will be moved to a new line. An exception is that users need to create a new paragraph on their own.
- To insert a punctuation mark after a word in a text, insert a punctuation mark without a space, then a gap follows and then – the next word, see below:

  ![Examples of entering text](image)

  A – recommended; B – not recommended

*Image 2 Examples of entering text*

- A new page will be added automatically if the previous page is full.
- One space is inserted between words.

**Removing Characters**

By entering text in the word processor or in other programmes and websites, mistakes can occur. In such cases, a wrong character can be replaced by removing it and entering the right one.
To correct a character in a text:

1. Place the mouse pointer after (or before) the character to be removed;
2. Left-click;
3. Press the Backspace (or Delete) key on the keyboard;
4. Enter the new character.

Spaces and breaks to create a new line can be also deleted at the end of a paragraph. The text layout is created by special nonprinting formatting marks that are not showed in the document on the display and on a text printout.

Useful tip

If text cannot be entered in a page in accordance with desired layout, check the use of nonprinting formatting marks!

To remove the odd formatting characters and nonprinting characters:

1. Click the Nonprinting Characters button in the Standard toolbar of the application:

2. Left-click to place the insertion point before a character to be removed;
3. Press the Delete key on the keyboard.

Over-typing

In the Writer and in other programmes, the over-typing mode can be used - characters of the existing text are replaced by new ones at the moment of typing the new text.

To switch to the over-typing mode:

Press the Insert key on the keyboard:

As this mode can be turned on unintentionally, it is recommended to check this mode in the status bar of the programme window. In Writer, the status bar shows the abbreviation OVER of the word Overwrite:

To switch on the over-typing mode:

1. Repeatedly press the Insert key on the keyboard; or
2. Place the mouse pointer on the OVER key in the status bar of the programme window;
3. Left-click.

The same method can be used also to switch on the over-typing mode.

**OpenOffice.org Writer Interface**

The graphical interface is what the user sees upon opening the programme – the application window, the control tools, menus, toolbars and the document.

In **Writer**, every document opens in a separate window.

Understanding the layout and the functionality of the user interface will ensure productive work in the OpenOffice.org **Writer** environment. The interface is divided into functional areas, each having a specific purpose.

![Image 3 The user interface of OpenOffice.org Writer](image.png)
The menu bar B contains menus with commands for various tasks. The names of the menus correspond to the functions of the commands:

- **File** – commands that apply to the entire document, such as creating a new document of the OpenOffice.org and other documents, saving, printing and document creation wizards;
- **Edit** – editing commands, such as copy, paste, find and replace;
- **View** – changing the appearance of the user interface and functional areas, adding and removing workspace objects, restoring the original appearance;
- **Insert** – inserting a new image, a drawing, a chart and page numbers;
- **Format** – formatting the parts of a document, fonts and paragraphs, page formatting;
- **Table** – commands for inserting, modifying and formatting a table;
- **Tools** – tools for additional tasks, such as spell check;
- **Window** – opening a new window, switching between open documents;
- **Help** – the help function, information about the application, and the software version.

The toolbars (C, D) include the most frequently used commands featured by buttons. By hovering the mouse pointer above a button, the name of the corresponding function appears in the language of the programme’s user interface. Toolbars can be turned off and on as needed.

**To turn on (off) a toolbar:**

1. Execute the View—>Toolbars menu command;
2. Choose the needed toolbar by its name.

The default toolbars in **OpenOffice.org Writer**:

- **Standard** – frequently used commands from the File, Edit, Insert menus;
- **Formatting** – commands for formatting text and other parts of a document.

Toolbar buttons and the related commands can be customized.

**Useful tip**
To make all the toolbar buttons visible, maximize the window!

The availability of additional options is indicated by a triangle next to the button:

**Note!**
Toolbars can open and close automatically, depending on the task performed in the application and the position of the insertion point in a document.

The ruler E shows the size of the text, tables, pictures and formatting elements, such as indents specified in the units of measurement used with the application.
To turn on (off) a ruler:

Execute the View→Ruler menu command.

Note!
The OpenOffice.org uses the default units of measurement - inches. How to change the units of measurement is described below.

In the user interface, the scroll bar F appears automatically, if any item does not fit into its allocated space. For example, in Writer, the scroll bar allows viewing the part of a document that does not fit into the window and cannot be seen in the display.

The document area G features a document whose appearance can be changed. The Writer allows using two layouts of a document:

- **Print Layout** – it shows how your document will look once it is printed.
- **Web Layout** – a web document can be created in Writer. No margins are shown and the document is not divided into pages.

To change the document layout to the web layout:

Perform the View→Web Layout menu command.

The zoom tool I changes the visual size of a document in a window and the real printout is not resized.

To modify the size of a document (to zoom or to resize):

1. Left-click on the – button to zoom out a document;
2. Left-click on the + button to zoom in a document:

   ![Zoom Tool](image)

   or

1. Click on the slider;
2. While holding down the mouse button, drag to the required direction;
3. Release the mouse button.

The status bar H displays information about a document, such as the total number of pages, the page number in which the insertion point is placed, the language of a document and the text input mode.

Useful tip

The zoom tool can be also used by the aid of the mouse; to resize the visual document, press the Ctrl key on the keyboard and while holding it down, scroll the mouse wheel:
Creating a Simple Document

To create a simple document:

1. Open the word processor;
2. Enter text in paragraphs;
3. Save the document.

Useful tip

An action can be reverted by using the Edit→Undo menu command or the Undo button in the toolbar. An undone action can be restored with the Edit→Redo command or the Redo button:

Task 3.1. Create a simple document with default settings, such as page size, margins and font size.

1. Activate OpenOffice.org Writer:
   1.1. Perform the operating system command in the top panel of the desktop
   Applications→Office→OpenOffice.org Word Processor:

2. Enter the text:
He heard quiet steps behind him. That didn’t bode well. Who could be following him this late at night and in this deadbeat part of town?

3. Create a new paragraph:
   3.1. Make sure that the insertion point is placed at the end of the entered text;
   3.2. Press the Enter key on the keyboard.

4. Enter the entire text:
   4.1. Enter text in a new paragraph:
   Was there another crook who’d had the same idea, and was now watching him and waiting for a chance to grab the fruit of his labor?
   4.2. Make sure that the insertion point is placed at the end of the entered text;
   4.3. Press the Enter key on the keyboard;
   4.4. Enter the text:
   Or did the steps behind him mean that one of many law officers in town was on to him and just waiting to pounce and snap those cuffs on his wrists? He nervously looked all around.

5. View nonprinting characters:
   5.1. Execute the View→Nonprinting Characters menu command;
   5.2. Find the specification of the end of the paragraph;
   5.3. Repeat the View→Nonprinting Characters menu command.

6. Replace the word nervously by the word quietly in the last sentence:
   6.1. Place the mouse pointer before the word nervously;
   6.2. Left-click;
   6.3. Press the Delete key on the keyboard several times until the word is deleted;
   6.4. Enter the word quietly.

7. Replace the word town at the end of the first paragraph by the word city:
   7.1. Place the mouse pointer before the word town;
   7.2. Left-click;
   7.3. Press the Insert key on the keyboard;
   7.4. Check that the character specifying the over-typing mode OVER is displayed in the status bar;
   7.5. Enter the word city;
   7.6. Repeatedly press the Insert key on the keyboard.

8. Save the document:
   8.1. Execute the File→Save menu command;
   8.2. In the Name field of the Save dialogue box, enter the file name simple;
   8.3. In the dialogue box Save, click the Save button.

9. Click the Close control button in the application window to close the simple.odt file:

10. Open the created file from its location in the file system:
10.1. Perform the **Places->Documents** menu command in the top panel of the desktop;

10.2. In the **Documents** folder, left-click to select the file;

10.3. Press the **Enter** key on the keyboard:

```
[Image: simple.odt]
```

11. Apply zoom 150%:

11.1. Click on the + button in the zoom tool several times until the 150% is reached:

```
[Image: zoom_tool]
```

12. Restore the original appearance of the document:

12.1. Click the slider button in the zoom tool;

12.2. While holding down the left mouse button, drag left to the middle of the zoom slider until 100% is reached;

13. Click the **Close** button in the title bar to close the **Writer** document window.

**Useful tip**

Although various operating systems and online services, such as e-mail attachments allow non-Latin characters in filenames, there are cases when such names may cause problems.

It is better to use only characters of the Latin alphabet in the filenames!

---

**Formatting a Document**

**Selecting Text**

Selecting text and other objects must be done prior to actions such as replacing, formatting and deleting with the corresponding text area.

**Note!**

While entering new text, it replaces the selected text area.

In virtually all cases, the user has to perform the following actions:

- To select a text area for an intended action;
- To execute the selected command for the respective action.

**To select text for further action:**

1. Left-click at the end of the area that you wish to select;
2. While holding down the mouse button, move (drag) the mouse pointer to the beginning of the text area;
3. Release the mouse button:

The background of the selected text area is shaded in a different colour. The colour and its intensity depend on the particular word processor and the operating system.

**For example, to delete text:**

1. Select the text area to be deleted;
2. Press the *Delete* key on the keyboard.

It is possible to select anything from a single character to a virtually unlimited number of text and document objects; individual spaces between words can also be selected.

**To undo selection:**

To continue work, position the insertion point in the required location of the text; or
Left-click at any place in text.

**Commands for Selecting Text**

In *Writer*, several additional actions are possible to make the text selection more convenient.

**To select some areas of text:**

1. Select the text area;
2. Press the *Ctrl* key on the keyboard;
3. While holding down the *Ctrl* key, select other areas of text;
4. Release the *Ctrl* key:

**To select one character:**

1. Position the mouse pointer anywhere on the word;
2. Double left-click.
To select a sentence in the text:
1. Position the mouse pointer anywhere in the respective sentence;
2. Left-click three times in a row.

To select the entire paragraph:
1. Position the mouse pointer anywhere in the respective paragraph;
2. Left-click four times in a row.

To select the entire content of a document:
1. Perform the Edit->Select All menu command; or
2. Perform the keyboard combination Ctrl+A.

**Useful tip**

Keyboard combinations can be used for frequently performed commands. They include universal shortcuts that can be performed in other programmes, as well. Keyboard shortcuts are written as a specific key press sequence performed without releasing each previous key.

Keyboard combinations are displayed in menus next to the corresponding command:

Most frequently used keyboard combinations are as follows:
- Ctrl+A – select the entire content of a document;
- Ctrl+B – apply bold formatting;
- Ctrl+Shift+P – apply subscript;
- Ctrl+Z – undo the previous action;
- Ctrl+S – save changes to a document;
- Ctrl+N – create a new document;
- Ctrl+C – copy a selection;
- Ctrl+V – paste a selection.

**Formatting Characters**

The desired appearance of a document can be achieved by formatting the selected text or changing formatting settings before entering text.

Frequently used formatting properties for characters:
- Font type;
- Font size;
- Bold, italic and underline;
- Font colour;
- Superscript and subscript;
- Font case;
- Additional font effects;
- Background fill.

All paragraph formatting options are available in the **Character** dialogue box. Frequently used formatting commands are also available on buttons in the **Formatting** toolbar.

**Font Type**

A font type determines the style of characters. A font is a collection of specially designed characters, and each font has its own name, e.g.:

*Times New Roman, Liberation Serif, Arial, Courier New, Comic Sans MS*

**Note!**

What fonts can be selected in the programme depends on the font types available in the operating system.

**To modify the font type:**

1. Select the existing text or position the insertion point;
2. Select the font type in the **Formatting** toolbar menu:

![Font Type Menu](image)

**Font Size**

A font size determines the geometric font size in a document:

![Font Size Options](image)

**To modify font size:**

1. Select the existing text or position the insertion point;
2. Select the font size in the **Formatting** toolbar menu:
1. Click in the font size field:

2. Enter the desired font size;
3. Press the Enter key on the keyboard.

**Highlighting Effects**

Bold, italic and underline are frequently used highlighting effects. These effects can be used individually or in various combinations:

```plaintext
text, **bold**, *italics*, underline, **bold and italics**, **bold and underline**
```

**To apply a highlighting effect:**

1. Select the existing text or position the insertion point;
2. Click the necessary highlighting option in the **Formatting** toolbar to apply the highlighting effect:

```
[Image 4 Selecting font highlighting]
```

A – bold; B – italic; C – underline

**Font Colour**

Font colour helps highlight a text area in a document or achieve the desired text formatting:

```plaintext
automatic, red, blue, magenta, green, black
```

**To modify a font colour:**

1. Select the existing text or position the insertion point;
2. Click on the menu at the **Font Color** button:
3. Click the desired font colour.

Special Effects

Some special font effects, such as superscript and subscript are frequently used:

This is some text with \textsuperscript{superscript}: $1 \text{ m}^3$, and \textsubscript{subscript}: $\text{H}_2\text{O}$

To apply superscript (subscript):

1. Select the existing text or position the insertion point;
2. Open the dialogue box with the Format $\rightarrow$ Character command;
3. Open the Position tab in the Character dialogue box;
4. Select Superscript (Subscript):
5. Confirm the selection.

Case

The term font case means upper and lower case letters. The case can be also changed for the entered text by without deleting characters and without over-typing them.

To change font case:

1. Select the existing text or position the insertion point;
2. With the Format $\rightarrow$ Character command, open the dialogue box;
3. Open the Font Effects tab in the Character dialogue box;
4. In the Effects menu, select Capitals to change the register for upper case letters, Lowercase – for normal text size:
5. Confirm the selection.

Additional Effects
The **Writer** application allows applying various additional font effects to text font. This is a suitable feature for creating posters, advertisements, titles, greeting cards and diplomas. All the font formatting tools can be found in the **Character** dialogue box and in its stabs. The **Formatting** toolbar displays formatting buttons for frequently used font effects. The whole appearance of the text can be seen in the preview:

![Character dialogue box](image)

*Image 5 The following features have been applied to text: black colour **Font Color**, **Outline** effect with **Shadow**, **Underlining** with a green dotted line, underline, **Overlining** in red and bold*

**Text Highlight Colour**

Background fill is used to highlight text or for design purposes and it can be used similarly to other previous effects. Users can use them according to their own wishes to format a text.

**To specify text fill:**

1. Select the existing text or position the insertion point;
2. Click on the menu at the **Highlighting** button:

![Highlighted text](image)

3. Choose the fill.

**Useful tip**

To remove formatting, perform a reverse formatting action, e.g., to make green characters black again, simply change the font colour to black.
**Task 3.2. Supplement the text. Format the text.**

1. Open the text.odt document:
   1.1. Execute the Places→Documents command in the top panel of the desktop;
   1.2. Left-click to select the 3_text_processing folder;
   1.3. Press the Enter key on the keyboard;
   1.4. Left-click to select the 3.2_font folder;
   1.5. Press the Enter key on the keyboard;
   1.6. Select the text.odt file in Writer;
   1.7. Press the Enter key on the keyboard.
2. Change font and font colour in the last paragraph:
   2.1. Select the text in the last paragraph:
      2.1.1. Left-click after the word sidewalk at the end of the text;
      2.1.2. While holding down the left mouse button, drag across the text until the beginning of the word Was is reached;
   2.2. Change font colour:
      2.2.1. In the Formatting toolbar, click on the menu at the Font Color button:
      2.2.2. Select the Green colour.
   2.3. Change the font type:
      2.3.1. Click on the font type menu in the toolbar;
      2.3.2. Select the DejaVu Sans font.
3. Enter the following sentence in the first line:

\[
\text{He needs } 1\text{m}^3 \text{H}_2\text{SO}_4 \text{ for this experiment.}
\]

3.1. Left-click to place the insertion point at the beginning of the document;
3.2. Enter the text He needs 1m;
3.3. Perform the Format→Character menu command;
3.4. In the Character dialogue box, open the Position tab:
      3.4.1. Left-click on the name of the Position tab.
3.5. In the Position pane, click on Superscript;
3.6. Click the OK button;
3.7. Enter 3;
3.8. Execute the Format→Character menu command;
3.9. In the Position tab, select Normal;
3.10. Click the OK button;
3.11. Enter the rest of the text without applying any effects;
3.12. Select 2;
3.13. Press the Ctrl key on the keyboard;
3.14. While holding down the Ctrl key on the keyboard, select 4:

\[
\text{H}_2\text{SO}_4 \text{ for this experiment.}
\]
3.15. Perform the Format→Character menu command;
3.16. In the Position tab, select Subscript:
3.17. In the dialogue box **Character**, click the **OK** button;
3.18. Cancel the selection:
   3.18.1. Left-click in the text.

4. In the third sentence, reduce the font size to 10:
   4.1. Select the text in the sentence:
       4.1.1. Place the mouse pointer above the third sentence;
       4.1.2. Left-click three times in a row.
   4.2. Click on the font size menu in the **Formatting** toolbar;
   4.3. Select font size **10**:

5. Make the word **steps** bold and italic:
   5.1. In the first sentence, select the word **steps**:
       5.1.1. Double left-click on the word **steps**.
   5.2. Click the **Bold** button in the toolbar;
   5.3. Click the **Italics** button in the toolbar.

6. Change the incorrect font case in the text:
   6.1. Select the text entered in upper case letters at the end of the document;
   6.2. Execute the **Format**->**Character** menu command;
   6.3. Open the **Font Effects** tab by clicking on it;
   6.4. in the **Effects** menu, select **Lowercase**:
       6.5. Click the **OK** button.

7. Remove the odd spaces before the word **greenbacks**:
   7.1. Position the mouse pointer before the word **greenbacks**;
   7.2. Left-click;
   7.3. Press the **Backspace** key on the keyboard eight times in a row.

8. Revert an unintended action:
   8.1. Select the entire text in the document:
       8.1.1. Press the **Ctrl** key on the keyboard;
       8.1.2. While holding down the **Ctrl** key, press the **A** key on the keyboard.
   8.2. Press the **Delete** key on the keyboard;
   8.3. Click the **Undo** button in the toolbar to revert the last action:
9. In the first sentence, highlight the word **experiment** with the red font colour:
   9.1. Place the mouse pointer above the word **experiment**;
   9.2. Double left-click;
   9.3. Click on the menu of the **Highlighting** button:
   9.4. Select **Light Red**.

10. Close the document, saving changes to it:
   10.1. Click the **Save** button in the toolbar;
   10.2. Click the **Close** button in the title bar to close the **Writer** window.

**Working with Paragraphs**

Paragraphs in a document are text areas created by pressing the **Enter** key on the keyboard at the location of the insertion point; the amount of text in a paragraph is not limited. Formatting applied to a paragraph applies to all lines in it. The entered text can also be split into paragraphs.

**Selecting a Paragraph**

A paragraph must be selected before performing any actions on it or applying any formatting to it.

To select a paragraph for an action:
Left-click (position the insertion point) anywhere in the text of the paragraph.

To select several paragraphs at the same time:
Select the text in paragraphs.

**Formatting a Paragraph**

Paragraphs, like fonts have their own properties and formatting options. Paragraph formatting can be applied best in the dialogue box **Paragraph**. Formatting commands frequently used are specified also on the buttons of the **Formatting** toolbar.

Frequently used formatting options:
- Alignment;
- Spacing between paragraphs;
- Indent;
- Line spacing;
Alignment
To align a text area to page margins, alignment is used. Lines can be aligned to the right or left margins of the text or justified in relation to margins. Text can also be aligned to the centre to the middle of the page between the side margins. Various alignment options can be applied to paragraphs of the text. For example, to place a word in the middle of a page, it should better be selected as a single paragraph and then centered.

To align a paragraph:
1. Select a paragraph (select text from several paragraphs);
2. Click the corresponding button in the Formatting toolbar:

   ![Alignment Options]

   A – left; B – centered; C – right; D – justified

   *Image 6 Alignment of a paragraph*

Spacing
Spacing is used to virtually separate paragraphs in a document. Spacing can be set before and after the paragraph up to the next line. Although it is possible to insert a blank paragraph in the text by pressing the Enter key on the keyboard to achieve the same effect, it is recommended to avoid such a step because further formatting can cause changes in text layout.

To apply spacing between paragraphs:
1. Select a paragraph (select text from several paragraphs);
2. Execute the Format->Paragraph menu command;
3. In the Indents & Spacing tab of the Paragraph dialogue box, specify:
   3.1. In the Above paragraph field, specify spacing up to the text above the paragraph;
   3.2. In the Below paragraph field, set spacing up to the text below the paragraph.

Indent
Indenting can be applied to the entire paragraph what means, to all lines in the text or it is also possible to apply first line indentation or a combination of several indentation options at the same time. Indents are specified in the units of measurement (inches, centimetres) used by the programme.
To set an indent for a paragraph (several paragraphs):

1. Select a paragraph (select text from several paragraphs);
2. Execute the Format->Paragraph menu command;
3. In the Indent pane in the Indents & Spacing tab of the Paragraph dialogue box, specify:
   3.1. In the Before text field - the left indent of the paragraph (in units of measurement);
   3.2. In the After text field – the right indent of the paragraph (in units of measurement);
   3.3. In the First line field – the left indent of the first line of the paragraph (in units of measurement).

The Decrease Indent and the Increase Indent buttons in the Formatting toolbar decrease the indent for the entire paragraph by moving it to the left and increase the indent for the entire paragraph by moving it to the right, e.g.:

Line Spacing

Line spacing is an area between text lines in a paragraph. Spacing can be set both for an individual paragraph and all the paragraphs of the document.

To apply line spacing:

1. Select a paragraph (select text from several paragraphs);
2. Perform the Format->Paragraph menu command;
3. In the menu Line spacing in the Indents & Spacing tab of the Paragraph dialogue box, indicate spacing between lines.

For example, the indent on the left side before the text of the second paragraph is 0.20 and the indent of the first line is 0.16; spacing above the previous paragraph is 0.10 and spacing below the next paragraph is 0.24 units of measurement (in inches) and the line spacing is 1.5:
Background Colour of Paragraph

Either solid colour or graphical image can be the background of the paragraph.

To apply background colour for a paragraph:
1. Select a paragraph (select text from several paragraphs);
2. In the Formatting toolbar, click on the menu at the Background Color button:

```
  [Image of Background Color button]
```
3. Click the desired colour in the palette.

To place an image in the background of the paragraph:
1. Select a paragraph (select text from several paragraphs);
2. Perform the Format->Paragraph menu command;
3. Open the Background tab of the Paragraph dialogue box;
4. Choose the Graphic in the As menu;
5. Find an image by clicking the Browse button;
6. Choose the Area type of the background layout in the Position pane;
7. Confirm the selection by clicking the OK button.

Borders

A border creates a frame around a paragraph; colour, shading can be applied to a border. A border can be applied to a part of a paragraph, e.g., on the right, left, top or bottom side of a paragraph.

To apply borders to a paragraph:

1. Select a paragraph (select text from several paragraphs);
2. Perform the Format->Paragraph menu command;
3. Open the Borders tab in the Paragraph dialogue box;
4. Specify the following properties of the border:
   4.1. Line arrangement;
   4.2. Shadow style;
   4.3. Line Style;
   4.4. Border Color;
   4.5. Spacing to contents.
5. Confirm the selection by clicking the OK button.

As seen below, a border with line spacing 0.02 (in inches) in the shape of a green double line with red shadow is placed on all of the four sides of the paragraph. The room between shading and the border line is 0.07.

Who could be following him this late at night and in this deadbeat part of town? And at this particular moment, just after he pulled off the big time and was making off with the greenbacks. Was there another crook who'd had the same idea, and was now watching him and waiting for a chance to grab the fruit of his labor? Or did the steps behind him mean that one of many law officers in town was on to him and just waiting to pounce and snap those cuffs on his wrists? He nervously looked all around. Suddenly he saw the alley.
Lists

Lists are created by using paragraphs. It is not a good practice to create lists by manually entering numbers or inserting bullet characters (symbols or pictures). Although lists made this way look the same as ones created automatically, it makes further editing and supplementing as well as layout adjustment more difficult.

To create a new bulleted list (a numbered list):

1. Position the insertion point at the beginning of a new paragraph;
2. In the Formatting toolbar, click the Bullets On/Off (Numbering On/Off) button:
3. Create a list:
   3.1. Enter text of the list line;
   3.2. Press the Enter key on the keyboard;
   3.3. Repeat the above steps for each line.
4. Stop inserting the automatic bullets (numbering):
   4.1. Press the Enter key twice at the end of the last line;
   or
   4.1. Press the Enter key at the end of the last line;
   4.2. In the Formatting toolbar, click the Bullets On/Off (Numbering On/Off) button.

To create a list from existing paragraphs:

1. Select a paragraph (select text from several paragraphs);
2. In the Formatting toolbar, click the Bullets On/Off (Numbering On/Off) button.

To modify the style of bullets (numbers):
1. Select paragraphs included in the list;
2. Execute the **Format->Bullets and Numbering** menu command;
3. In the **Bullets and Numbering** dialogue box:
   3.1. In the **Bullets** tab, choose the style for a bullet character;
   3.1. In the **Numbering type** tab, choose a numbering type;
   3.1. In the **Graphics** tab, choose a bullet type.

**Line Break**

To create text paragraphs, click the corresponding key on the keyboard. It is sometimes necessary to use line break in a paragraph, by starting a new line, but at the same time, retaining paragraph properties and the applied formatting. In such cases, the return option is used. **Writer** inserts a soft return character in the specified location of the text and it is a non-printing formatting mark.

**To insert return option in text of a paragraph:**

1. Position the insertion point in the text;
2. Use the key combination Shift+Enter:

```
He heard quiet steps behind him. That didn't bode well. Who could be following him this late at night and in this deadbeat part of town? And at this particular moment, just after he pulled off the big time and was making off with the greenbacks. (−)
Was there another crook who'd had the same idea, and was now watching him and waiting for a chance to grab the fruit of his labor? Or did the steps behind him mean that one of many law officers in town was on to him and just waiting to pounce and snap those cuffs on his wrists? (−)
```

Starting a new line with line break (return), a paragraph retains all the formatting properties that have been applied.

**Task 3.3. Arrange text in the document. Apply bullets.**

1. Open the **layout.odt** document:
   1.1. Perform the **Places->Documents** command in the top panel of the desktop;
   1.2. Double left-click to open the **3_text_processing** folder;
   1.3. Double left-click to open the **3.3_paragraph** folder;
   1.4. Double left-click to open the **layout.odt** file.
2. Split the text into paragraphs:
   2.1. Position the insertion point after the first sentence in the text before the word **He:**
   2.2. Press the **Enter** key on the keyboard;
   2.3. Position the insertion point before the word **Was:**
   2.4. Press the **Enter** key on the keyboard;
   2.5. Place the insertion point before the word **Suddenly:**
   2.6. Press the **Enter** key on the keyboard;
   2.7. Place the insertion point before the word **The:**
   2.8. Press the **Enter** key on the keyboard;
   2.9. Place the insertion point before the word **Could:**
   2.10. Press the **Enter** key on the keyboard.
3. Center the heading:
3.1. Left-click on the heading *The story*;
3.2. Click the **Centered** button in the **Formatting** toolbar:

4. Create spacing between the text paragraphs:
4.1. Select paragraphs in the text (without the heading):
   4.1.1. Left-click to position the insertion point at the end of the text;
   4.1.2. Press the **Shift** key on the keyboard;
   4.1.3. While holding down the **Shift** key, click before the word *He* in the beginning of the text.
4.2. Execute the **Format–>Paragraph** menu command;
4.3. In the **Paragraph** dialogue box, open the **Indents & Spacing** tab:
   4.3.1. Left-click on the tab name.
4.4. In the **Spacing Above paragraph** field, increase the spacing to **0.16**:
   4.4.1. Delete **0.00** in this field;
   4.4.2. Enter **0.16**;
   or
   4.4.1. Repeatedly click the corresponding button to set the necessary line spacing value to get 0.16:

   ![Spacing dialogue box](image)

4.5. In the dialogue box, click the **OK** button.
5. Increase the spacing of the fourth paragraph to **1.5 lines**:
5.1. Left-click in the fourth paragraph;
5.2. Perform the **Format–>Paragraph** menu command;
5.3. In the **Paragraph** dialogue box, open the **Indents & Spacing** tab, if required;
5.4. In the **Line spacing** tab, select the **1.5 lines** spacing.
6. To continue work, set a border of double red line with grey shading to the fourth paragraph:
6.1. Left-click on the **Borders** tab name to open it;
6.2. Click the **Set All Four Borders** pane:

   ![Set All Four Borders](image)

6.3. In the **Style** pane, select a double line of **2.60 points**:

   ![Style pane](image)

6.4. In the **Color** menu, select **Red**;
6.5. Click on the **Cast Shadow** to **Bottom Right**;
6.6. In the dialogue box, click the **OK** button.

7. Indent the second and the third paragraph:
   7.1. Select the second and the third paragraph:
      7.1.1. Left-click at the end of the third paragraph after the word *around*;
      7.1.2. While holding down the mouse button, drag it until the beginning of the second paragraph;
      7.1.3. Release the mouse button before the word *He*.
   7.2. Execute the **Format**→**Paragraph** menu command;
   7.3. In the **Paragraph** dialogue box, click on the **Indents & Spacing** tab to open it;
   7.4. Repeatedly click the corresponding button to set the line spacing value to **0.20** in the **Before text** field;

8. Apply the indent to the first paragraph:
   8.1. Click the corresponding button to set the line spacing value to **0.16** in the **First line** field:
   8.2. In the dialogue box, click the **OK** button.

9. Justify the text in the last paragraph:
   9.1. Left-click in the last paragraph of the text;
   9.2. Click the **Justified** button in the toolbar.

10. Indent the last paragraph to the right side:
    10.1. Left-click on the upward triangle in the right side of the ruler;
    10.2. While holding down the mouse button, drag to the left;
    10.3. Release the mouse button:

11. Indent the first line:
    11.1. Left-click on the downward triangle in the left side of the ruler;
    11.2. While holding down the mouse button, drag to the right;
    11.3. Release the mouse button:

12. Select background colour for a paragraph:
    12.1. Click on the menu of the **Background Color** button in the toolbar:
    12.2. Select **Light Green**.

13. Separate the first sentence in the third paragraph:
    13.1. Insert return:
       13.1.1. Position the insertion point before the word *Or*;
       13.1.2. Press the **Shift** key on the keyboard;
       13.1.3. While holding down the **Shift** key, press the **Enter** key on the keyboard;
       13.1.4. Release the keys.
13.2. Make sure that there is no indent before the word Or at the beginning of the new line.

14. Create the list of actions to make a text template in Writer:
   14.1. Position the insertion point at the end of the text;
   14.2. Press the Enter key;
   14.3. Enter the following text:

   If You want to use this “dummy” text in Writer:

   14.4. By pressing the Enter key on the keyboard, create a new paragraph;
   14.5. Click the Numbering On/Off button in the toolbar:

   14.6. Enter the text, by pressing the Enter key at the end of each line:

   If You want to use this “dummy” text in Writer:

   1. Start new Writer document;
   2. Type letters dt at the beginning;
   3. Press F3 key on keyboard.

   14.7. Stop automatic numbering:

   14.7.1. At the end of the last line, press the Enter key twice.

15. Replace numbers by bullets in the list:
   15.1. Select the list – all the three paragraphs;
   15.2. Perform the Format→Bullets and Numbering menu command;
   15.3. In the Bullets and Numbering dialogue box, open the Bullets tab:

   15.3.1. Left-click on the name of the tab.
   15.4. Select the Check mark bullets style:

   15.5. In the dialogue box, click the OK button.

16. Save the document under another name in the Documents folder:
   16.1. Execute the File→Save As menu command;
   16.2. In the Places pane of the Save dialogue box, select the Documents folder, if required;
   16.3. In the Name field, enter the filename paragraphs;
   16.4. In the dialogue box, click the Save button.

17. Close the Writer window:

   17.1. Click the Close button in the title bar.

**Opening a Writer File**

While working with documents, they can be edited and supplemented in word processor programmes. A user should know or be able to find the location on the
computer’s hard drive in the file system or on the network where the text file is stored. This file can be opened in different ways.

To open a spreadsheet file from the software Writer environment:
1. Execute the **File→Open** menu command;
2. In the **Open** dialogue box, select the file from a default folder or find a text file in the file system.
3. Complete the action by clicking the **Open** button.

To open a document file from the Documents folder (from a different location in the file system):
1. Open the folder **Documents** by performing the operating system menu command **Places→Documents**:
2. Double left-click on the icon of the document file.

To open a text file with the search function:
1. Execute the operating system **Places→Search for Files** menu command;
2. In the **Name contains** field in the **Search for Files** dialogue box, enter a full filename or a part of the filename;
3. Click the **Find** button;
4. Double left-click on the required record in the list of results:
To open any of the ten last used documents:

1. Activate **Writer**;
2. Execute the **File**→**Recent Documents** menu command;
3. Select a document from the list:

**Inserting Tables in a Document**

**Changing Basic Settings of an Application**

During the installation of the computer system, it is possible to adjust various additional settings – such as the keyboard language or locale settings – or accept the system defaults. Some applications may also allow adjusting settings during installation. The basic settings determine the system of measurement used with the application; it can differ from the one used by the operating system. It is also important to know whether the decimal mark is a point or a comma – e.g., Ls 2,65 or Ls 2.65.

**Note!**

Before entering numerical values in a dialogue box, e.g., when setting column width, make sure that the correct unit of measurement and decimal mark are used.
Like the other applications in the OpenOffice.org suite, **Writer** also uses many settings determining the default operation of the programme.

Frequently used basic settings are:

- Default save folder for documents;
- Units of measurement for dialogue boxes;
- The name of the programme user. It is displayed in file properties and can be inserted into a document as a separate field.

**To modify the basic settings of Writer:**

1. Open the Options (basic settings) dialogue box with the **Tools→Options** command;
2. Expand the **OpenOffice.org Writer** menu:
   
   ![Options menu](image)

3. Perform changes in the dialogue box.

**To change the default save folder in the Options dialogue box:**

1. Open the options (basic settings) dialogue box;
2. Expand the **OpenOffice.org** list;
3. Select the **Paths** dialogue box;
4. In the window **Paths used by OpenOffice.org**, select the location of the **My documents** folder;
5. Click the **Edit** button:
6. Specify the new save location of the document.

To modify the units of measurement used in the application:

1. Open the basic settings dialogue box;
2. Expand the OpenOffice.org Writer list;
3. Choose the General dialogue box;
4. Select units of measurement in the Settings pane in the dialogue box:

![Image of General settings dialogue box]

To modify user data:

1. Open the basic settings dialogue box;
2. Expand the OpenOffice.org list;
3. Choose the User Data dialogue box;
4. Fill in/register fields in the dialogue box:
   4.1. First/Last name/Initials – to give user’s name, last name, initials;
   4.2. Company – to specify the work place:

![Image of User Data dialogue box]

To modify the decimal separator:
1. Perform the **Tools**→**Options** menu command in the application window;
2. Expand the **Language Settings** menu;
3. Select **Languages**;
4. In the checkbox **Language of**:
   4.1. In the **Locale setting** menu, choose the state:
   4.2. Confirm the selection by clicking the **OK** button in the dialogue box.

---

### Tables

Tables are used to show structured data in a text document. Text, numbers and paragraphs can be inserted in any cell of the table. In **Writer**, all the table commands are located in the **Tables** menu.

#### Inserting a Table

**To insert a table in a document:**

1. Position the insertion point to locate a table in the document;
2. Execute the **Table**→**Insert**→**Table** command:
3. Specify the number of **Columns** and the number of **Rows** in the corresponding fields;
4. Specify additional options, if necessary:
   4.1. The **Name** of the table;
   4.2. Repetition of column names on each page (for a long table):
      4.2.1. Tick the **Heading** checkbox.
   4.3. Choose formatting from the available options by clicking the **Autoformat** button.
5. Confirm the changes with the **OK** button:
Applying Changes to a Table

A table with all columns of equal width is typically inserted in a document, and the table occupies the entire width of the page between the margins; the row height is set by the font size.

A reference point must be set for cell formatting, inserting or deleting rows or columns – by positioning the insertion point in the respective cell, a row or a column or selecting the corresponding cells.

To modify the column width (row height):

1. Position the mouse pointer on the outline of the column (the row) border;
2. Left-click;
3. While holding down the button, drag to the required direction;
4. Release the mouse button:

To move columns (rows):

1. Place the insertion point in a cell of a column;
2. Execute the Table→Insert→Columns (Rows) menu command;
3. In the Insert Columns (Rows) dialogue box, specify:
   3.1. The Number of columns (rows);
   3.2. The position of placing, e.g., before or after the location of the insertion point in the table.
4. Click the OK button.

To delete columns (rows):

1. Position the insertion point in a cell of a column (row);
   or
1. Select cells of the table;
2. Perform the Table→Delete→Columns (Rows) menu command.

To delete the entire table:

1. Position the insertion point in any cell of the table;
2. Execute the Table→Delete→Table menu command.

Note!
By deleting a table or parts thereof, all the data in the respective cells are also deleted.

Selecting Cells
To perform any actions with cells or their objects, they must first be selected. This is similar to text selection in a document. The selected cells or the insertion point will indicate the place you wish to perform any action.

To select the entire column of the table:
1. Hover the mouse pointer above a column of the table, until an arrow appears;
2. Left-click:

Formatting a Table

Formatting a table can be done best with the aid of buttons of the Table toolbar. It appears automatically when the insertion point is placed in the table. If the table toolbar does not show, open the toolbar with the View→Toolbars→Table menu command.

To apply formatting to a table:
1. Place the insertion point in a cell (in a row, in a column) or select cells;
2. Execute formatting commands in the Table toolbar.

To specify additional formatting properties:
1. Place the insertion point in the table;
2. Click the properties button in the Table Properties toolbar;
   or
2. Execute the Table→Table Properties menu command;
3. In the **Table Properties** dialogue box, open the corresponding tab by clicking on its name;
4. Specify formatting;
5. Close the dialogue box by clicking the **OK** button.

![Image 5: Specifying the column width in the units of measurement in the Table Format dialogue box](image)

**Tabs**

Tabs help arranging data in a way they are placed in a table. By pressing the Tab key on the keyboard, the insertion point moves forward to the next tab stop.

Useful tip

Before setting tab stops, choose your desired units of measurement for the ruler.

**To choose the units of measurement for the ruler:**

1. In the **Writer** window, right-click on the ruler:
2. Choose a unit of measurement in the right-click menu:
To adjust tab stops:

1. In the **Writer** window, position the mouse pointer on the ruler;
2. Left-click;
3. Repeat actions.

By clicking the mouse button, tab stops are set and displayed on the ruler. They can be freely moved.

To transfer tab stop:

1. Left-click on the tab stop;
2. While holding down the mouse button, drag to the required direction;
3. Release the mouse button in the new required location:

```
  1  2  3  4  5  6
```

Additional properties of tab stops can be set under the **Tabs** in the **Paragraph** dialogue box.

To specify additional properties for tab stops:

1. Open the **Paragraph** dialogue box:
   1.1. Double left-click on the ruler in the margin area;
   or
   1.1. Execute the **Format**→**Paragraph** menu command.
2. Left-click on the **Tabs**;
3. In the **Position** pane, choose the tab stop;
4. In the value field, enter the area from the margin in the units of measurement;
5. In the **Type** pane, specify the alignment of the tab stop against the text:
   5.1. Left-click and select to the left, to the right, centre, in the place of the decimal separator:

```
<table>
<thead>
<tr>
<th>First stop</th>
<th>Second stop</th>
<th>Third stop</th>
<th>Fourth stop</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sun</td>
<td>Moon</td>
<td>Earth</td>
<td>Mars</td>
</tr>
</tbody>
</table>
```

6. In the **Fill character** pane, choose the fill between the text in tab stops;
7. Confirm the selection by clicking the **OK** button:
To use tab stops:

1. Arrange tab stops on the ruler in the **Writer** window;
2. Under **Tabs** in the **Paragraph** dialogue box, set additional tab stop properties, if necessary;
3. Enter the following data:
   3.1. Place the insertion point at the beginning of the line;
   3.2. Press the **Tab** key on the keyboard;
   3.3. Enter text;
   3.4. Press the **Tab** key on the keyboard to switch to the next tab stop;
   3.5. Repeat actions until the last tab stop is reached.
4. Press the **Enter** key on the keyboard to start a new line.

To delete a tab stop:

1. Place the mouse pointer above the corresponding tab stop;
2. Left-click;
3. While holding down the mouse button, drag the tab stop to the margin area of the ruler;
4. Release the mouse button.

**Task 3.4. Change the units of measurement of the system and the decimal separator.**

Create a table with data in the document. Use tab stops for data arranging.

1. Change units of measurement used in the application to centimetres:
   1.1. Activate the **Writer** application:
      1.1.1. Perform the **Applications**→**Office**→**OpenOffice.org Word Processor** menu command in the top panel of the desktop.
   1.2. Execute the menu command in the programme window **Tools**→**Options**;
   1.3. Expand the **OpenOffice.org Writer** menu result list:
      1.3.1. Click on the black triangle before the **OpenOffice.org Writer**.
   1.4. To select the **General**, left-click on it;
1.5. In the Measurement unit menu in the Settings pane, select Centimeter (if changing is necessary):

2. To continue, change the decimal separator to a comma (,):
   2.1. Expand the Language Settings record:
       2.1.1. Click on the black triangle before Language Settings.
   2.2. Left-click on Languages;
   2.3. In the Locale setting menu (in the Language of pane), choose Latvian;
   2.4. Confirm the changes by clicking the OK button in the dialogue box.

3. Enter data in a table:
   3.1. Create a table with three columns and four rows:
       3.1.1. Execute the Table->Insert->Table menu command;
       3.1.2. In the Insert Table dialogue box, specify the number of columns in the table:
           3.1.2.1. Select the text in the Columns field;
           3.1.2.2. To replace the existing number, enter 3.
       3.1.3. Specify the number of rows:
           3.1.3.1. Increase the number of rows to 5 by clicking on the upward arrow next to the Rows field:
   3.2. Set the first row of the table as the column headings:
       3.2.1. Left-click to tick the Heading checkbox:
       3.3. Confirm the insertion of the table by clicking the OK button in the dialogue box.

4. Enter the given data:

<table>
<thead>
<tr>
<th></th>
<th>Last year</th>
<th>This year</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peaches</td>
<td>23</td>
<td>3</td>
</tr>
<tr>
<td>Apples</td>
<td>56</td>
<td>67</td>
</tr>
<tr>
<td>Plums</td>
<td>Not at all</td>
<td>5</td>
</tr>
<tr>
<td>Oranges</td>
<td>2</td>
<td>67</td>
</tr>
</tbody>
</table>

4.1. Position the mouse pointer in a cell;
4.2. Left-click;
4.3. Enter the text.
5. Add the heading to the table:
   5.1. Place the insertion point in the first cell of the table;
   5.2. Press the Enter key on the keyboard;
   5.3. Enter the text Harvest report;
   5.4. Center the heading:
   5.4.1. Click the Centered button in the toolbar.
6. Insert two more rows in the table:
   6.1. Move the insertion point to any cell in the bottom row of the table;
   6.2. Perform the Table→Insert→Rows menu command;
   6.3. In the Number field in the Insert Rows dialogue box, enter 2 for rows;
   6.4. Check if the position After is selected;
   6.5. Click the OK button.

Useful tip
To insert the next row in a table, place the insertion point in the last cell of the table and press the Tab key on the keyboard.

7. Enter the word autumn in the last cell;
   7.1. Left-click to position the insertion point in the last cell;
   7.2. Enter the text.
8. Apply yellow colour to the last column of the table:
   8.1. Select the last column of the table:
   8.1.1. Hover the mouse pointer above the column, until a black arrow appears;
   8.1.2. Left-click:
   8.2. Click the Background Color button in the table toolbar:
   8.3. Choose the Yellow colour.
9. Place borders of a red dotted line to the cells of the table:
   9.1. Select all the cells of the table:
   9.1.1. Position the insertion point in the last cell of the table;
   9.1.2. Left-click;
   9.1.3. While holding down the mouse button, drag the mouse pointer to the first cell of the table;
   9.1.4. Release the mouse button.
   9.2. Select a dotted line:
   9.2.1. In the table toolbar, click Line Style button;
   9.2.2. Select a dotted line 9 pt:
9.3. Select the red colour for borders:
   9.3.1. Click the Line Color button in the table toolbar;
   9.3.2. Select Light red:

10. Place a border of a double blue line with shading around the table:
    10.1. Proceed with the previous task and check if the insertion point is placed in the cell of the table;
    10.2. Perform the Table→Table Properties menu command;
    10.3. In the Table Format dialogue box, left-click on the Borders tab to open it;
    10.4. In the Line arrangement pane, select the Set Outer Border Without Changing Inner Lines option:
    10.5. In the Line Style pane, select a double line 2.60 pt;
    10.6. In the Color menu, select Black;
    10.7. Apply shading:
    10.7.1. Select the Shadow style Cast Shadow to Top Right option:
    10.8. Confirm changes by clicking the OK button in the dialogue box;
10.9. If you wish to cancel the selection, left-click in the table.

11. Delete the sixth row in the table:
   11.1. Position the insertion point in the sixth row of the table;
   11.2. Perform the Table->Delete->Rows menu command.

12. Set 5 cm width to the last column of the table:
   12.1. Check if the insertion point is placed in the last column of the table;
   12.2. Execute the Table->Table Properties menu command;
   12.3. In the Table Format dialogue box, left-click on the Columns tab to open it;
   12.4. Reduce the width of the third column:
      12.4.1. Reduce the column width to 5 cm:

12.5. Confirm changes by clicking the OK button in the dialogue box.

13. Increase the height of the first row of the table:
   13.1. Position the mouse pointer on the bottom border of the first row of the table;
   13.2. Left-click;
   13.3. While holding down the mouse button, drag down;
   13.4. Release the mouse button:

14. Create tab stops:
   14.1. Position the insertion point below the table;
   14.2. Press the Enter key on the keyboard;
   14.3. Left-click on the horizontal ruler at the numbers 2, 6 and 11;
   14.4. Enter data:
      14.4.1. Press the Tab key on the keyboard;
      14.4.2. Enter the word Planets;
      14.4.3. Press the Tab key;
      14.4.4. Enter the word Moon;
      14.4.5. Press the Tab key;
      14.4.6. Enter the word Earth;
      14.4.7. Press the Enter key on the keyboard;

14.4.8. Repeat the actions for other data:

15. Adjust the first tab so that the text is centred against the mark on the ruler:
15.1. Perform the Format->Paragraph menu command;
15.2. Open Tabs of the Paragraph dialogue box by clicking on it;
15.3. In the Position pane, select the first tab stop;
15.4. In the Type pane, select Centered;
15.5. Confirm the selection by clicking the OK button.

16. In the first tab stop, enter the word Constellations:
   16.1. Make sure that the insertion point is placed at the beginning of a new line;
   16.2. Press the Tab key on the keyboard;
   16.3. Enter the word Constellations;
   16.4. Press the Tab key on the keyboard;
   16.5. Enter the word Orion:

   Satellites   Astra
   Constellations   Orion

17. Delete the tab stop:
   17.1. Position the mouse pointer on the ruler on the last tab stop;
   17.2. Left-click;
   17.3. While holding down the mouse button, drag the tab stop to the margin area;
   17.4. Release the mouse button.

18. Save the document under the name Harvest:
   18.1. Perform the File->Save menu command;
   18.2. In the Name field in the Save dialogue box, enter the word harvest;
   18.3. Confirm saving by clicking the Save button.

**Inserting Pictures and Other Objects**

**Pictures**

Pictures can be added to a text document.

**Note!**

Using a large number of high-quality (high-resolution) pictures in a document increases its file size and may cause problems when attempting to e-mail the file, publish it online or save it to a data storage device.

**Inserting a Picture**

OpenOffice.org Writer allows inserting pictures of various formats in documents.

Frequently used picture formats:

- JPG, JPEG – used for photos, a universal picture format;
- GIF – pictures with a small colour palette;
- PNG – a picture format commonly used online;
- BMP – a universal picture format, often with a large file size;
- WMF – a graphics file format in Windows systems.

To insert a picture from a file:

1. Place the insertion point in the document;
2. Execute the Insert->Picture->From File menu command;
3. Find the picture file in the file system;
4. Select a picture file;
5. In the Insert Picture dialogue box, click the Open button.

Selecting Pictures

To perform any action with a picture or other object, it must first be selected.

To select a picture (object):

Click on a picture (object).

Resizing, Moving and Deleting a Picture (an Object)

Upon selecting a picture or other object, a frame with eight points called handles appears around it. The picture can be resized by using these handles. Other objects are also handled similarly.

To resize a picture:

1. Left-click on a picture to select it;
2. Click on any handle;
3. While holding down the mouse button, drag until the necessary size is achieved;
4. Release the mouse button:

   ![Resizing a picture diagram]

   **Useful tip**

   To retain picture proportions, press and hold down the **Shift** key while resizing the picture.

To move a picture:

1. Left-click on a picture;
2. While holding down the button, drag the picture to a new location:
To delete an object:

1. Select an object, e. g., a picture, a chart, a drawn object;
2. Press the **Delete** key on the keyboard.

**Drawn Objects**

In the **Writer** application, text documents can be supplemented by drawn objects. Drawing is easiest by using the **Drawing** toolbar.

**To open the drawing toolbar:**

Click the **Show Draw Functions** button in the **Standard** toolbar;

or

Perform the **View**→**Toolbars**→**Drawing** menu command;

or

Click the **Show Draw Functions** button in the **Standard** toolbar:

The drawing toolbar contains many features; it is difficult to list – let alone memorize – all of them. Toolbar button labels can aid with this. Many toolbar buttons have additional menus, which are indicated by a black triangle next to the button:
stars; N – edit and create shape deformation points; O – create stylized text; P – insert an object from a file; R – apply extrusion effect to a shape

*Image 6 Drawing toolbar with the Bultas menu opened*

**To draw an object:**

1. Activate the drawing toolbar;
2. Select an object by clicking the button in the toolbar;
3. Place the mouse pointer in the document;
4. Left-click;
5. While holding down the mouse button, drag it until the desired size is achieved;
6. Release the mouse button.

A drawn object can be moved or resized the same as a picture.

**Charts**

**Inserting a Chart**

A chart is a graphical representation of numeric data. By modifying the chart data, the chart changes, as well. In *Writer*, data for creating a chart must be entered into a separate table.

*To insert a chart in a document:*

1. The place where to insert the chart is selected by left-clicking to position the insertion point in the document;
2. Execute the Insert→Object→Chart menu command.

Double-click to make the OpenOffice.org *Writer* toolbar and the menu bar change its appearance and show as a chart toolbar with typical buttons and commands when the chart is inserted in a document or when it is selected. The initial data are shown in the chart and they must be changed in the data table.
To open a chart data table:

1. Activate chart toolbars, if necessary:
   1.1. Double-click on a chart.
2. Open the data table:
   2.1. In the Formatting toolbar, click the Chart Data Table button:

or

2.1. Perform the View→Chart Data Table command;
3. Enter data in the table:

The above example shows the space used by multimedia files on a computer’s file system, split by months:
- **MP3** – music files in a compressed format;
- **AVI** – video files;
- **JPEG** – pictures;
- **ODP** – OpenOffice.org Impress presentations.

The data depiction in columns of a table (bars, lines, sectors) is called data series. The first column **Categories** is typically used to enter the categories for comparison – months, in this example.

The number of rows and columns in a table can be changed in the data table toolbar:

A – add a row; B – add a data series; C – delete a row; D – delete a data series; E – move a data series to the right; F – move a row down

Image 7 Editing a data table of a chart

To change a chart type:

1. Activate chart toolbars, if necessary:
   1.1. Double left-click on a chart.
2. Open the chart type selection dialogue box:
   2.1. Execute the Format→Chart Type menu command;
or

2.1. Click the Chart Type button in the chart toolbar:

![Chart Type button](image)

3. In the Chart Type dialogue box, select a chart type:

![Chart Type dialogue box](image)

### Copying

Text does not always have to be written anew. Often there are ready materials available in other documents, applications or websites. Text and other objects in electronic form can be copied and pasted, which saves the user’s time.

The copying action is universal and can be similarly used in other operating systems and applications. Apart from texts, users can copy files, pictures, folders, documents.

Four actions must be executed to execute the copy function. If any of them is not performed or is wrong, copying cannot be completed.

**To re-use any object:**

1. Select an object, a text area to be copied;
2. Perform the copy command using any method you know:
   - Perform the Edit→Copy menu command (to copy);
   - Perform the Copy command in the right-click menu, by right-clicking on an object (an area of selected text);
   - Press the Ctrl key on the keyboard and while holding it down, press the C key, using the Ctrl+C key combination.
3. Select the new location for the object to be copied:
   - 3.1. Open the document file;
   - 3.2. Left-click in the new location to position the insertion point;
4. Perform the paste command using any method you know:
   - Execute the Edit→Paste menu command;
   - Execute the Paste command in the right-click menu, by right-clicking on an object;
Press the **Ctrl** key on the keyboard and while holding it down, use the **Ctrl+V** key combination.

When text is copied from another source, e.g., from a website, default copying will be done and text will retain its original formatting – colour, layout and division into paragraphs, hidden characters used for the web content will be retained.

**To paste text only:**

1. Select the text to be copied;
2. Copy it;
3. Position the insertion point in the new location to paste the selected text;
4. Execute the **Edit->Paste Special** menu command;
5. In the **Paste Special** dialogue box, select **Unformatted Text**;
6. Confirm the selection:

![Unformatted Text][1]

**Task 3.5. Create a document and copy text and a picture. Create a chart. Insert a picture from the file.**

1. Create a new document:
   1.1. Activate the application **Writer**:
      1.1.1. Execute the **Applications->Office->OpenOffice.org Word Processor** menu command.
   1.2. Save the created document under the elements.odt name:
      1.2.1. In the **Standard** toolbar, click the **Save** button;
      1.2.2. In the **Name** field in the **Save** dialogue box, enter the filename elements;
      1.2.3. In the dialogue box, click the **Save** button.
2. In the new document, copy text from other document without saving formatting:
   2.1. Open the text.odt document in the **3.5_objects** subfolder of the **3_text_processing** folder:
      2.1.1. Execute the **Places->Documents** command in the top folder of the desktop;
      2.1.2. Double left-click on the **3_text_processing** folder to open it;
      2.1.3. Select the **3.5_objects** folder;
      2.1.4. Press the **Enter** key on the keyboard;
      2.1.5. Select the **text.odt** document file;
      2.1.6. Press the **Enter** key on the keyboard, do not close the folder.
   2.2. Select the entire text in the document:
      2.2.1. Press the **Ctrl** key on the keyboard;
      2.2.2. While holding down the **Ctrl** key, press the **A** key on the keyboard;
      2.2.3. Release the keys.
   2.3. Copy the text in the new document:
      2.3.1. Perform the **Edit->Copy** menu command;
      2.3.2. Open the box of the created document:
2.3.2.1. Click on the elements.odt button in the document window in the top panel of the desktop:

2.3.3. Execute the Edit->Paste Special menu button;
2.3.4. In the Paste Special dialogue box, select Unformatted text;
2.3.5. Click the OK button.

3. Insert a picture from the file:
3.1. Place the insertion point at the end of the first paragraph;
3.2. Execute the Insert->Picture->From File menu command;
3.3. In the Insert Picture dialogue box:
3.3.1. In the Places pane, select the Documents folder;
3.3.2. Double left-click to open the 3_text_processing folder;
3.3.3. Double left-click to open the 3.5_objects folder;
3.3.4. Select the picture file photo.jpg;
3.3.5. In the dialogue box, click the Open button.
3.4. Reduce the picture size:
3.4.1. Position the mouse pointer on the handle in the bottom right corner of the picture;
3.4.2. Press the Shift key on the keyboard;
3.4.3. Left-click on the handle;
3.4.4. While holding down the keys, drag diagonally upwards, until the corresponding size is reached;
3.4.5. Release the mouse button and the keys.
3.5. Move the picture to the upper right corner of the document:
3.5.1. Left-click on the picture;
3.5.2. While holding down the mouse button, move the picture;
3.5.3. Release the mouse button.

4. Copy a picture from other document, specify its size in units of measurement:
4.1. Open the text file mouse.odt:
4.1.1. Open the 3.5_objects folder:
4.1.1.1. Click on the button of the file browser window in the top panel of the desktop:
4.1.2. Right-click on the mouse.odt file;
4.1.3. Perform the Open With OpenOffice.org Word Processor command in the right-click menu:
4.2. Right-click on the picture in the document;
4.3. Perform the Copy command in the right-click menu;
4.4. Switch back to the file elements window:
4.4.1. Perform the Window->elements. odt- OpenOffice.org Writer menu command.
4.5. Position the insertion point at the beginning of the third paragraph;
4.6. Perform the Edit->Paste menu command;
4.7. Perform the Format->Picture menu command;
4.8. In the Picture dialogue box:
   4.8.1. Click on the Type tab to open it, if necessary;
   4.8.2. In the Size checkbox, tick Keep ratio;
   4.8.3. In the Height field, select the field value;
   4.8.4. Set picture height to 2.6 cm:

![Picture Size Dialogue Box]

4.8.5. Open the Wrap tab by clicking on its name;
4.9. In the Settings pane, select the wrapping option Parallel:

![Parallel Wrap]

4.9.1. In the dialogue box, click the OK button to confirm changes.

5. Save changes to the document:
5.1. Click the Save button in the Standard toolbar.

6. Insert a chart:
6.1. Position the insertion point at the end of the text;
6.2. Execute the command in the Insert-Object-Chart menu;
6.3. Increase the chart size to the margins:
   6.3.1. Left-click on the handle in the corner of the chart;
   6.3.2. While holding down the mouse button, drag it until the desired size is achieved;
   6.3.3. Release the mouse button.
6.4. Execute the command in the Edit-Object-Edit menu;
6.5. Enter the chart data:
   6.5.1. Click the Chart Data Table button in the chart toolbar:

![Chart Data Table]

6.5.2. Delete the last column:
   6.5.2.1. Left-click in the cell of the last column;
   6.5.2.2. Click the Delete Series button in the toolbar of the dialogue box:

![Delete Series]

6.5.3. Click in the last row:
   6.5.3.1. Click the Delete Row button:
6.6. Enter new data in the table by replacement:

<table>
<thead>
<tr>
<th>Categories</th>
<th>Y-Values</th>
<th>Y-Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2001</td>
<td>10</td>
</tr>
<tr>
<td>2</td>
<td>2002</td>
<td>5</td>
</tr>
<tr>
<td>3</td>
<td>2003</td>
<td>6</td>
</tr>
</tbody>
</table>

6.6.1. Select the cell value;
6.6.2. Replace them with the data from the table;
6.6.3. Repeat this action in all the cells.

6.7. By clicking on the Close button, close the Data Table dialogue box:

6.8. Change the chart type:
   6.8.1. Click the Chart Type button in the chart toolbar:
   6.8.2. Tick the 3D Look;
   6.8.3. Click the OK button.

7. Left-click anywhere outside the chart area;
8. Insert the Star shape below the chart:
   8.1. If required, open the drawing toolbar:
      8.1.1. In the Standard toolbar, click the Show Draw Functions button:
   8.2. In the drawing toolbar, open the Star button menu:
      8.2.1. Click on the black triangle at the button;
   8.3. Select the 8-Point Star:
      8.4. Left-click in the document under the chart;
   8.5. While holding down the left mouse button, draw up a star;
   8.6. Release the left mouse button.

9. Save changes and close the document:
   9.1. Click the Save button in the toolbar;
   9.2. Execute the File->Close menu command.

10. Close other opened windows:
    10.1. Click the Close button in the title bars of the windows.

Mail Merge
Mail merge is used when it is necessary to mail letters of similar content as a printed document or e-mail message. Most workplaces use personal electronic address books on each user’s computer or shared address books for the entire institution, organization or company. For example, a company will most likely have a catalogue of the employees’ mail and e-mail addresses, as well as of customers. E-mail clients usually also have a built-in address book. These stored contacts can be used for mail merge.

The necessary items

- Main document – it is possible to create a new document or use an existing one;
- Address database – it is possible to use an existing database (address book) or create a new list of recipients;
- Data fields must be entered in the main document, corresponding to the list of recipients.

**Writer** will insert the recipient’s data, taken from the respective address book record, in the corresponding fields in each document. The applications of the OpenOffice.org suite, including **Writer**, support various types of databases – spreadsheets, **Base** files, tables of comma-separated values (**CSV** format), text files, and many other file formats.

Data is stored in an address book (or any other type of database) in the form of individual records. Each record has corresponding fields – column headers – for data entry; e.g., first name, last name, workplace, and address:

<table>
<thead>
<tr>
<th>Title</th>
<th>First Name</th>
<th>Last Name</th>
<th>Company Name</th>
<th>Address Line 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mr.</td>
<td>Elton</td>
<td>Silver</td>
<td>Fast Goods</td>
<td>Trafalgar Square 2</td>
</tr>
<tr>
<td>Mrs.</td>
<td>Elen</td>
<td>White</td>
<td>Plum</td>
<td>Abbey Road 34-45</td>
</tr>
<tr>
<td>Mr.</td>
<td>James</td>
<td>Bond</td>
<td>MI 6</td>
<td>Hidden Str. 67-9</td>
</tr>
<tr>
<td>Dr</td>
<td>Alfred</td>
<td>Doolitle</td>
<td>Health Investigation Fruit Str. 567</td>
<td></td>
</tr>
</tbody>
</table>

**Useful tip**

Fields are special areas in a document where the application inserts the corresponding data, for example, the page number. In **Writer**, fields can be recognized by their grey background:

This is automatically inserted page number: 1.
And this is today's date: 11/04/11

### Mail Merge by Using a Wizard

**Writer** has a wizard that makes mail merging easier.

**To use mail merge in Writer with the help of a wizard:**

1. Activate **Writer**:
   1.1. Open an existing text document file;
   or
   1.1. Prepare a document with the main text to be mailed (printed).
2. Open the mail merge wizard with the **Tools→Mail Merge Wizard** menu command;
3. Go through eight steps in the wizard, clicking **Next** at the end of each:
   3.1. Select a starting document – use the current document, open an existing
document, or create a new one:
   
   ![Select starting document for the mail merge](image)

   3.2. In the next step, select the document type: letter or e-mail message:
   
   ![Select a document type](image)

   3.3. In the third step, select the address list and address block layout:
   
   3.3.1. Select a database file on the computer;
   
   3.3.2. Select an address block layout from the available templates or create your
   own;
   
   3.3.3. Match the record fields in the address block;
   
   3.3.4. Preview the address block of each document.

   3.4. Create a salutation in the next step;
   
   3.5. In the fifth step, adjust the layout of the address block, if necessary;
   
   3.6. The sixth step allows going back to the main document and editing it. The
   changes will apply to the documents of all recipients;
   
   3.7. In the next step, it is possible to personalize each individual document
   separately, if necessary;
   
   3.8. The mail merge is finished in the eighth and final step – by saving, printing or e-
   mailing the document.

   **Note!**
   To send the prepared e-mail messages by using mail merge, the sender must specify an
   existing e-mail address and must know the outgoing mail server address.

**Mail Merge with Inserting Fields**

The wizard offers existing templates, e.g., an existing address block with fields included
from an address book. In practice, it is often more convenient to create an address and a
salutation block by yourself, by inserting fields from an address database in a text
document.
Actions to perform:

- Register a database for **Writer** to be able to use it. As a result of the registration, a special link to the database or a file containing the data is created in the **Documents** folder of the user account.
- Create fields in the body of the document.

**To perform mail merge:**

1. Open the prepared document or create a new one;
2. Register an existing list of recipients (database) for the use in the **OpenOffice.org** suite:
   2.1. Perform the menu command **File→Wizards→Address data Source**;
   2.2. In the first step of the wizard, select the database type, in this case – **Other external data source**:

   ![Database Type Selection](image)

   2.3. In the next step, click the **Settings** button:
   2.3.1. Select a database type:

   ![Database Type Settings](image)

   2.3.2. Depending on the selected database type, in the next step, specify the file location or the database server address;
   2.3.3. Finish the registration of the database.
3. Match the database with the standard fields of the **OpenOffice.org** address book – click on **Field Assignment** button:
   2.4.1. Assign the fields by using the menus: **OpenOffice.org** address book field → database field:

   ![Field Assignment](image)

   2.4.2. Confirm the selected fields – click the **OK** button;
   2.5. Enter the **Address book name** in the respective field and finish the wizard.
4. In the **Writer** window, perform the menu command **View→Data Sources**;
4. Expand the address data source by clicking on the black triangles:

5. Drag the data field labels – column headers – to the body of the document:

6. Perform the File−Print menu command;
7. Confirm that you wish to print a form letter;
8. In the Mail Merge dialogue box:
   8.1. Choose the output: Printer or File;
   8.2. Select All records, or a From−To range of records in the address book;
   8.3. Click the OK button.
9. Print by using the standard Print dialogue box.

Labels

Labels are useful for specifying the mailing addresses on envelopes. In this case it is also convenient to use the previously registered address database.

**Note!**
The special label paper consists of sheets already divided into labels. When preparing and printing labels, the brand and type of labels specified in the application must match those specified on the packaging of the paper. Otherwise the printed text will not properly fit inside the labels.

To print mailing labels:

1. Open Writer;
2. Perform the File→New→Labels menu command;
3. Open the Options tab of the dialogue box and tick the Synchronize Contents checkbox. This will allow adjusting existing labels:
4. In the **Labels** tab of the dialogue box, select the label format:
   4.1. Select the **Brand** and **Type** in the respective menus, for example, label paper **L7560 Clear Address** of the **Avery A4** brand:

5. Select the fields to be placed in the label from the database:
   5.1. In the **Database** menu, select the registered address source;
   5.2. In the **Table** menu, select the table of the database (if there are several);
   5.3. Create the label fields:
      5.3.1. In the **Database field** menu, select a field to be placed in the label;
      5.3.2. Click the corresponding button to insert it in the label;
      5.3.3. If necessary, place the insertion point in the label at the end of the field in the label and press the **Enter** key on the keyboard;

   **Useful tip**

   When preparing the label text, it can be supplemented with text entered with the keyboard, and it is possible to insert additional punctuation marks.

   5.3.4. Repeat the above steps until the content of the label is ready:

6. Create a new **Writer** document by clicking the **New Document** button;
7. If necessary, change the appearance of the label:
   7.1. Adjust the layout of fields in the first label, add text, punctuation marks;
   7.2. Click **Synchronize labels**. The button will not appear if the corresponding checkbox was not ticked when creating the labels (step 3):
Module 3

8. Execute the **File−Print** menu command;
9. Confirm that you wish to print a form letter;
10. In the **Mail Merge** dialogue box:
    10.1. Choose the output: **Printer** or **File**;
    10.2. Select All records, the selected records, or a From−To range of records in the address book;
    10.3. Click the **OK** button.
11. Print by using the standard **Print** dialogue box.

**Spellchecking**

OpenOffice.org applications have the built-in spell check option and this is used the same way as in OpenOffice.org suite. Spell check compares the entered words which are separated by spaces with the dictionary words. The misspelled words are underlined with a red wavy line and the underline is not printed.

The default option **Check spelling as You type** in the basic settings is turned on in OpenOffice.org applications and the entered words or words that have been in the text are underlined in red if not matching with the suggestions by the dictionary.

**To correct the misspelled words:**

1. Right-click on the underlined word;
2. In the menu, click on the suggestion of the right word:

![Spellcheck Example](apple.png)

Depending on the applications of the operating system, spell check can be executed by various software parts. **Writer** uses the default **Hunspell/Myspell** module for spell check.

**Note!**

To perform spell check in specific language, a corresponding dictionary must be installed on the computer. Software installation is described in Module 2.

**To perform spell check in the default language of the document:**

1. Press the **F7** functional key on the keyboard;
2. In the **Spelling** dialogue box:
   2.1. View the word displayed in red;
   2.2. Select a word from the dictionary in the **Suggestions** pane;
   2.3. Click the **Change** button;
   2.4. Repeat the above steps to correct other misspelled words.
To add a word to the dictionary:

1. Right-click on the underlined word in the text;
2. Perform the Add→Standard.dic command in the right-click menu.

To change spell check language:

1. Press the F7 key on the keyboard;
2. In the Text language menu of the Spelling dialogue box, change the text language:
3. Perform spell check and correct the spotted word.

To change the language of the entire document or of its part:

1. In the Tools→Language window, perform the menu command by choosing the necessary option:
   - For Selection – for the selected text;
   - For Paragraph – for the selected paragraph;
   - For All Text – for the entire text of the document.
2. Select any of the available dictionaries:

   ![Language and Spell Check Window](image)

   **Useful tip**

   Language of the document or the selected text is seen in the Writer status bar:

   ![Writer Status Bar](image)

Task 3.6. Prepare a letter to be sent to several recipients. Perform spell check. Use the existing mailing list. Create labels with the recipient’s name.

1. Open the flint.odt text file:
   1.1. Perform the Places→Search for Files menu command in the top panel of the desktop;
   1.2. In the Name contains field of the dialogue box, enter flint;
   1.3. Click the Find button in the dialogue box;
   1.4. Double left-click on the file flint.odt that has been found.
2. Apply spell check to the text:
   2.1. Perform the Tools→Spelling and Grammar menu command;
   2.2. Correct the misspelled words in the text:
      2.2.1. In the Not in dictionary pane of the Spelling: English (UK) dialogue box, view a word underlined in red;
      2.2.2. In the Suggestions pane, left-click on the right version of the word to select it;
      2.2.3. Click the Change button in the dialogue box;
2.2.4. Repeat the above steps to correct the misspelled words up to the author’s last name Flintos:

![Spelling correction tool](image)

2.3. Add the author’s last name to the dictionary:
2.3.1. Click the Add button;
2.3.2. Select the Standard (All) dictionary.

2.4. Replace the word Chaitmen with Chairmen:
2.4.1. Click the Change button.

2.5. In the dialogue box, confirm the end of the spell check by clicking OK.

3. Register a database:
3.1. Execute the File->Wizards->Address Data Source menu command;
3.2. In the dialogue box, select Other external data source;
3.3. Click the Next button in the dialogue box;
3.4. Click the Settings button in the next step. In the Create Address Data Source dialogue box, select a spreadsheet – a file of the address list:
3.4.1. In the Database type menu, select Spreadsheet;
3.4.2. Click the Next button;
3.4.3. In the next step Database properties – Connection settings, click the Browse button;
3.4.4. In the Places pane of the Open dialogue box, select the Documents folder, if necessary;
3.4.5. Select the 3_teksapstrade folder;
3.4.6. Press the Enter key on the keyboard;
3.4.7. Select the 3.6_mail folder;
3.4.8. Press the Enter key on the keyboard;
3.4.9. Select the address_list.ods file;
3.4.10. Click the Open button;
3.4.11. Click the Finish button.

3.5. In the fourth step, click the Field Assignment button:
3.5.1. Match the address database fields with the fields of the OpenOffice.org suite in accordance with the table menus of the Field assignment pane:

<table>
<thead>
<tr>
<th>OpenOffice.org Field</th>
<th>Mailing list field in the menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Title</td>
</tr>
</tbody>
</table>
Module 3

| First Name | First Name |
| Last Name  | Last Name  |
| Company    | Company Name |
| Street     | Address Line 1 |
| City       | City        |
| State      | State       |
| Country    | Country     |
| ZIP Code   | ZIP         |
| E−Mail     | E−mail Address |

3.5.2. Click the OK button:

3.6. In the Address book name field of the Address Source Wizard dialogue box, enter the name of the data source Mailings;

3.7. Click the Finish button.

4. Create a main document:

4.1. Perform the View→Data Sources menu command;

4.2. Expand the Mailings:

4.2.1. Click on the black triangles:

4.3. Left-click in the beginning of the document;

4.4. Enter Dear;

4.5. Insert space;

4.6. Insert the fields for salutation, name and last name in the document:

4.6.1. Left-click on the name of the field – the Title column name in the opened address base;

4.6.2. While holding down the mouse button, drag it to the document:
4.6.3. Insert space after the field;
4.6.4. Repeat above steps for the First Name and Last Name fields;
4.6.5. Add a token at the end and press the Enter key on the keyboard:

5. Prepare the document for printing and save it as follows:
5.1. Execute the File→Print menu command;
5.2. Click the Yes button in the dialogue box to confirm mail merge:

5.3. Make sure that mail merge will be applied to all the records of the address list -
the All range in the Records pane must be selected;
5.4. In the Output pane, select File;
5.5. Make sure that in the Save merged document pane one file is selected to save
the document - Save as single Document:
5.6. Click the OK button in the dialogue box;
5.7. In the Name field of the Save dialogue box, enter the filename letters;
5.8. In the Places pane, select the Desktop folder;
5.9. Save changes with the Save button.

6. View the created document:
6.1. Minimize all the opened windows:
   6.1.1. Click Minimize button in the title bar of the windows.
6.2. Find the icon of the letters.odt file on the desktop;
6.3. Double left-click on it;
6.4. Make sure that names and last names from the address table instead of the
fields are inserted in the document.

7. Prepare labels for envelopes with recipients’ addresses:
7.1. Execute the File→New→Labels menu command;
7.2. In the **Labels** dialogue box, click on the **Options** tab to open it;
7.3. Tick the **Synchronize contents** checkbox;
7.4. Choose the label paper:
   7.4.1. Click on the **Labels** tab to open it;
   7.4.2. In the **Brand** menu of the **Format** pane, select **Avery A4**;
   7.4.3. In the **Type** menu, select **L7560 Clear Address**.
7.5. Select the database:
   7.5.1. In the **Database** menu, select **Mailings**;
   7.5.2. In the **Table** menu, select **Sheet1**;
7.6. In the table label, insert the database fields:
   7.6.1. In the **Database field** menu, select the **Title** field;
   7.6.2. Click the insertion button:
   7.6.3. Repeat the above steps for the **First Name** and **Last Name** fields;
   7.6.4. Press the **Enter** key on the keyboard to start a new line;
   7.6.5. Insert the **Company Name** field;
   7.6.6. Press the **Enter** key to start a new line;
   7.6.7. Insert the **Address Line field**;
   7.6.8. Press the **Enter** key on the keyboard;
   7.6.9. Insert the **City** and **State** fields;
   7.6.10. Press the **Enter** key;
   7.6.11. Insert the **Country** and **ZIP** fields.

**Useful tip**
The text inserted in the **Label text** field, can be edited, spaces can be added and field names can be removed.

7.7. Click the **New Document** button.
8. Edit the layout of the label text:
   8.1. Insert space between the **Title**, **First Name**, **Last Name** fields in the first label;
   8.2. Drag the **Company Name** field to one position below:
      8.2.1. Position the insertion point before the **Company Name** field;
      8.2.2. Press the **Enter** key.
      8.2.3. Insert a comma and space after the **City** field;
      8.2.4. Insert a comma and the word **Index** between the **Country** and **ZIP** fields:

```
<Title>  <First Name>  <Last Name>
<Company Name>
<City>,  <State>
<Country>, Index <ZIP>
```

   8.2.5. Click the **Synchronize Labels** button.
9. Save the labels to a file:
   9.1. Perform the **File→Print** menu command;
   9.2. Click the **Yes** button in the dialogue box to confirm mail merge:
9.3. Make sure that mail merge will be applied to all the records of the address book – the All range in the Records pane must be selected;
9.4. In the Output pane, select File;
9.5. Make sure that Save as single Document is selected in the Save merged document pane:
9.6. Click the OK button in the dialogue box;
9.7. In the Name pane of the Save dialogue box, enter the filename labels;
9.8. In the Places pane, select the Desktop folder;
9.9. Confirm the save function by clicking the Save button.

10. View the created document:
10.1. Perform the Places−>Desktop menu command in the top panel of the desktop;
10.2. Find the icon of the labels.odt file;
10.3. Double left-click on it;
10.4. In the dialogue box, do not confirm the data restoring from the first record of the address book by clicking the No button;
10.5. Make sure that data from the address book and the entered text are added to separate labels on the document pages.

11. Close all the opened windows without saving changes to documents:
11.1. Maximize the minimized windows by clicking the window button in the bottom panel of the desktop.
11.2. Click the Close button in the title bar;
11.3. Click the Discard button not to save changes to documents.

**Document Formatting**

Upon opening Writer, a blank first page opens in the programme window; however, even this page contains a lot of information.

You can create a new document based upon a template and it has:
- Page size;
- Margin size;
- Page orientation;
- A default font type and size, as well as style.

The user can modify these default settings in the document in line with their own needs; however, by creating a new document, the default template settings will be applied to a new document.

**Document Page Settings**

**To modify page size, orientation and margins:**

1. Execute the Format−>Page menu command;
2. In the dialogue box, open the Page tab;
3. Apply changes:
3.1. In the Format menu, select paper format for a document page;
3.2. Choose portrait or landscape in the Orientation pane;
3.3. In the Margins pane, set the margin width in units of measurement for the left, right, top and bottom margin;
3.4. In the Page Layout menu of the Layout settings pane, adjust the margin size to the right and left page (all pages), symmetrically, only for the right or the left, respectively;

4. Confirm changes with the OK button:

To reset default properties:
1. Open the Page dialogue box with the Format-->Page command;
2. Open the Page tab;
3. Click the Reset button.

**Note!**
Choose the same page format as specified for the printer connected to the computer system, otherwise the settings of the text and other components will be shown differently in printouts.

**To modify page margins with the ruler:**
1. Position the mouse pointer on the horizontal or vertical ruler between a text area and margin;
2. Left-click;
3. While holding down the mouse button, drag to the necessary direction;
4. Release the mouse button when the desired margin width is set:
Document Pages

While creating a document in the word processor, a new page is added automatically when the previous one is full. However, there might be cases when it is necessary to insert a new page in a definite place in the text, e.g., to separate the topics. For this purpose, several blank paragraphs can be inserted in the text; however, this is not a good practice.

In **Writer**, page break with special non-printing formatting marks can be inserted.

**To insert page break:**

1. Position the insertion point in a document;
2. Perform the **Insert**→**Manual Break** menu command;
3. In the dialogue box, select **Page Break**;
4. Confirm the action with the **OK** button:

In **Writer**, page break is shown with a thin blue line at the beginning of the page:

**To remove page break:**

1. Position the insertion point before the first word on the page;
2. Press the **Backspace** key.

**Automatic Hyphenation**
When aligning text, especially at justification option, some lines can have different appearance than the rest of the text. It happens because Writer automatically transfers text to a new line based on spacing between words. In some cases, such text may not look neat:

Automatic hyphenation can be used to make a document look neat if the dictionary of the language used in the document is available on the computer.

To apply automatic hyphenation:

1. In the Tools→Language→Hyphenation window, execute the menu command;
2. Perform actions in the Hyphenation dialogue box:
   1. Hyphenate – confirms hyphenation;
   2. Next – moves to the next word that can be hyphenated;
   3. Remove – reverts hyphenation;
3. Click the Cancel button to close the window:

Footer and Header

When working with larger documents, it is often necessary to place some specific text at the top or bottom of the page. It would be difficult to manually add it to each individual page, and doing so would make editing and supplementing the document virtually impossible. Special areas are created at the top and bottom of the document, called the header and the footer, respectively. The header and footer can contain text, fields, f. e., page numbers, a filename, the entered text - the author’s name or last name.

Text entered once in the header and footer areas will apply to all the pages of the document.

To create the header (footer) area in a document:

1. Perform the Insert→Header (Footer)→Default menu command;
2. Position the insertion point in the header (footer) area:
3. Enter the necessary text;
4. Insert application fields:
   4.1. Perform the Insert–>Fields menu command to select:
   4.2. Date;
   4.3. Page Number;
   4.4. Page Count;
   4.5. The name, last name of the author from the user’s account data.
5. Insert a picture or a drawing object, f. e., an organization logo.

**Task 3.7. Apply formatting to a document: use automatic hyphenation, insert a header and insert the page number as the footer. Change the page format. Create gutter in the document. Prepare the document for duplex printing.**

1. Open the header.odt file:
   1.1. Execute the Places–>Documents menu command in the top panel of the desktop;
   1.2. In the file browser window, execute the command Go–>Location in the menu;
   1.3. Position the text cursor at the end of the address in the Location field;
   1.4. Supplement the address with /3_teksapstrade/3.7_document;
   1.5. Press the Enter key on the keyboard;
   1.6. Select the header.odt file;
   1.7. Press the Enter key on the keyboard.
2. Apply automatic hyphenation to the first paragraph:
   2.1. Select the first paragraph in the document:
      2.1.1. Left-click four times in a row in the paragraph text.
   2.2. Perform the Tools–>Language–>Hyphenation menu command;
   2.3. Confirm all the hyphenation places:
      2.3.1. In the Hyphenate dialogue box, click the Hyphenate button twice;
      2.3.2. In the Hyphenation completed alert dialogue box, click the OK button.
3. Set page format A4:
   3.1. Execute the Format–>Page menu command;
   3.2. In the Format menu of the Paper Format pane, select A4.
4. Set horizontal orientation for pages:
   4.1. Select Landscape.
5. Create a gutter margin:
   5.1. In the Margins pane, set the 3.5 cm width to left margin:
   5.2. Click in the Left field;
   5.3. Select default value;
   5.4. Enter 3.5;
   5.5. In the Page Layout menu of the Layout settings pane, select the opposite gutters Mirrored for odd and event pages;
   5.6. Confirm changes with the OK button.
6. Split text by pages: insert page break after the first paragraph:
   6.1. Position the insertion point at the end of the first paragraph;
   6.2. Perform the command in the Insert–>Manual Break menu;
   6.3. In the Insert Break dialogue box, check that Page break is selected;
6.4. Confirm insertion with the OK button.

7. Remove unnecessary page break before the last paragraph of the document:
   7.1. Place the insertion point before the text in the last paragraph;
   7.2. Press the Backspace key on the keyboard.

8. Create the header for pages:
   8.1. Execute the command in the menu Insert->Header->Default;
   8.2. Insert a page number:
      8.2.1. Position the insertion point in the header area, if necessary;
      8.2.2. Enter the words Page from with space at the end;
      8.2.3. Execute the Insert->Fields->Page Number menu command;
      8.2.4. Insert space after the page number field;
      8.2.5. Perform the Insert->Fields->Page Count menu command;
      8.2.6. Insert space and the words pages total:

         Page 5 from 7 pages total

9. Enter the name of the document in the page footer:
   9.1. Perform the command in the Insert->Footer->Default menu;
   9.2. Enter the text This is sample document;
   9.3. Center it:
      9.3.1. Click the Centered button in the Formatting toolbar.

10. Enlarge the footer area:
    10.1. Position the mouse pointer on the vertical ruler between the footer area
          and the margin:
    10.2. Left-click;
    10.3. While holding down the mouse button, drag down;
    10.4. Release the mouse button:

11. Save changes to the document:
    11.1. Click the Save button in the toolbar.

12. Use preview:
    12.1. Execute the File->Page Preview menu command;
    12.2. View all the pages:
      12.2.1. Click the Multiple pages button in the preview toolbar:
      12.2.2. Select the 3 x 3 pages version:

    12.3. Close preview:
      12.3.1. Click the Close preview button in the toolbar.
13. Close the document:
   13.1. Click the Close button in the title bar.

Saving a File in a Different Format

File format is determined by the way a particular programme forms the structure and the layout of a document; different programmes do it differently. Saving a text document in a different file format is necessary in order to use it in applications that cannot directly open files in the OpenOffice.org Writer format.

Frequently used text file types:
- **ODF Text Document (.odt)** - document format in Writer;
- **ODF Text Document Template (.ott)** - OpenOffice.org Writer template with the file extension .ott;
- **OpenOffice.org 1.0 Text Document (.sxw)** - a text document of older OpenOffice.org version.
- **Text (.txt)** - a document of plain text and universal format. However, it does not save document formatting, tables and pictures.
- **Microsoft Word 97/2000/XP (.doc)** - compatibility with older MS Office Word versions.
- **Microsoft Word 2007 XML (.docx)** - compatibility with MS Word.
- **HTML Document (.html)** - website format, it can be opened with web browser. Writer suits to web page development.
Module 3

To save a text document in other format:

1. Perform the File→Save As command;
2. In the Save dialogue box, open the list of available formats;
3. Specify the File Type in the list;
4. Save the presentation by clicking the Save button.

Various software and operating systems are available for users, and standards of applications can be different in various organizations. For example, Writer cannot be installed on the recipient’s computer and this can cause problems when recipients wish to open a document.

When a document is saved in a format suitable for other application, it cannot retain its layout, appearance features and formatting properties. In such cases, the document can be exported in a widespread file format, which, in addition to ensuring compatibility, can protect the original document against undesired, unintended changes.

To export a document in universal file formats not tied to specific software:

Execute the command File→Export, specifying the File Type in the dialogue box, f. e.:

- XHTML (.html; .xhtml) - web format with the filename extension .html;
- PDF - Portable Document Format; a document of Adobe Acrobat format with the file extension .pdf.

Styles

A style is a combination of various formatting properties. For example, if it is necessary to apply a specific colour, font type, highlighting, font size and a particular effect to a text, all of these properties can be saved as a style and later applied again with a single command. OpenOffice.org Writer has built-in styles for paragraphs and text.

To apply style to text:

1. Select text;
2. Execute the Format→Styles and Formatting menu command;
3. In the Styles and Formatting dialogue box, open the Character Styles tab;
4. Double left-click to choose the necessary style:

5. Close the Styles and Formatting dialogue box.
To apply style to a paragraph:

1. Select a paragraph (paragraphs);
2. Perform the **Format->Styles and Formatting** menu command;
3. In the **Styles and Formatting** dialogue box, open the **Paragraph Styles** tab;
4. Double left-click to choose the necessary style:

5. Close the ** Styles and Formatting** dialogue box.

Style can be modified and changes will be applied automatically in the entire document where the specific style has been used.

To modify existing style:

1. Open the ** Styles and Formatting** dialogue box;
2. Right-click on the style name;
3. Perform the **Modify** command in the right-click menu:

4. Modify formatting using the dialogue box.

If the desired format has been applied to a paragraph or text, the existing formatting can be used with another text area or paragraph by the use of the Format Paintbrush.

To use copy format tool:

1. Select the formatted text or specify the formatted paragraph;
2. Click the **Format Paintbrush** button in the Standard toolbar:

3. Select the text to be formatted (select a paragraph).

Creating a Document from a Template

Templates are pre-formatted documents on the base of which a new document can be created. In **OpenOffice.org Writer**, it is possible to use the built-in templates, save an existing document as a template, or download templates from online.
The number of the default templates depends on the software version and the operating system.

Essentially, a template is an existing document that serves as the basis for a new document when opened in **Writer**. The filename extension of **Writer** templates is **.ott**.

Create a document from a template in the file system:

1. Find a template in the file system;
2. Double left-click to open a template;
3. Create a document;
4. Save a document.

To create a document from an online template:

1. Activate **Writer**;
2. Perform the **File->New->Templates and Documents** command;
3. Click on **Get more templates online** link:

   ![Get more templates online](http://templates.go-oo.org/?cid=923508)

4. Find an online template;
5. Perform downloading or open in **Writer**;
6. Create a document;
7. Save the document.

**Inserting a Character**

Not all characters of the selected font can be entered with the keyboard. There are also many special characters used in documents, such as the paragraph mark §, the copyright symbol ©, letters of the Greek alphabet, such as the Ω, and other characters.

To insert a character in a document:

1. Position the insertion point in the document;
2. Perform the command in the **Insert->Special Character** menu;
3. Select a character in the dialogue box;
4. In the **Special Characters** dialogue box, click the **OK** button:
Task 3.8. Create a cover letter from a file. Save it in Adobe Acrobat format.

1. Activate Writer:
   1.1. Perform the operating system Applications->Office->OpenOffice.org Word Processor menu command in the top panel of the desktop.
   1.2. Create a new document from a file:
   1.3. Perform the File->New->Templates and Documents menu command;
   1.4. Select the My Documents folder located in the left corner;
   1.5. Double left-click to open the 3_text_processing folder in the right pane of the Templates and Documents dialogue box;
   1.6. Double left-click to open the 3.8_export folder;
   1.7. Select the letter.ott template file;
   1.8. Click the Open button in the dialogue box.

2. Replace the template text:
   2.1. Select the text [Contact Name];
   2.2. Enter Dr. John Silver;
   2.3. Select the first paragraph;
   2.4. Enter the text;
   2.5. Enter the text We need to discuss some aspects of cooperation.

3. Modify the text style:
   3.1. Select the first sentence in the second paragraph;
   3.2. Perform the Format->Styles and Formatting menu command;
   3.3. Click the Character Styles button to open the Character Styles tab in the dialogue button;
   3.4. Double left-click on the Emphasis style:

   ![Character Styles Dialogue]

4. Modify the paragraph style:
   4.1. Left-click on the entered text in the first paragraph;
4.2. In the dialogue box, click on the **Paragraph Styles** button to open the respective tab;

4.3. Double left-click on the **Text** style:

4.4. Click the **Close** button to close the **Styles and Formatting** dialogue box.

5. Apply formatting of the first paragraph to the entire text:

5.1. Check if the insertion point is placed in the first paragraph of the text of the cover letter;

5.2. Click the **Format Paintbrush** button in the **Standard** toolbar:

5.3. Select the last two paragraphs of the text.

6. View the document in the web layout mode:

6.1. Perform the **View->Web Layout** command in the menu.

7. Restore the print layout mode of the document:

7.1. Perform the command in the **View->Print Layout** menu.

8. Save the document in **PDF** format:

8.1. Execute the command in the **File->Export as PDF** menu;

8.2. Save the PDF format default settings:

8.2.1. Click the **Export** button in the **PDF Options** dialogue box.

8.3. In the **Name** field, enter the filename **letter**;

8.4. Click the **Save** button.

9. Save the created document as a template:

9.1. Click the **Save** button in the **Standard** toolbar;

9.2. In the **Name** field of the **Save** dialogue box, enter the name **cover**;

9.3. In the document type menu, select the **ODF Text Document Template**:

9.4. Click the **Save** button.

**Printing a Document**

In **Writer**, like in other programmes, printing options are available.

**To print a document;**
1. Perform the **File→Print** command;
2. In the **Print** dialogue box:
   2.1. Select a printer. Several printers can be connected to the computer, including the ones connected to the computer network;
   2.2. Specify printing options – the entire document, definite pages, the selected area;
   2.3. Specify the number of copies to be printed:

![Print dialogue box diagram](image)

A – print the entire document; B – select pages for printing; C – print selection; D – select a printer; E – specify the number of copies to be printed

*Image 10 Printing a document*

**Useful tip**

Although a document looks the same on the display as it does when printed, it is possible to see the overall view of the document with the preview to make sure that the desired appearance is achieved.

**To open a document in preview:**

1. Execute the **File→Page Preview** command;
2. Click the menu of the **Multiple Pages** button in the toolbar;
3. Select the number of pages to preview at once:

![Page Preview toolbar](image)

**To close preview:**

Click the **Close Preview** button in the preview toolbar:
Search and Replace Commands

Search tools in Writer make it easier to find a specific place in a document. The user has to enter a word or part of it, and the search function will automatically search through the entire document and find matching instances. This is particularly useful when working with large documents.

To search a word or a phrase in a document:

1. Open a document in Writer;
2. Open the search tool with the Edit→Find & Replace command;
3. In the Search for field of the Find & Replace dialogue box, enter the searched word or the phrase;
4. Click the Find button;
5. Repeatedly click the Find button, to move over to the next suggestion.

To auto-replace a word or a phrase in a document:

1. Open a document in Writer;
2. Open the search tool with the Edit→Find & Replace command;
3. In the Search for field of the Find & Replace dialogue box, enter the searched word or the phrase;
4. In the Replace with field, enter a word or a phrase for replacing;
5. Click the Replace button;
6. Click the Replace button to repeat the replace command for the next case;
   or
7. Click the Replace All button to replace all the cases:
**Useful tip**

Search in a text document begins with the location of the insertion point. If the search tool has come to the end of the document, confirm to continue searching from the beginning of the document by clicking the **Yes** button in the dialogue box:

![OpenOffice.org 3.2](image)

### Help in Working with Application

**Writer** has built-in help function that contains the user guide and answers to various questions. Texts are in English.

#### To use the Help function of OpenOffice.org:

1. Execute the command in the **Help→OpenOffice.org Help** menu
   or
2. Press the **F1 function** key on the keyboard

![OpenOffice.org Help - OpenOffice.org Writer](image)

- **Contents** – contents of OpenOffice.org Help function;
- **Index** – a searchable index of topic;
- **Find** - search function;
- **Bookmarks** – bookmarks created by the user

*Image 11 Dialogue box of the Help function*

The Help system opens in **Writer** by default; if necessary, it is easy to switch to the Help systems on other applications of the OpenOffice.org suite.

The Help window is divided into two sections: the left side features a searchable index of topic and a tab with the search tool, while the right side displays the contents of the selected section and the search results.
To bookmark a topic:

Click the **Add to Bookmarks** button.

![Add to Bookmarks button](image)

**Tooltip**

It is possible to learn the meaning of a toolbar button by reading its name in the language of the application.

**To view the command performed by a toolbar button:**

Place the mouse pointer on the button:
Supplement 1

ECDL requirements for Module 3: Word Processing:
- Work with documents and save them in different file formats;
- Choose built-in options such as the Help function to enhance productivity;
- Create and edit small-sized word processing documents that will be ready to share and distribute;
- Apply different formats to documents to enhance them before distribution and recognize good practice in choosing the appropriate formatting options;
- Insert tables, images and drawn objects into documents;
- Prepare documents for mail merge operations;
- Adjust document page settings and check and correct spelling before finally printing documents.

<table>
<thead>
<tr>
<th>Category</th>
<th>Skill Set</th>
<th>Ref.</th>
<th>Task Item</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1 Using the Application</td>
<td>3.1.1 Working with Documents</td>
<td>3.1.1.1</td>
<td>Open, close a word processing application.</td>
<td>13</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.1.1.2</td>
<td>Create a new document based on default template, other available template like: memo, fax, and agenda.</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.1.1.3</td>
<td>Save a document to a location on a drive. Save a document under another name to a location on a drive.</td>
<td>14</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.1.1.4</td>
<td>Save a document as another file type like: text file, Rich Text Format, template, software specific file extension, version number.</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.1.1.5</td>
<td>Switch between open documents.</td>
<td>54</td>
</tr>
<tr>
<td>3.1.2 Enhancing Productivity</td>
<td>3.1.2.1 Set basic options/preferences in the application: user name, default folder to open, save documents.</td>
<td>36</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3.2 Document Creation</td>
<td>3.2.1 Enter Text</td>
<td>3.2.1.1</td>
<td>Switch between page view modes.</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.2.1.2</td>
<td>Enter text into a document.</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.2.1.3</td>
<td>Insert symbols or special characters like: ©, *, ‡.</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.2.2.1</td>
<td>Display, hide non-printing formatting marks like: spaces, paragraph marks, manual line break marks, tab characters.</td>
<td>9</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.2.2.2</td>
<td>Select character, word, line, sentence, paragraph, entire body text.</td>
<td>16</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.2.2.3</td>
<td>Edit content by entering, removing characters, words within existing text, by over-typing to replace existing text.</td>
<td>8, 9</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.2.2.4</td>
<td>Use a simple search command for a specific word, phrase.</td>
<td>83</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3.2.2.5</td>
<td>Use a simple replace command for a specific word, phrase.</td>
<td>83</td>
</tr>
<tr>
<td>Category</td>
<td>Skill Set</td>
<td>Ref.</td>
<td>Task Item</td>
<td>Page</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------------------</td>
<td>------</td>
<td>---------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.2.2.6 Copy, move text within a document, between open documents.</td>
<td>53</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.2.2.7 Delete text.</td>
<td>16</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.2.2.8 Use the undo, redo command.</td>
<td>13</td>
</tr>
<tr>
<td>3.3 Formatting</td>
<td>3.3.1 Text</td>
<td></td>
<td>3.3.1.1 Change text formatting: font sizes, font types.</td>
<td>18, 18</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.1.2 Apply text formatting: bold, italic, underline.</td>
<td>19</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.1.3 Apply text formatting: subscript, superscript.</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.1.4 Apply different colours to text.</td>
<td>19</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.1.5 Apply case changes to text.</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.1.6 Apply automatic hyphenation.</td>
<td>73</td>
</tr>
<tr>
<td></td>
<td>3.3.2 Paragraphs</td>
<td></td>
<td>3.3.2.1 Create, merge paragraph(s).</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.2 Insert, remove soft carriage return (line break).</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.3 Recognize good practice in aligning text: use align, indent, and tab tools rather than inserting spaces.</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.4 Align text left, centre, and right, justified.</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.5 Indent paragraphs: left, right, first line.</td>
<td>26</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.6 Set, remove and use tabs: left, centre, right, decimal.</td>
<td>41</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.7 Recognize good practice in paragraph spacing: apply spacing between paragraphs rather than use the Return key.</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.8 Apply spacing above, below paragraphs. Apply single, 1.5 lines, double line spacing within paragraphs.</td>
<td>25, 26</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.9 Add, remove bullets, numbers in a single level list. Switch between different standard bullet, number styles in a single level list.</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.2.10 Add a box border and shading/background colour to a paragraph.</td>
<td>27, 28</td>
</tr>
<tr>
<td></td>
<td>3.3.3 Styles</td>
<td></td>
<td>3.3.3.1 Apply an existing character style to selected text.</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.3.2 Apply an existing paragraph style to one or more paragraphs.</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.3.3.3 Use copy format tool.</td>
<td>78</td>
</tr>
<tr>
<td>3.4 Objects</td>
<td>3.4.1 Table Creation</td>
<td></td>
<td>3.4.1.1 Create a table ready for data insertion.</td>
<td>38</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.4.1.2 Insert, edit data in a table.</td>
<td>38</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.4.1.3 Select rows, columns, cells, entire table.</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.4.1.4 Insert, delete, rows and columns.</td>
<td>39</td>
</tr>
<tr>
<td></td>
<td>3.4.2 Table Formatting</td>
<td></td>
<td>3.4.2.1 Modify column width, row height.</td>
<td>39</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.4.2.2 Modify cell border line style, width, and colour.</td>
<td>39</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3.4.2.3 Add shading/background colour to cells.</td>
<td>40</td>
</tr>
<tr>
<td>Category</td>
<td>Skill Set</td>
<td>Ref.</td>
<td>Task Item</td>
<td>Page</td>
</tr>
<tr>
<td>-------------------</td>
<td>--------------------</td>
<td>--------------</td>
<td>---------------------------------------------------------------------------</td>
<td>--------</td>
</tr>
<tr>
<td>3.4.3 Graphical</td>
<td>3.4.3.1</td>
<td>51, 49</td>
<td>Insert an object (picture, image, chart, drawn object) to a specified location in a document.</td>
<td></td>
</tr>
<tr>
<td>Objects</td>
<td>3.4.3.2</td>
<td>49</td>
<td>Select an object.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.4.3.3</td>
<td>53</td>
<td>Copy, move an object within a document, between open documents.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.4.3.4</td>
<td>49, 50</td>
<td>Resize, delete an object.</td>
<td></td>
</tr>
<tr>
<td>3.5 Mail Merge</td>
<td>3.5.1 Preparation</td>
<td>60</td>
<td>Open, prepare a document, as a main document for a mail merge.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.5.1.1</td>
<td>60</td>
<td>Select a mailing list, other data file, for use in a mail merge.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.5.1.2</td>
<td>60</td>
<td>Insert data fields in a mail merge main document (letter, address labels).</td>
<td></td>
</tr>
<tr>
<td>3.6 Prepare Outputs</td>
<td>3.6.1 Setup</td>
<td>70</td>
<td>Change document orientation: portrait, landscape. Change paper size.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.1.1</td>
<td>70</td>
<td>Change margins of entire document, top, bottom, left, right.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.1.2</td>
<td>71</td>
<td>Recognize good practice in adding new pages: insert a page break rather than using the Return key.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.1.3</td>
<td>72</td>
<td>Insert, delete a page break in a document.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.1.4</td>
<td>73</td>
<td>Add, edit text in headers, footers.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.1.5</td>
<td>74</td>
<td>Add fields in headers, footers: date, page number information, file name.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.1.6</td>
<td>74</td>
<td>Apply automatic page numbering to a document.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.1.7</td>
<td>74</td>
<td>Spell check a document and make changes like: correcting spelling errors, deleting repeated words.</td>
<td></td>
</tr>
<tr>
<td>3.6.2 Check and Print</td>
<td>3.6.2.1</td>
<td>63</td>
<td>Add words to a built-in custom dictionary using a spell checker.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.2.2</td>
<td>64</td>
<td>Preview a document.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.2.3</td>
<td>82</td>
<td>Print a document from an installed printer using output options like: entire document, specific pages, number of copies.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3.6.2.4</td>
<td>81</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Task 3.9. Test your knowledge by completing the following task

Explanation:

Centimetres as the units of measurement and the decimal separator comma (,) are used in the task description.

The whole task consists of 30 parts and points will be awarded for a successful completion of each part of the task.

The task must be completed within 45 minutes.

Although definite steps are suggested for the completion of each part, other relevant and convenient methods can be used.

Try to complete the whole task on your own and without following any directions.

The task is successfully completed if the score achieved exceeds 24 points (i.e., 75% of the maximum possible 32 points).

8. Open the text.odt file in the 3.9_test subfolder of the 3_text_processing subfolder in the Documents folder of the user account. Save it under the name story.odt in the Documents folder (1 point):
   8.1. Execute the Places->Documents menu command in the top panel of the desktop;
   8.2. Left-click on the 3_text_processing folder;
   8.3. Press the Enter key on the keyboard;
   8.4. Double left-click on the 3.9_test folder;
   8.5. Click on the text.odt file;
   8.6. Press the Enter key on the keyboard;
   8.7. In the Writer window, execute the File->Save As menu command;
   8.8. In the Name field of the Save dialogue box, enter the story.odt filename;
   8.9. In the Places pane, left-click on the Documents folder to select it;
   8.10. Click the Save button in the dialogue box.

9. Change the page orientation to a portrait version (1 point):
   9.1. Open the Page Style dialogue box:
   9.1.1. Perform the Format->Page menu command.
   9.2. Left-click on the Page tab in the dialogue box to open it, if necessary;
   9.3. In the Paper Format pane, select Portrait:

10. To continue, change the page format to A4 (1 point):
    10.1. In the Format menu of the Paper Format pane, select A4:
    10.2. To confirm the changes, click the OK button in the Page Style dialogue box.

11. In the beginning of the document, insert the field with the today’s date (1 point):
11.1. Place the insertion point at the very beginning of the document before the title;
11.2. Perform the Insert->Fields->Date menu command;
11.3. Press the Enter key on the keyboard.

12. Align the text in the paragraph starting with Was there... to both the margins of the text (1 point):
   12.1. Place the mouse pointer above the paragraph;
   12.2. Left-click;
   12.3. Click the Justified button in the toolbar of the Writer window:

12.4.

13. Center the text The Next Stories (1 point):
   13.1. Place the mouse pointer above the text The Next Stories;
   13.2. Left-click;
   13.3. Perform the Format->Paragraph menu command;
   13.4. In the Paragraph dialogue box, click on the Alignment tab to open it;
   13.5. In the Options pane, select Center:

   13.6. Click the OK button in the dialogue box.

14. Apply a 3 cm left indent to the text highlighted in green (1 point):
   14.1. Select the text in green for the list:
       14.1.1. Left-click at the end of the selected text area;
       14.1.2. While holding down the left mouse button, drag it diagonally to the beginning of the selected text area;
       14.1.3. Release the mouse button:

   14.2. Perform the Format->Paragraph menu command;
   14.3. In the Paragraph dialogue box, click on the Indents & Spacing tab to open it;
   14.4. Repeatedly click the corresponding button to set the line spacing value of the Before text field up to 3.0 cm in the Indent pane:

   14.5. Confirm the changes by clicking the OK button in the dialogue box.

15. Create a list of bullets using the text in green (1 point):
   15.1. Select the text in green, if necessary;
   15.2. Click the Bullets On/Off button in the toolbar:
15.3. Left-click at the end of the list.

16. Use the double line spacing within a paragraph that starts with He heard quiet...:
   16.1. Left-click on the paragraph to move the insertion point along it;
   16.2. Perform the Format-&gt;Paragraph menu command;
   16.3. In the Line spacing menu in the Indents & Spacing tab of the Paragraph dialogue box, select Double:

```
<table>
<thead>
<tr>
<th>Line spacing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Double</td>
</tr>
</tbody>
</table>
```

16.4. In the Paragraph dialogue box, click the OK button.

17. Replace soft carriage return with hard carriage return in the paragraph under the title Continued (1 point):
   17.1. In the toolbar of the Writer window, click the Nonprinting Characters button:

```
Nonprinting Characters
```

17.2. Place the insertion point before the soft carriage return in the specified paragraph:

```
the sidewalk
```

17.3. Press the Delete key on the keyboard;
   17.4. Press the Enter key on the keyboard;
   17.5. In the toolbar of the Writer window, click the Nonprinting Characters button to hide nonprinting characters;
   17.6. Save the changes to the document by clicking the Save button in the toolbar:

```
Default Save
```

18. Use the TAB key on the keyboard to apply a 3 cm left indent to the sentence highlighted in blue (1 point):
   18.1. Position the mouse pointer on 3 on the horizontal ruler;
   18.2. Left-click:

```
   2   3   4
```

18.3. Place the insertion point at the beginning of the sentence marked in blue;
   18.4. Press the TAB key on the keyboard:

```
end, he would have to go
```

19. Apply subscript to the text Ask in book shops (1 point):
   19.1. Select the text Ask in book shops in the sentence;
19.2. Perform the **Format->Character** menu command;
19.3. In the **Character** dialogue box, left-click on the **Position** tab to open it, if necessary;
19.4. In the **Position** pane, select **Subscript**:

![Subscript](image)

19.5. Confirm the changes by clicking the **OK** button in the dialogue box.

20. Insert page break before the text **Some lines...** (1 point):
20.1. Place the insertion point before the word **Some**;
20.2. Execute the **Insert->Manual Break** menu command;
20.3. Make sure that **Page Break** is selected in the **Insert Break** dialogue box:

![Insert Break](image)

20.4. Click the **OK** button in the **Page Break** dialogue box.

21. Apply a double line border to a paragraph after the title **Some lines from new tale** (1 point):
21.1. Left-click in the text in the paragraph;
21.2. Perform the **Format->Paragraph** menu command;
21.3. In the **Paragraph** dialogue box, left-click on the **Borders** tab to open it;
21.4. In the **Line Style** pane, select a double **3.0pt** line;
21.5. In the **Color** menu, select **Light red**;
21.6. In the **Line arrangement** pane, tick the **Set All Four Borders** checkbox:

![Borders](image)

21.7. Click the **OK** button in the dialogue box.
22. After the text ... the way he had come, at the end of the first document page, insert the copyright symbol and the euro sign in a new paragraph (1 point):
   22.1. Place the insertion point after the words ... the way he had come at the end of the sentence;
   22.2. Press the Enter key on the keyboard;
   22.3. Perform the Insert->Special Character menu command;
   22.4. In the Special Character pane in the dialogue box, find ©;
   22.5. Left-click on it;
   22.6. Find €;
   22.7. Left-click on it;
   22.8. Click the OK button in the dialogue box.

23. Apply red formatting to the first sentence in the paragraph after the title Some lines from new tale, the font size is 16 (1 point):
   23.1. Select the first sentence of the paragraph;
   23.2. In the Font Size toolbar menu, select 16:
   23.3. Open the Font Color button menu:
   23.4. Select Light Red;
   23.5. Click the Save button in the toolbar.

24. Delete the last column in the table on the second page of the document (1 point):
   24.1. Click in any cell in the last column of the table;
   24.2. Perform the Table->Delete->Columns menu command.

25. Insert a new row in the table before the last row:
   25.1. Left-click in any cell in the last row of the table;
   25.2. Perform the Table->Insert->Rows menu command;
   25.3. In the Insert Rows dialogue box, select Before:
   25.4. Click the OK button in the dialogue box.

26. Enter the following text in the inserted row (1 point):

   Cinderella | 765

   26.1. Position the insertion point in the first cell of the inserted row;
   26.2. Enter Cinderella;
   26.3. Press the Tab key on the keyboard;
   26.4. Enter 765.

27. Apply shadow to the table (1 point):
   27.1. Place the insertion point in any cell in the table, if necessary;
   27.2. Execute the Table->Properties menu command;
   27.3. In the Table Format dialogue box, click on the Borders tab, to open it;
27.4. In the **Shadow style** pane, click the **Cast Shadow to Top Right**;

27.5. Click the **OK** button in the **Table Format** dialogue box.

28. Apply spellchecking to the document (1 point):
   28.1. Execute the **Tools->Spelling and Grammar** menu command;
   28.2. Correct the misspelled words:
      28.2.1. In the **Spelling** dialogue box, click **Change** to confirm a suggestion from the **Suggestions** pane:
      or:
      28.2.2. Select the right version of the word in the **Suggestions** pane;
      28.2.3. Click the **Change** button in the **Spelling** dialogue box;
   28.3. Confirm to continue spellchecking at the beginning of the document:

**Useful tip**

If "Check spelling as you type" is enabled in the application, spellchecking can also be performed by right-clicking on a word with a red wavy underline and selecting the correct word in the right-click menu:
The misspelled words in this text are as follows:

<table>
<thead>
<tr>
<th>Word in the text</th>
<th>Correction or action</th>
</tr>
</thead>
<tbody>
<tr>
<td>behinď</td>
<td>behind</td>
</tr>
<tr>
<td>greenbacks</td>
<td>Ignore the correction by clicking the Ignore once button</td>
</tr>
<tr>
<td>croek</td>
<td>crook</td>
</tr>
<tr>
<td>labor</td>
<td>labour</td>
</tr>
<tr>
<td>warists</td>
<td>wrists</td>
</tr>
<tr>
<td>linne</td>
<td>line</td>
</tr>
<tr>
<td>draipping</td>
<td>dripping</td>
</tr>
<tr>
<td>sidewalk</td>
<td>Ignore the correction by clicking the Ignore once button</td>
</tr>
<tr>
<td>Rumpelstiltskin</td>
<td>Proper noun. Ignore the correction by clicking the Ignore once button</td>
</tr>
</tbody>
</table>

29. Insert the picture `doors.jpg` below the table at the end of the document (1 point):
   29.1. Position the insertion point below the table at the end of the document;
   29.2. Perform the *Insert-*Picture-*From File* menu command;
   29.3. In the *Insert Picture* dialogue box:
      29.3.1. Open the picture location, if necessary:
         29.3.1.1. In the *Places* pane, select the *Documents* folder;
         29.3.1.2. Double left-click on the *3_text_processing* folder;
         29.3.1.3. Double left-click on the *3.9_test* folder;
      29.3.2. Select the `doors.jpg` picture file;
      29.3.3. In the dialogue box, click the *Open* button.

30. Resize the picture to 30 percent of its original size by retaining the proportions (1 point):
   30.1. Make sure that the picture is selected - handles have appeared around the picture;
   30.2. Perform the *Format-*Picture menu command;
   30.3. In the *Picture* dialogue box, click on the *Type* tab to open it;
   30.4. In the *Size* checkbox, tick *Relative*;
   30.5. In the *Width* field, insert 30:
   30.6. Tick the *Keep ratio* checkbox:
   30.7. In the *Picture* dialogue box, click the *OK* button;
   30.8. Save the changes to the document by clicking the *Save* button in the toolbar.

31. Copy the picture in the *letter.odt* document (1 point):
31.1. Right-click on the picture;
31.2. Perform the **Copy** command in the right-click menu;
31.3. Open the **letter.odt** document file:
   31.3.1. Perform the **File->Open** menu command;
   31.3.2. In the **Places** pane of the dialogue box, select the **Documents** folder;
   31.3.3. Select the **3_text_processing** folder;
   31.3.4. Press the **Enter** key on the keyboard;
   31.3.5. Select the **3.9_test** folder;
   31.3.6. Press the **Enter** key on the keyboard;
   31.3.7. Double left-click on the **letter.odt** file;
31.4. Place the mouse pointer at the end of the text;
31.5. Right-click;
31.6. Perform the **Paste** command in the right-click menu;
31.7. Close the **story.odt** document:
   31.7.1. Open the **story.odt** document by clicking on the button in the bottom panel of the desktop:
   31.7.2. Click the **Close** button in the title bar of the Writer window.
32. Replace the word **benefit** with **profit** in the entire document (1 point):
   32.1. Perform the **Edit->Find & Replace** menu command;
   32.2. In the **Search for** field of the **Find & Replace** dialogue box, enter **benefit**;
   32.3. In the **Replace with** field, enter **profit**;
   32.4. Click the **Replace All** button;
   32.5. In the alert dialogue box, click the **OK** button:
   32.6. Close the **Find & Replace** dialogue box by clicking the **Close** button.
33. Insert the word **Newslist** on the right side of the document header (1 point):
   33.1. Create the document header:
      33.1.1. Perform the **Insert->Header->Default** menu command.
   33.2. Position the insertion point in the header, if necessary;
   33.3. Enter **Newslist**;
   33.4. Align the text to the right margin:
      33.4.1. In the toolbar, click the **Align Right** button:
34. Use the mail merge option in the document by using the existing list of recipients **address_list.ods**. Save the merged document as **mail.odt**: (3 points)
   34.1. Place the insertion point before the text **Our Company Today** at the beginning of the document:
   34.2. Activate the merge wizard:
      34.2.1. Execute the **Tools->Mail Merge Wizard** menu command.
34.3. In the mail merge wizard:

34.3.1. Make sure that the **Use the current document** is selected as the main document:

![Select the document upon which to base the mail merge document](image)

34.3.2. Click the **Next** button;

34.3.3. Make sure that the type of the document is **Letter**:

![What type of document do you want to create?](image)

34.3.4. Click the **Next** button;

34.3.5. Insert the address block:

34.3.5.1. Click the **Select Address List** button, to choose the list of recipients;

34.3.5.1.1. In the **Select Address List** dialogue box, click the **Add** button;

34.3.5.1.2. Make sure that the **Documents** folder is selected in the **Places** pane in the **Open** dialogue box;

34.3.5.1.3. Double left-click on the **3_text_processing** folder;

34.3.5.1.4. Double left-click on the **3.9_test** folder;

34.3.5.1.5. Select the file **address_list.ods**;

34.3.5.1.6. Click the **Open** button.

34.3.5.2. Click the **OK** button in the **Select Address List** dialogue box;

34.3.6. Accept the default type of the address list by clicking the **Next** button;

34.3.7. Untick the **This document should contain a salutation** selection in the checkbox;

![Create a salutation](image)

34.3.8. Click the **Next** button;

34.3.9. Accept the default location of the address block by clicking the **Next** button;

34.3.10. In the next step, click the **Next** button;

34.3.11. In the seventh step, click the **Next** button;

34.3.12. Save the main document:

34.3.12.1. Select **Save starting document**;

34.3.12.2. Click the **Save starting document** button:
34.4. Click the Finish button in the mail merge wizard;
34.5. Execute the File->Save menu command;
34.6. In the Name field of the Save dialogue box, enter filename mail;
34.7. Click the Save button;
34.8. Close the merged document by clicking the Close button in the title bar of the window.

35. View a print preview of the document letter.odt; if possible, make one printout (1 point):
35.1. Open the letter.odt document:
35.1.1. Execute the File->Recent Documents->... letter.odt menu command;
35.2. Perform the File->Page Preview menu command;
35.3. Execute the File->Print menu command;
35.4. In the Print dialogue box, click the OK button to print the document and click the Cancel button to cancel printing;
35.5. Click the Close Preview button:

36. Add an automatic page number in the centre of the footer (1 point):
36.1. Create the document footer:
36.1.1. Perform the Insert->Footer->Default menu command.
36.2. Position the insertion point in the footer area;
36.3. Execute the Insert->Fields->Page Number menu command;
36.4. Click the Centered button in the toolbar.

37. Save the document letter.odt as a template.ott (1 point):
37.1. Perform the File->Save As menu command;
37.2. In the Save dialogue box, click on File type;
37.3. Select the ODF Text Document Template file type:
37.4. In the Name field, enter the file name template, by replacing the existing name;
37.5. Click the Save button;
37.6. Close the document window by clicking the Close button in the title bar.