5th module

Using Databases – OpenOffice.org Base
# Table of Contents

**DATABASES**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to Databases</td>
<td>4</td>
</tr>
<tr>
<td>Tables</td>
<td>5</td>
</tr>
<tr>
<td>Forms</td>
<td>7</td>
</tr>
<tr>
<td>Queries</td>
<td>8</td>
</tr>
<tr>
<td>Reports</td>
<td>9</td>
</tr>
<tr>
<td>Creating a Database</td>
<td>9</td>
</tr>
<tr>
<td>Creating Databases and Objects with a Wizard</td>
<td>9</td>
</tr>
<tr>
<td>Saving a Database</td>
<td>16</td>
</tr>
<tr>
<td>Actions in a Database</td>
<td>19</td>
</tr>
<tr>
<td>Opening a Database File</td>
<td>19</td>
</tr>
<tr>
<td>Actions with Database Objects</td>
<td>20</td>
</tr>
<tr>
<td>Creating a Table in Design View</td>
<td>22</td>
</tr>
<tr>
<td>Modifying a Form in Design View</td>
<td>26</td>
</tr>
<tr>
<td>Entering, Modifying and Sorting Data</td>
<td>28</td>
</tr>
<tr>
<td>Entering Data in a Database</td>
<td>28</td>
</tr>
<tr>
<td>Creating a New Record</td>
<td>29</td>
</tr>
<tr>
<td>Deleting a Record (Data)</td>
<td>29</td>
</tr>
<tr>
<td>Field Index Management</td>
<td>30</td>
</tr>
<tr>
<td>Record Sorting</td>
<td>31</td>
</tr>
<tr>
<td>Record Search</td>
<td>32</td>
</tr>
<tr>
<td>Data Retrieval</td>
<td>35</td>
</tr>
<tr>
<td>Applying Filters</td>
<td>35</td>
</tr>
<tr>
<td>Creating Queries</td>
<td>37</td>
</tr>
<tr>
<td>Creating a Query with a Wizard</td>
<td>38</td>
</tr>
<tr>
<td>Creating a Query in Design View</td>
<td>41</td>
</tr>
<tr>
<td>Information Output</td>
<td>43</td>
</tr>
<tr>
<td>Reports</td>
<td>43</td>
</tr>
<tr>
<td>Data Export</td>
<td>49</td>
</tr>
<tr>
<td>Printing</td>
<td>51</td>
</tr>
<tr>
<td>Additional Actions in the Application</td>
<td>55</td>
</tr>
<tr>
<td>Application Help</td>
<td>55</td>
</tr>
<tr>
<td>Displaying and Hiding Toolbars</td>
<td>56</td>
</tr>
</tbody>
</table>
MODULE 5

DATABASES

In this module, you will learn to:

- Understand how databases work;
- Work in OpenOffice.org Base;
- Create database objects;
- Modify database objects;
- Retrieve information from a database;
- Select information according to set criteria;
- Print out data.

Introduction to Databases

Imagine that you have a large collection of music records with more than 10,000 units. On top of that, albums are sometimes loaned to friends, leased out, or loaned to an archive. How would you go about organizing and managing this collection?

Countless unorganized notes probably will not help, and sooner or later everything will be a disarray of unrelated facts, such as the artist, band’s founding year, lists of guest appearances on albums, or the name of the person who has borrowed the album. On the other hand, when data are arranged in a specific system – a database – they start becoming useful information. Information in a database is interlinked, rather than being simply individual pieces of data.

Databases are a powerful tool for information processing. They store information, allow updating and changing it, retrieve specific, selected data. Database engines vary: some verify and maintain data integrity or allow sharing, others provide different possibilities. Databases are used for processing large volumes of interrelated information, such as in ticket booking, national registries, banks, patient registration in hospitals.

Some examples of databases:

- MySQL
- PostgreSQL
- Oracle
- DB2
- SQL Server

These databases are essentially a mechanism of information storage and processing. For the user to be able to easily use a database, a database management system is employed – a programme or group of programmes that are able to modify, delete, add and retrieve information, create database objects, and perform other actions in the
Large, branching databases for professional use are normally developed by specialists. Users work with the visible side of a database by entering data in forms and receiving back processed results.

For example, when purchasing an airline ticket online:

- The user fills a form, enters the required mandatory and optional data, and confirms it.
- The database system performs information processing, selection, ticket reservation.
- The database system executes changes in other related systems at the airport and the airline’s registration system.
- The user receives a boarding pass or other confirmation.

In this case, the user does not have to understand the entire database system. The maintenance, technical implementation and integration of databases are ensured by specialists. Administrators of the service using the data system are able to establish the user’s access level to the database.

The OpenOffice.org suite includes database management system Base. Version 3 of the software uses integrated database engine HSQL, but also allows connecting to other types of databases.

As relatively small databases use this type of integrated solution, the term “database” is used to refer to both the software and the integrated data storage mechanism at the same time.

**Base** uses the following objects for data management:

- Tables;
- Forms;
- Queries;
- Reports.

**Tables**

Data in a database are stored in a table or multiple interlinked tables. The table is the fundamental structure of a database, so it is important to understand how it works.
A table is organized in horizontal rows and vertical columns:

- **Field** – contains information about a table object; fields form table columns. Fields are normally given a name in the column header, indicating what kind of data they contain. A particular data type can be assigned to fields, e.g., numbers, text, dates. The application will not allow entering data that does not match the type defined for the field. In addition, it is possible to define field properties, such as text length limitations, format and number of decimal places. A single data object is entered in each field; for example, artist or band name in one field, album name in another.

- **Record** – a table row with related data – contains information about a single table object.

It is possible to create a database with a single large table, but it is easier to process information when data is stored in several tables. The larger the database, the more important it is to place thematically different data groups in separate tables. For example, in a database of music records, it is better to store artist data separately. To add new information to a database, it is more convenient to create a new table without modifying the existing table structure.

**Primary key**

To ensure interlinking of specific database tables, one or several primary key fields are defined in each table. The primary key uniquely identifies a table record within the entire database. Primary keys are usually:

- A field specified by the user, for example, a catalogue number, that does not repeat;
• A field created by the programme and filled automatically, for example, in the form of growing numbers.

The primary key is usually marked with a little key symbol.

Field index

Indexing in programmes is used to ensure that records are found faster. By default, the primary key field is indexed, but this property can be assigned to any field.

Relations

Multiple tables are created in databases in order to prevent unnecessary duplication of data. The linkage of tables is called relation. In the example of a music records catalogue, it is possible to create linkage between a particular artist in one table and the artist’s albums in another table:

![Image No. 2. Linkage between tables]

For example, the table tbl_artists contains information about artists – band name, year founded, country, etc.; the other table tbl_albums lists the albums in the collection.

One record of the first table can be linked with several records in the list of this band’s albums. Such a relationship is called “one-to-many” and denoted by 1 - n. Databases also use a “one-to-one” relationship, which means that a table record can be linked with only a single field in another table. This is denoted by 1 - 1.

Such linkage, in addition to its direct purpose, also ensures integrity of information. The application will not allow deleting a linked field while the link to a different table is active.

Forms

In databases, it is possible to use forms for the creation, display and modification of records. Data entry in a form is visually easier to understand than in a table, and is simpler for the user. Forms may contain fields for data entry, field descriptions (names), action buttons, menus, pictures, and design elements.
The purpose of a database is not only to store and accumulate information, but also to ensure information retrieval according to specific criteria.

Queries are used for this purpose. Once created, a query can be saved and later reused.

A query can be used for selection of information in one or several tables. Mathematical and logical actions, and wildcards are used to establish criteria. The result of a query can be displayed in data table, form and report views; it is possible to specify the table fields to be included.

The result obtained from a query can be displayed in a form.
Reports

Reports are usually used to print out information with a particular design. Reports are created using query or table data.

![Image No. 5. A report page prepared for printing in landscape orientation]

The layout of reports can be modified; it is possible to add pictures and other design features.

Creating a Database

Creating Databases and Objects with a Wizard

There are built-in templates in OpenOffice.org Base that make the creation of a new database easier. The user can select database tables from existing samples and modify them as needed.

To create a new database by using a wizard and the default settings:

Create a new database

1. Open the application Base:
2. Perform the menu command Applications→Office→OpenOffice.org Database;

**Note!**
The application OpenOffice.org Base may not be available on the computer by default. If that is the case, it must first be installed. Installation of software is described in Module 2 of the ECDL study material.

3. In the Database Wizard, make sure that **Create a new database** is selected and click **Next**;
4. In the next step, click **Finish**

5. In the **Name** field of the **Save** dialogue box, enter a name for the database;
6. If necessary, specify the location in the computer’s file system;
7. Save by clicking the **Save** button.

Image No. 6. *OpenOffice.org Base*

**Creating a table by using a wizard**

1. In the **Database** pane, select the object type **Table**;
2. In the **Tasks** pane, click on **Use Wizard to create Table**;
3. Step one – select fields to be included in a table from a sample:
   3.1. Select the database category;
   3.2. Choose a table from the Sample tables list;
   3.3. Select the necessary fields in the table sample for the creation of the table;
   3.4. Click the respective button to insert the selected fields in the new table:
   3.5. Click Next.

4. Step two – Set the data type of the selected fields, if necessary:
   4.1. Select a field in the Selected fields pane;
   4.2. In the Field information pane, change the field properties;
   4.3. Click Next.

5. Step three – set an automatic primary key:
   5.1. Make sure that the application will automatically add a Primary key to the record;
   5.2. Tick the checkbox Auto value;
5.3. Click Next.

6. Step four – finishing the table wizard:
   6.1. Enter the table name the field **What do you want to name your table?**;
   6.2. Click Finish.

![Table Wizard](image)

**Useful tip:**

When assigning names to database objects, it is recommended to add a short prefix describing the object type:

- **tbl** for table, **frm** for form, **qry** for query, **rpt** for report;
- or use prefixes chosen by the user for different database objects.

Creating a form by using a wizard

7. In the **Database** pane, select **Forms**;
8. In the **Tasks** pane, click on **Use Wizard to Create Form...**;

![Tasks](image)

9. Step one – select the table fields to be included in the form:
   9.1. In the **Tables or queries** menu, select the database table;
   9.2. In the **Available fields** menu, select the fields for the form;
   9.3. Move the selected fields or all fields to the pane **Fields in the form:**
9.4. Click **Next**.

10. Step two – setting up a subform (not examined in this study material):
    10.1. If necessary, add a subform;
    10.2. Click **Next**.

11. Step five (if a subform is not created) – selecting the design of the form:
    11.1. Choose the **Label placement** (labels are field names);
    11.2. Choose the **Arrangement of the main form**:

11.3. Click **Next**.

12. Step six – selection of the data display and entry mode:
    12.1. Make sure that the **The form is to display all data** is selected;
    12.2. Click **Next**.

13. Step seven – selection of the form style:
    13.1. In the **Apply styles** pane, select the colour fill of the form;
    13.2. Under **Field border**, choose the appearance of fields in the form.
13.3. Click **Next**.

**Useful tip:**

A preview of the form can be seen right away in the **Form design** window under the dialogue box.

14. Finish the creation of the form:

14.1. Enter the name of the form in the field **Set the name of the form**;

14.2. Make sure that **Work with the form** has been selected;

14.3. Click **Finish**.
Saving a Database

OpenOffice.org Base saves databases with the filename extension odb.

The default location is the Documents folder created by the operating system in the user account, unless a different location is specified. The location specified in the default settings of the application can be changed by the user. A database file includes all of the database’s objects and data.

If changes have been made to a database object or data in a table, the application will ask to confirm saving them – also when closing individual objects.
Module 5

Task 5.1. Create a music CD database by using the built-in wizards of Base with the default settings. Create a table and form for data entry and display.

1. Create a database called music_cd.odb in the Documents folder:
   1.1. Open Base with the menu command Applications->Office->OpenOffice.org Database;
   1.2. In the Database Wizard, make sure that Create a new database has been selected;
   1.3. Click Next in the dialogue box;
   1.4. In step two, accept the default settings by clicking Finish;
   1.5. In the Name field of the Save dialogue box, enter database name music_cd;
   1.6. Click Save.

2. Create a table called tbl_CD-Collection by using a wizard:
   2.1. In the Database pane, select the object Tables, if necessary;
   2.2. In the Tasks pane, click on Use Wizard to Create Table;
   2.3. Select the category Personal;
   2.4. Select the table CD-Collection in the Sample tables menu:
   2.5. Use all the sample table fields;
   2.6. Click Next to move on to the next step of the wizard;
   2.7. Confirm the default field settings by clicking Next;
   2.8. Set the field CollectionID as the primary key:
       2.8.1. Click on the radio button Use an existing field as primary key;
       2.8.2. In the Fieldname menu, choose CollectionID;
       2.8.3. Tick the Auto value checkbox:
       2.8.4. Click Next;
       2.8.5. Enter tbl_CD-Collection in the field What do you want to name your table?;
       2.8.6. Click Finish.

3. Create a form called frm_CD-Collection:
   3.1. In the Database pane, select the object Forms;
   3.2. In the Tasks pane, click on Use Wizard to Create Form;
   3.3. Insert all fields of the table tbl_CD-Collection in the form:
3.4. Move **CollectionID** to the top of the list of fields in the form:
   3.4.1. In the pane **Fields in the form**, select the field **CollectionID**;
   3.4.2. Move it to the top:

![Fields in the form](image)

3.5. Click **Next**;

3.6. Click **Next** in the next step;

3.7. Select the arrangement **Columnar – Labels Left**:

![Columnar - Labels Left](image)

3.8. Click **Next**;

3.9. In the next step, make sure that the form can be used to view and enter all data – **The form is to display all data** must be selected;

3.10. Click **Next**;

3.11. Select form style **Red** in the **Apply styles** pane;

3.12. Select **Field border 3D look**;

3.13. Click **Next**;

3.14. In the field **Name of the form**, enter **frm_CD-Collection**;

3.15. Click **Finish**.

4. Create a record in the database:
   4.1. In the **Artist** field of the form, enter **Joe Cocker**;
   4.2. In the **Format** field, enter **CD**;
   4.3. In the **ReleaseYear** field, enter **2010**.

5. Close the form window:
   5.1. Click the **Close** button in the title bar of the form window;
   5.2. In the dialogue box, confirm saving the entered data by clicking **Yes**.

6. Check the records in the database table:
   6.1. In the **Database** pane, select the object **Tables**;
   6.2. In the **Tables** pane, double left-click on the table **tbl_CD-Collection**;
   6.3. Increase the width of the **Artist** field:
      6.3.1. Right-click on the name of the **Artist** field;
      6.3.2. In the right-click menu, choose the command **Column Width**:
      ![Column Width](image)
      6.3.3. In the **Column Width** dialogue box, set the column width to 3 cm:
6.3.4. Click **OK**.

7. Close the table window:
   7.1. Click the **Close** button in the title bar of the table window.

8. Close the database, saving the changes:
   8.1. Perform the menu command **File → Exit**;
   8.2. Confirm the changes by clicking **Yes** in the dialogue box.

**Actions in a Database**

**Opening a Database File**

Naturally, to work with a database, it must first be opened. As with other actions on the computer, there are several ways to open an existing database.

**To open a file from the Base environment:**

1. Perform the menu command **File → Open**;
2. In the **Open** dialogue box, select a file in the default folder or find a file in a different location;
3. Complete the action by clicking **Open**.

**To open a file from the Documents folder:**

1. Open the **Documents** folder by performing the operating system menu command **Places → Documents**;
2. Double left-click on the icon of the database file.

**To open a file by using search:**

1. Perform the operating system menu command **Places → Search for Files**;
2. In the **Name contains** field of the **Search for Files** dialogue box, enter the full or partial name of the file;
3. Click **Find**;
4. In the list of results, double left-click on the necessary file.
To open a Base file by using a wizard:

1. Open the application with the menu command Applications→Office→OpenOffice.org Database;
2. In the Database Wizard, click Open;
3. Select the database file on the computer’s hard drive;
4. Complete the action by clicking Finish.

Actions with Database Objects

OpenOffice.org Base objects are used for actions in a database – tables, forms, queries, reports.

Two view modes are used for objects:
- Data view. Used to enter, output data, view reports.
- Design view. Used to design database objects – add elements, edit, set properties and object features.

To open a database object in data view:

1. Select a database object type in the Database pane of the Base window;
2. Activate the database object:
   2.1. Double left-click on the icon in the object pane;
   or
   2.1. Click the button Open Database Object in the object toolbar:

   ![](image.png)
   A – Selected database object type; B – Selected object; C – Open object in data view; D – Object preview

*Image No. 7. Previewing and opening a table*
Useful tip:
It is possible to enable preview for the selected database object (D in Image No. 7):

To open a database object in design view:
1. Select the database object type in the Database pane of the Base window;
2. Select a database object;
3. Open the object in design view:
   3.1. Click the Edit button in the object toolbar:
   or
   3.1. Perform the menu command Edit→Edit.

To delete a database object:
1. Select the database object type in the Database pane of the Base window;
2. Select a database object;
3. Delete the object:
   3.1. Click the Delete button in the object toolbar:
   or
   3.2. Perform the menu command Edit→Delete.

To rename a database object:
1. Select the database object type in the Database pane of the Base window;
2. Select a database object;
3. Rename the object:
   3.1. Click the Rename button in the object toolbar:
   or
   3.2. Perform the menu command Edit→Rename.

Useful tip:
Commands for actions with a database object are easy to find in the menu that opens upon right-clicking on the object:
Creating a Table in Design View

Like the other database objects, tables can also be created manually in design view. Fields are added to a table in the form of vertical columns, and it is possible to set the field type and other properties.

Field type determines the type of data to be entered, e.g., number, text, date, checkbox.

Each field type also has additional properties, such as the amount of characters in a number, format, length of text, mandatory/optional filling of the field. The properties are changed in the Field Properties pane.

Field types depend on the database mechanism used.

Frequently used field types in OpenOffice.org Base:

- Text with a fixed amount of characters, **Text (fix)** – the field saves the amount of characters set by the user.
- Text with a maximum amount of characters, **Text** – the default maximum amount of characters is 100.
- Text with a maximum amount of characters, **Memo** – similar to **Text**, but the default maximum amount of characters is 2147483647.
- **Yes/No** – a checkbox is displayed in the field. The user can tick it with a mouse click.
- **Number** – the field must contain a number, otherwise the application will display an error.
- **Integer** – a number to which automatic actions can be applied, such as automatic numbering.
- **Date** – month, day and year information in a specific format.

To add a field to a table:

1. Open a table in design mode;
2. Enter the **Field Name** in the respective column;
3. Choose the **Field Type** in the respective column;
4. Set the **Field properties** in the respective pane.

**Task 5.2. Add artist data to the existing database music_cd.odb. Set the field ID as the automatic primary key.**
1. Open the database `music_cd.odb` from the subfolder 5.2_table of the folder 5_databases:
   1.1. Open OpenOffice.org Base with the menu command Applications->Office->OpenOffice.org Database;
   1.2. In the Database Wizard dialogue box, select Open an existing database file:
   1.3. Click Open:
   1.4. In the Places pane of the Open dialogue box, select the user folder Documents;
   1.5. In the folder content pane, select the folder 5_databases;
   1.6. Click Open;
   1.7. Select the folder 5.2_table
   1.8. Click Open;
   1.9. Select the file music_cd.odb;
   1.10. Click Open.

2. Create a new table tbl_artists:
   2.1. In the Database pane, select Tables;
   2.2. In the Tasks pane, click on Create Table in Design View;
   2.3. Create table fields:
      2.3.1. Click on a cell;
      2.3.2. Enter text in the cells of the column Field name:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Text [VARCHAR]</td>
</tr>
<tr>
<td>Artist</td>
<td>Text [VARCHAR]</td>
</tr>
<tr>
<td>Year founded</td>
<td>Text [VARCHAR]</td>
</tr>
<tr>
<td>Country</td>
<td>Text [VARCHAR]</td>
</tr>
<tr>
<td>Active</td>
<td>Text [VARCHAR]</td>
</tr>
<tr>
<td>Date added</td>
<td>Text [VARCHAR]</td>
</tr>
<tr>
<td>Notes</td>
<td>Text [VARCHAR]</td>
</tr>
</tbody>
</table>

3. Change the field type of the field ID:
   3.1. Click on the cell opposite to ID under Field Type;
   3.2. In the menu, choose INTEGER:
3.3. In the **Field Properties** pane, set the property **AutoValue** to **Yes**:

![Field Properties pane with AutoValue set to Yes]

4. Set the **Artist** field as mandatory:
   4.1. Select the **Artist** field;
   4.2. In the **Field Properties** pane, set **Entry required** to **Yes**:

![Field Properties pane with Entry required set to Yes]

5. Change the type of the field **Year founded**:
   5.1. Choose the type **NUMBER** under **Field Type**;
   5.2. In the **Field Properties** pane, set the **Length** value to 4 characters.

6. Change the type of the field **Active** – tick the checkbox:
   6.1. Change the type **Yes/No [BOOLEAN]** under **Field Type**.

7. Change the type of the field **Date added**:
   7.1. Set the field type to **Date**;
   7.2. In the **Field properties** pane, click on the date format selection button:

![Field Properties pane with date format MMM D, YYYY]

7.3. In the **Field Format** dialogue box, choose the date format **MMM D, YYYY**

![Field Format dialogue box]

7.4. Confirm the selection of the format by clicking **OK**.

8. Move the table field **Active** to the end:
   8.1. Left-click on the selection cell of the field:
8.2. Perform the menu command Edit->Cut;
8.3. Left-click on the selection cell of an empty field at the end of the table;
8.4. Perform the menu command Edit->Paste.

9. Make sure that the field ID is set as the primary key of the table records:
   9.1. Right-click on the selection cell of the ID field;
   9.2. Make sure that there is a tick in the menu at Primary Key:

10. Save the table in the database:
    10.1. Click the Save button in the toolbar
    or
    10.2. Perform the menu command File->Save in the table window;
    10.3. In the Save As dialogue box, enter the table name tbl_artists;
    10.4. Confirm by clicking OK.

11. Close the table:
    11.1. Click the Close button in the title bar of the table window.

**Useful tip:**

If no primary key has been defined for the table, a dialogue box called No primary key appears.

Upon clicking Yes, a primary key field called ID is automatically added to the table. If No is chosen, a primary key is not created.

12. Rename the table CD-Collection:
    12.1. Select the table CD-Collection in the Tables pane;
    12.2. Perform the menu command Edit->Rename;
    12.3. In the Table Name field of the Rename to dialogue box, change the table name to tbl_CD-Collection;
    12.4. Click OK.

13. Close the database music_cd.odb:
    13.1. Click on the window close button in the title bar:
    13.2. Confirm the changes by clicking Save in the dialogue box.
or
13.1. Perform the menu command **File→Save**;
13.2. Close the application window by clicking the **Close** button.

**Modifying a Form in Design View**

Existing database forms can be supplemented with pictures, graphical objects, a header and footer (creating a form in design view is not examined in this material). Opening a form in design view activates the toolbars **Form Design** and **Form Controls** with form elements.

**Useful tip:**
A form is displayed in web layout view by default. It is easier to edit a form in print layout view.

**To add a header to a form:**

1. Open the selected form in design view;
2. Perform the menu command **View→Print Layout**;
3. Perform the menu command **Insert→Header→Default**;
4. Click inside the header area;
5. Enter (edit) text;
6. Save the changes:
   6.1. Perform the menu command **File→Save** or
   6.1. Click the **Save** button in the toolbar:

A – Header area; B – Footer area

*Picture No. 7. A form in design view with text in the header and footer in print layout*
Module 5

Task 5.3. Add header text to a form in a database. Format the background of the form. Remove the footer text. Delete the form.

1. Open the database form.odb:
   1.1. Perform the menu command Places->Documents in the top panel of the desktop;
   1.2. Open the folder 5_databases with a double left click;
   1.3. Open the folder 5.3_form_design with a double left click;
   1.4. Open the file form.odb with a double left click.

2. Open a form in design view:
   2.1. In the Database pane, select the object type Forms;
   2.2. In the Forms pane, select the form frm_artists;
   2.3. Click the Edit button in the toolbar:

3. Change the form view to print layout view:
   3.1. Perform the menu command View->Print Layout in the form window.

4. Add text to the header:
   4.1. Perform the menu command Insert->Header-Default;
   4.2. Enter the following text in the header: Artists from my collection.

5. Format the text to make it red with font size 16:
   5.1. Select the header text;
   5.2. Click the toolbar button Font Color;
   5.3. Choose Light red:
   5.4. In the Size menu, choose font size 16:

6. Centre the header text:
   6.1. Click the Centered button in the Formatting toolbar:

7. Remove the background fill of the form:
   7.1. Perform the menu command Format->Page;
   7.2. Open the Background tab by clicking on it;
   7.3. Set the Background color to No fill:

8. Remove the footer from the form:
   8.1. In the Page Style dialogue box, open the Footer tab by clicking on it;
   8.2. Remove the tick from the Footer On checkbox:
8.3. Click OK in the dialogue box.
9. Close the form:
   9.1. Click the Close button in the title bar of the form window;
   9.2. In the dialogue box, click Save.
10. Delete the form frm_CD-Collection:
    10.1. Select the form frm_CD-Collection in the Forms pane;
    10.2. Press the Delete key on the keyboard;
    10.3. In the dialogue box, confirm the deletion of the database object by clicking Delete:

11. Close the database:
    11.1. Click the Close button in the title bar of the database window;
    11.2. In the dialogue box, click Save.

### Entering, Modifying and Sorting Data

Databases store data in tables. Changes in the data can be made both by directly entering them in the table and by using forms linked directly and indirectly (with a query) with the table.

#### Entering Data in a Database

To enter (modify) data in a table:

1. Select a table;
2. Open the table in data view;
3. Select a data field in a record;
4. Enter (edit) values – text, numbers, or other.

To enter (modify) data in a form:

1. Select a form;
2. Open the form in data view;
3. Select a record:
   3.1. Enter the number of the record in the Absolute Record field:
3.2. Press Enter on the keyboard;  
or  
3.1. Use the navigation buttons (Image No. 4);  
4. Click inside the corresponding field;  
5. Enter (modify) data.  

Creating a New Record  

To create a new record while using a table in data view, no additional actions are required. The fields of a new record are inserted below the last record in the table.  

To create a new record while using a form:  

1. Open a form in data view;  
   1.1. Go to the last record;  
   1.2. Click the navigation button Next Record;  
   or  
   1.1. Click the New Record button (Image No. ).  

Deleting a Record (Data)  

Records can be deleted both in a table and in a form linked to it.  

To delete a record in a table:  

1. Open a table in data view;  
   1.1. Click on the selection cell to select the record (Image No. );  
   1.2. Press Delete on the keyboard;  
   or  
   1.1. Click inside any field of the record;  
   1.2. Perform the menu command Edit→Delete Record:  

   ![Menu Command](Image No. )  

2. Confirm the deletion in the dialogue box by clicking Yes.  

To delete a record in a form:  

1. Open a form in data view;  
2. Go to the necessary record:  
   2.1. Use the navigation buttons;  
   or  
   2.1. Enter the number of the record in the Record field;
2.2. Confirm the entered number by pressing the Enter key;
3. Click the Delete Record button in the control toolbar (Image No.);
4. Confirm the deletion in the dialogue box by clicking Yes.

The deletion of individual data from a database is performed in a table or form by deleting values in the selected field.

**To delete data in a record field:**

1. Select a field value;
2. Press Delete on the keyboard

**Note!**
The deletion of a record or individual data is irreversible!

**Field Index Management**

Field indexing makes finding records faster.

**To manage index fields:**

1. Open a table in design view;
2. Perform the command Tools–Index Design:

**Image No. 8. Actions with indexes**

**To index a table field:**
1. Open the **Indexes** dialogue box;
2. Click the **New Index** button;
3. Enter a name for the index;
4. In the menu, select the field to be indexed:

![Indexing Dialogue Box](image)

5. Close the dialogue box by clicking **Close**.
6. Confirm saving by clicking **Yes**.

**Note!**
Indexing too many fields can slow the application down!

### Record Sorting

Records in tables, forms and queries can be easily sorted in ascending or descending order by a selected field. Sorting by multiple conditions is also possible – first sort by one field, then continue sorting by another.

Record sorting is performed similarly in the previously mentioned database objects, and it is easy to do by using the toolbar buttons:

![Sort Buttons](image)

A – **Sort** button to sort by several fields; B – **Sort Ascending** button to sort in alphabetical order; C – **Sort Descending** button to sort in reverse alphabetical order

*Image No. 9. Buttons for record sorting*

**To sort table records in ascending order by a selected field:**

1. Open a database table (form, query) in data view;
2. Select the field by which to sort;
3. Click the **Sort Ascending** button;
4. Save the changes in the table.

**To sort table records by several fields:**

1. Open a database table in data view;
2. Click the **Sort** button;
3. In the first **Field Name** menu, select the first field by which to sort;
4. In the **Order** menu, choose the sort order: **Ascending** for alphabetical order, **Descending** for reverse alphabetical order;
5. Repeat the steps for the following sort conditions;
6. Confirm by clicking **OK**:

**Record Search**

When working with data in large tables, it may be difficult to locate specific data for viewing, modification or replacement with a different value. Like in other applications of the OpenOffice.org suite, it is possible to use a search command.

**To find a value in a database table:**

1. Open a table in data view;
2. Click the **Find Record** button in the toolbar:

3. In the **Record Search** dialogue box, enter the value to search for and the search settings;

   **Image No. 10. Record search**

   A – The value to search for; B – Search in **All Fields** or a **Single Field**, C – Optional search settings; D – The number of the record found
4. Click **Search**;
5. View the result marked in the table with a red border, perform the necessary actions;
6. To continue searching, click **Search** again;
7. Stop searching by clicking **Close** in the **Record Search** dialogue box.

Searching in a form is done in a similar way.

**Task 5.4. Modify the database data.odb:**

1. Open the database **data.odb** from the subfolder **5.4_data** of the folder **5_databases**:
2. Perform the menu command **Places→Search for Files** in the top panel of the desktop;
   2.1. In the **Name contains** field of the search dialogue box, enter the database filename **dati**;
   2.2. Click **Find**;
   2.3. Double left-click on the file **data.odb** that has been found:

![file selection]

3. Add new records to the table **tbl_artists**:
   3.1. In the **Database** pane, select the object **Table**;
   3.2. In the **Tables** pane, select the table **tbl_artists**;
   3.3. Open the table in data view:
      3.3.1. Click the button **Open Database Object** in the **Table** toolbar:

![open database object]

3.4. Adjust the width of the **Artist** and **Notes** columns so that the entire content of the fields is visible:
   3.4.1. Double-click on the dividing line to the right of the field’s name;
   
   ![columns adjustment]

   or

   3.4.1. Click on the dividing line;
   3.4.2. Drag right until the entire content of the fields is visible:
   
   ![columns adjustment]

3.5. Add records to the table:

<table>
<thead>
<tr>
<th>Artist</th>
<th>Year founded</th>
<th>Country</th>
<th>Active</th>
<th>Date added</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dire Straits</td>
<td>1977</td>
<td>UK</td>
<td></td>
<td>Feb 8, 2011</td>
<td>leader Mark Knopfler</td>
</tr>
<tr>
<td>Linkin Park</td>
<td>1996</td>
<td>USA</td>
<td>Yes</td>
<td>Feb 8, 2011</td>
<td></td>
</tr>
<tr>
<td>Cream</td>
<td>1966</td>
<td>UK</td>
<td></td>
<td>Feb 8, 2011</td>
<td></td>
</tr>
</tbody>
</table>
Useful tip:
The content of identical fields can be copied and pasted with the commands **Copy** and **Paste**.

The format of the **Date added** field is set as **MMM D, YYYY** (the first three letters of the month, the date, the year with four digits).

There is a **checkbox** in the **Active** field.

4. Delete the record about **Monty Python**:
   4.1. Click inside the table field containing the text **Monty Python**;
   4.2. Perform the menu command **Edit→Delete record**;
   4.3. In the dialogue box, confirm the deletion by clicking **Yes**.

5. By using the search tool in the table, change an incorrect record with the value **1937** to **1977**:
   5.1. Open the search tool by clicking the **Find Record** button in the **Table Data** toolbar of the table window:
   5.2. In the **Text** field of the search dialogue box, enter **1937**;
   5.3. Click **Search**;
   5.4. Close the search dialogue box by clicking **Close**;
   5.5. Change the data in the field of the record to **1977**;
   5.6. Do not close the table.

6. Create new records by using the database form **frm_artists**:

<table>
<thead>
<tr>
<th>Artist</th>
<th>Year founded</th>
<th>Country</th>
<th>Active</th>
<th>Date added</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>U2</td>
<td>1976</td>
<td>Ireland</td>
<td>Yes</td>
<td>Feb 10, 2011</td>
<td></td>
</tr>
<tr>
<td>Run D.M.C.</td>
<td>1981</td>
<td>USA</td>
<td></td>
<td>Feb 10, 2011</td>
<td>Hip Hop</td>
</tr>
<tr>
<td>Vacuum</td>
<td>1996</td>
<td>Sweden</td>
<td>Yes</td>
<td>Feb 10, 2011</td>
<td></td>
</tr>
</tbody>
</table>

6.1. Switch to the database window:
   6.1.1. Click on the button of the window in the bottom panel of the desktop:
   6.2. In the **Database** pane, choose the object **Forms**;
   6.3. Select the form **frm_artists**;
   6.4. Press **Enter** on the keyboard;
   6.5. Click the **New Record** button in the **Form Controls** toolbar:
   6.6. Fill the fields of the record;
   6.7. Click the navigation button **New Record**;
   6.8. Repeat the steps for the other records.

7. Make sure that the data entered in the form appear in the table **tbl_artists**:
7.1. Switch to the table tbl_artists:
   7.1.1. Click the corresponding button of the table window in the bottom panel of the desktop.
7.2. Click the Refresh button to refresh the table:

7.3. View the new records.

8. Supplement record No. 18 in the database:
   8.1. Switch to the form window by clicking the corresponding button in the bottom panel of the desktop;
   8.2. In the Record field, enter record number 18;
   8.3. Press Enter on the keyboard;
   8.4. In the Country field, enter USA;
   8.5. Press Enter on the keyboard;
   8.6. In the Date added field, enter 03/23/11;
   8.7. Press Enter on the keyboard.

9. Delete the record of the artist Falco;
   9.1. Find the record that contains the word Falco in the Artist field:
      9.1.1. Click the Find Record button in the form navigation bar;
      9.1.2. In the Text field of the search dialogue box, enter Falco;
      9.1.3. Click Search;
      9.1.4. Close the search dialogue box by clicking Close;
   9.2. Click the Delete Record button in the form navigation bar:

   9.3. Confirm the deletion of the record by clicking Yes in the dialogue box.

10. Close the database:
    10.1. Close the table, saving the changes:
       10.1.1. Click the Close button in the title bar of the database window;
       10.1.2. In the dialogue box, click Save.
    10.2. Close the form:
       10.2.1. Click the Close button in the title bar of the database window;
       10.2.2. In the dialogue box, click Save.
    10.3. Close the database, saving the changes:
       10.3.1. Click the Close button in the title bar of the database window;
       10.3.2. In the dialogue box, click Save.

Data Retrieval

There would be little point in storing information in databases if it was not possible to view the data and use it further.

Applying Filters
Using filters is one of the simplest ways of data selection. In Base, filters can be applied to records in tables, forms and queries. Filters are applied by using toolbar buttons: A – AutoFilter; B – Apply filter; C – Standard filter; D – Remove filter.

The automatic filter selects data by determining whether they match the value of the selected field.

**To use the automatic filter:**

1. Open a database object in data view;
2. Select the field by which to select records;
3. Click the **AutoFilter** button in the toolbar.

**Useful tip:**
The automatic filter can be applied successively several times, selecting records by multiple conditions. An applied filter is indicated by a depressed **Apply Filter** button.

The standard filter in Base allows selecting records successively by three conditions in tables and queries.

**To use the standard filter:**

1. Open a database table (query) in data view;
2. Click the **Standard Filter** button;
3. In the **Standard Filter** dialogue box:
   3.1. Select a table field for the first criterion;
   3.2. Choose a condition;
   3.3. Enter the values to search for;
   3.4. Create the next condition;
   3.5. Confirm by clicking **OK**.

A – Logical operator for connecting conditions; B – Field; C – Condition; D – Field value
For example, the filter shown in the picture selects records that contain the value **1965** in the *Year founded* field and the text **UK** in the *Country* field:

<table>
<thead>
<tr>
<th>ID</th>
<th>Year founded</th>
<th>Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1965</td>
<td>UK</td>
</tr>
</tbody>
</table>

**To remove a filter:**

Click the **Remove Filter/Sort** button (*D* in Image No. 11).

**Note!**

Text in filters and queries (see below), when specifying the values to search for, is placed inside apostrophes, e.g., ‘UK’.

**Creating Queries**

A query selects records in a database according to requirements set by the user. The result of a query can be set to include either all the fields of database table records, or only specified fields.

As with the other database objects, queries can be created with the help of a wizard or in design view, by manually setting the information selection criteria and determining the selection values.

Mathematical and logical operators, negation and combinations thereof are used to set the criteria in queries:

- **Equal** ( = )
- **Smaller than** ( < )
- **Greater than** ( > )
- **Like** – equal to the specified text
- **Null** – empty field
- **And**
- **Or**

Negation is created by adding the word **Not**.

Wildcard characters are used to substitute a part of text or number:

- * (asterisk) or % (percent sign) – substitutes any number of characters
- ? (question mark) or _ (underscore) – substitutes any single character

For example, selection by the value ‘*end’ will return all data ending with the characters end.

For a query to be performed, it is not necessary to include all the fields of a table, and it is also possible to include fields from a different table.
Creating a Query with a Wizard

The built-in wizards of OpenOffice.org allow creating a query quickly and easily. A query is given a name and saved just like any other database object. A query is usually created in such a way as to ensure that it can be reused. After supplementing information in a database, the query will include in its results the newly added records, as well.

The wizard consists of eight steps.

To create a query by using a wizard:

1. In the database window, select the object Query;
2. In the Tasks pane, click on Use Wizard to Create Query;
3. Select a table in the Tables menu;
4. Specify what fields from the table to display in the query result;
5. Select ascending or descending sorting order;
6. Specify the selection criteria. The wizard allows specifying three fields and creating conditions for them;
7. If necessary, set additional mathematical operations to be performed with the values in the returned fields;
8. If necessary, assign aliases (alternative explanatory names) to the table fields;
9. In the last step, check the query overview and name the query.
10. Finish the wizard by clicking Finish.

Task 5.5. By using the wizard, create a query in the artist database table tbl_artists, selecting:

- Artists from the United Kingdom (UK);
- With year founded after 1970;
- The selected records must be sorted in descending order by the band name (the Artist field);
- The results must display the fields Artist, Year founded, Country and Notes.

1. Open the database uk.odb in the subfolder 5.5_query_from_wizard of the folder 5_databases:
   1.1. Perform the menu command Places->Documents;
   1.2. Open the folder 5_databases with a double left click;
   1.3. Open the folder 5.5_query_from_wizard with a double left click;
   1.4. Open the database uk.odb with a double left click.
2. Create a query as specified in the task:
   2.1. In the Database pane, select the object type Queries;
   2.2. In the Tasks pane, click on Use Wizard to Create Query;
   2.3. In step one:
      2.3.1. In the Tables menu under Select the fields (columns) for your query, select the table tbl_artists;
2.3.2. In the pane **Fields in the Query**: add table fields **Artist, Year founded** and **Notes**;

2.3.3. Click **Next**;

2.4. Step two – **Select the sorting order**:
   
   2.4.1. In the **Sort by** menu, select the **Artist** field;
   
   2.4.2. Choose reverse alphabetical order – **Descending**;
   
   2.4.3. Click **Next**.

2.5. Step three – **Select the search conditions**:

   2.5.1. In the **Fields** menu, select the **Country** field;
   
   2.5.2. In the **Condition** menu, select **like**;
   
   2.5.3. In the **Value** field, enter **UK** (in uppercase and without apostrophes);
   
   2.5.4. In the next line, choose **Year founded** in the **Fields** menu;
   
   2.5.5. Set the **Condition** to **(is greater than)**;
   
   2.5.6. In the **Value** field, enter **1970**;
   
   2.5.7. Make sure that **Match all of the following** has been selected (logical operator **AND**):
2.5.8. Click Next;
2.6. In step four, it is possible to perform additional arithmetical operations in the query fields;
2.7. Step seven allows assigning alternative names to the fields to be included in the results, by entering them in the corresponding Alias fields:

2.8. Step eight – overview:

2.8.1. In the Name of the query field, enter *qry_artists*;
2.8.2. Click Finish:

3. View the result of the query:

3.1. Switch to the query window by clicking the corresponding button in the bottom panel of the desktop:
3.2. Close the query window by clicking the Close button in the title bar.

4. Open the newly created query in design view:
   4.1. Select the query qry_artists in the database pane Queries, if necessary;
   4.2. Perform the menu command Edit->Edit.

5. View the selection criteria:

   ![Selection Criteria Example]

6. Close the database, saving the changes:
   6.1. Close the query window by clicking the Close button in the title bar;
   6.2. Close the database window;
   6.3. In the dialogue box, confirm saving the changes by clicking Yes.

---

**Note!**

In **Linux**, the letter case matters. For example, in selection criteria, the value `uk` (lowercase) is not the same as `UK` (uppercase).

---

**Creating a Query in Design View**

Like the other database objects, queries can also be created in design view, by including one or several database tables. Design view is convenient for modifying existing queries, adding new fields and changing criteria. Design view allows specifying a selection criterion for a field without including the field itself in the results table.

**To create a query in design view:**

1. Select the object type Queries in the database;
2. Perform the command Create Query in design view;
3. Select and add the tables from which to retrieve data for the result;
4. Select the table fields that are to be included in the query result;
5. Set the query criteria for the fields;
6. Save the query, entering a name for it.

**Task 5.6. Create a query from two interlinked tables, which will select albums of UK bands released after 1979 in the database.**

1. Open the database albums.odb from the subfolder 5.6_query_design of the folder 5_databases:
   1.1. Perform the menu command Places-->Documents;
1.2. Perform the file browser menu command Go→%databases;
1.3. Perform the file browser menu command Go→%query_design;
1.4. Select the file albums.odb;
1.5. Press Enter on the keyboard.

2. Create a query in design view:
   2.1. In the Database pane, select the database object type Queries;
   2.2. In the Tasks pane, click on Create Query in design view;
   2.3. In the dialogue box Add Table or Query, add tables:
      2.3.1. Select the table tbl_albums;
      2.3.2. Click the Add button;
      2.3.3. Repeat the actions for the table tbl_artists;
      2.3.4. Click the Close button to close the dialogue box.

2.4. In the Field menu, select the table fields to be included in the query:
   2.4.1. From the table tbl_albums – the fields Album, Format, Year;
   2.4.2. From the table tbl_artists – the fields Artist, Country;
   2.5. In the Country column, remove the tick from the Visible checkbox;

Useful tip:
The selected table can be changed in the menu of the Table field.

2.6. Create the data selection criteria. In the Criterion field, enter:
   2.6.1. In the Year column, enter >=1979 – albums released in or after 1979;
   2.6.2. In the Artists column, enter UK (uppercase) – bands from the United Kingdom.
43  Module 5

<table>
<thead>
<tr>
<th>Field</th>
<th>Album</th>
<th>Format</th>
<th>Year</th>
<th>Artist</th>
<th>Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alias</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table</td>
<td>tbl_albums</td>
<td>tbl_albums</td>
<td>tbl_albums</td>
<td>tbl_artists</td>
<td>tbl_artists</td>
</tr>
<tr>
<td>Sort</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Visible</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Function</td>
<td>&gt;= 1979</td>
<td></td>
<td></td>
<td></td>
<td>'UK'</td>
</tr>
</tbody>
</table>

**Note:**

OpenOffice.org Base will change the entered criteria to suit the syntax of the programme – a space will be inserted before the number **1979**, and the letters **UK** will be enclosed in apostrophes.

3. Run the query:
   3.1. Click the **Run Query** button in the toolbar:

4. View the result of the query:

   ![Query Result](image)

**Note:**

Although the query also uses the **Country** field of the table **tbl_artists**, it will not be displayed in the result, as the checkbox of the property **Visible** has not been ticked.

5. Sort the query results in ascending order by artist name:
   5.1. Left-click on an Artist field;
   5.2. Click the **Sort Ascending** button in the toolbar:

6. Save the query:
   6.1. Click the **Save** button in the toolbar;
   6.2. Name the query **qry_selection_1979**;
   6.3. Confirm by clicking **OK**.

**Information Output**

**Reports**
OpenOffice.org Base allows creating and printing reports, including in them specific selected data or all the information stored in a database. The built-in wizard makes it easier to create and design a report. A report is saved as a database object and can be reused – with modifications, if necessary. A report can be created both from a database table and from a query with selected results.

**To create a report with a wizard:**

1. In the Database pane of the Base window, select the object type Reports;
2. In the Tasks pane, click on Use Wizard to Create Report;
3. In the Report Wizard dialogue box:
   3.1. In step one Field Selection, in the Tables or queries menu select the table or query and the fields to be included in the report;
   3.2. If necessary, change the position of the selected field by using the Up and Down buttons:

   ![Report Wizard dialogue box]

   3.3. Step two Labeling Fields allows changing the Labels (field names) of the fields displayed in the report:
3.4. In step three **Grouping**, if necessary, select the fields by which to group the records in the report, e.g., **Artist**:

3.5. In step four **Sort Options**, choose the data sorting order:
3.6. In step five **Choose Layout**, choose the **Layout of data** and **Layout of headers and footers**:

3.7. In step six **Create report**, finish the creation of the report by choosing:

- **Static report**, if the report is to include the current records of the database;
- **Dynamic report**, if the report is to include the records from the database as at the time when the report is opened, refreshing it each time.

4. Save the report, entering a name for it.

**Task 5.7.** Create a report for the table tbl_albums of the database report.odb, including all fields, grouping by the Artist field, and sorting in ascending order. Data layout style **Align left – Modern**, landscape orientation, **dynamic refreshing**.

1. Open the database report.odb from the subfolder 5.7_reports of the folder 5_databases:
1.1. Perform the menu command **Places->Documents**;
1.2. In the file browser, perform the menu command **Go->Locations**;
1.3. In the **Location** field of the file browser, add `/5_databases/5.7_reports` to the address

**Useful tip:**
The folders automatically entered by the file browser can be confirmed by pressing **Tab** on the keyboard.

1.4. Press **Enter** on the keyboard;
1.5. Double left-click to open the file **report.odb**.

2. Create a report as specified in the task:
   2.1. In the **Database** pane, select the object **Reports**;
   2.2. In the **Tasks** pane, click on **Use Wizard to Create Report**;
   2.3. In step one of the wizard:
      2.3.1. In the **Tables or queries** menu, select the database table **tbl_albums**;
      2.3.2. Include all fields in the report;
      2.3.3. Click **Next**.
   2.4. Step two allows changing the names of the fields in the report. Leave the default names;
      2.4.1. Click **Next**.
   2.5. Click **Next** to accept the default grouping settings;
   2.6. In step four **Sort options**:
      2.6.1. In the **Sort by** menu, select the **Artist** field;
      2.6.2. Make sure that sorting in **Ascending** order has been chosen;
      2.6.3. Click **Next**.
   2.7. Choose the layout in step five:
      2.7.1. In the **Layout of data** pane, select the style **Align left– Modern**;
      2.7.2. Make sure that **Landscape** orientation has been chosen;
      2.7.3. Click **Next**.
   2.8. Finish the creation of the report:
      2.8.1. In the field **Title of report**, enter the name **rpt_albums**;
      2.8.2. Make sure that dynamic refreshing of content (**Dynamic report**) has been selected;
      2.8.3. Click **Finish**.

3. View a print preview of the report:
   3.1. Perform the menu command **File->Page Preview**;
4. Close the report by clicking the **Close** button in the title bar of the report window;
5. Open the newly created report in design view:
5.1. Select the report in the Reports pane;
5.2. Click the Edit button in the toolbar:

6. Insert text in the header of the report:
6.1. Click inside the header after the word Title:
6.2. Enter Albums in collection

7. Change the page format to A4:
7.1. Perform the menu command Format→Page;
7.2. Open the Page tab;
7.3. In the Paper Format menu of the Page Style dialogue box, select A4:
7.4. Open the Organizer tab of the Page Style dialogue box;
7.5. In the Next Style menu, select First Page to apply the changes to the following pages, as well:
7.6. Close the dialogue box by clicking OK.

8. Delete the Format field in the report:
8.1. Click on the Format field;
8.2. Click the Delete Column button in the table toolbar:

9. Switch the fields Artist and Album:
9.1. Select the text Artist;
9.2. Perform the menu command Edit→Cut;
9.3. Click after the Album field;
9.4. Perform the menu command Edit→Paste;
9.5. Select the text Album;
9.6. Left-click on the selected text;
9.7. While holding the mouse button, drag the selected field to the next column;
9.8. Release the mouse button.

10. Close the report:
10.1. Perform the menu command File→Exit;
10.2. In the dialogue box, confirm saving the changes by clicking Yes.

11. Close the database:
   11.1. Click the Close button in the title bar;
   11.2. Confirm the changes by clicking Yes.

Data Export

Export commands are used to transfer data to a different application. Although Base does not have direct commands for export of database tables and queries, the integrated OpenOffice.org environment provides many possibilities for saving data in a different file format.

Note:

Data export is performed from the structure of the actual database, and is usually executed with direct database commands or with an executable script written in a programming language. This type is not examined in this material, as it requires special knowledge.

Tables and Queries

To save data in a different format:

1. They must be copied into OpenOffice.org Writer or Calc;
2. Then use the menu commands File→Save As or File→Export, or File→Export as PDF.

In Base these actions can be performed with:
- Tables;
- Query results;
- Individual table and query result records.

The easiest way to do this is by dragging. It is also possible to use the standard commands Copy and Paste.

Task 5.8. Save database table data in comma-separated values (csv) format.
1. Open the database csv_export.odb from the subfolder 5.8_export of the folder 5_databases:
   1.1. Perform the menu command Places→Documents;
   1.2. Select the folder 5_databases;
   1.3. Press Enter on the keyboard;
   1.4. Select the folder 5.8_export;
   1.5. Press Enter on the keyboard;
   1.6. Select the file csv_export.odb;
   1.7. Press Enter on the keyboard.
2. Copy a table into Calc:
   2.1. Select the table tbl_artists:
2.2. In the **Database** pane, select the database object **Tables**;
2.3. In the **Tables** pane, select the table **tbl_artists**;
2.4. Perform the menu command **Edit->Copy**;
2.5. Create a new **Calc** document:
   
   2.5.1. Perform the menu command **File->New->Spreadsheet**;

2.6. Perform the menu command **Edit->Paste** in the newly opened spreadsheet window:

3. Save the **Calc** document in **csv** format:
   
   3.1. Perform the menu command **File->Save**;
   
   3.2. In the **Name** field of the **Save** dialogue box, enter the filename **artists**;
   
   3.3. In the **File Type** menu, select **Text CSV (.csv)**;

   3.4. Confirm saving by clicking **Save**;

   3.5. In the alert dialogue box, confirm the selection of the format – **Keep Current Format**;

   3.6. In the dialogue box **Export of text files**, confirm the action by clicking **OK**;
3.7. In the next dialogue box, confirm saving the worksheet by clicking OK.

Forms and Reports

To save form or report data in a different format:

1. Open the form (report);
2. Perform the menu command File→Save Copy As;
3. Specify the file type in the dialogue box.

To export in Adobe Acrobat format, perform the command File→Export as PDF.

Note!
When saving form data in a different format, the database record saved will be the one that is opened in the form.

Printing

Reports

Printing data in Base is easiest in the form of a report. As a report can include all table data and fields, only specific fields, or selected results, this approach will ensure the best results. Query results are also best printed as a report.

To print a report for a table or query:

1. Perform the command File→Print;
2. Set the additional options in the Print dialogue box;
   2.1. Select the printer;
   2.2. Select All or specific Pages;
2.3. Set the number of copies.

3. Click Print.

A – Optional settings; B – Selecting the print range; C – Selecting the printer; D – Number of copies

Image No. 13. Printing a report

Forms

OpenOffice.org Base allows printing database information by using form layout.

Useful tip:
Before printing a form, choose print layout view. Then the form will appear the same in the display as when printed out on paper.

To view a form in print layout:
In the form window, perform the menu command View→Print Layout

To print database information in form view:
1. Open a database form in data or design mode;
2. Change the form view to print layout, if necessary;
3. Perform the menu command File→Print;
4. Select the printer;
5. In the Print dialogue box, set:
   5.1. All Pages to print all records in form layout;
   5.2. Pages – to print specific records and/or a range of records.
6. Specify the Number of copies in the respective field;
7. Click Print.

Tables and Queries

Tables and query results to be printed, in full or in part, are first copied into an OpenOffice.org Writer document. After that, the editing and printing features of this application are used. The steps for printing tables and queries are similar.
To print a database table or part thereof:

1. Select a database table;
2. Copy the table (Ctrl+C);
3. Open a new Writer document;
4. Perform the paste command using one of the available methods (Ctrl+V);
5. Select the pasting type (table, field, text);
6. Select all or individual database fields for pasting into the text document;
7. Complete the pasting;
8. Edit and format the text in the document, if necessary;
9. Print from the Writer environment.

To change page settings in Writer:

Open the Page Style dialogue box with the menu command Format->Page.

Frequently used page settings in the Page tab of the dialogue box:

- **Format** – the size of the paper sheet in the printer;
- **Orientation** – horizontal (Landscape) or vertical (Portrait) orientation of the page;
- **Margins** – the size of the page margins in units of measurement (by default – inches).

![Page Style Dialogue Box](image)

**Task 5.9. Prepare for printing the results of the query qry_artists and the table tbl_artists of the database print.odb.**

1. Open the database print.odb from the subfolder 5.9_print of the folder 5_databases:
   1.1. Perform the menu command Places->Search for Files in the top panel of the desktop;
1.2. In the **Name contains** field of the dialogue box, enter the database filename **print**;

1.3. Click **Find**;

1.4. Double left-click on the file **print.odb** that has been found.

2. Copy the database table **tbl_artists** into a new **Writer** document:

2.1. In the **Database** pane, select the object **Tables**;

2.2. In the **Tables** pane, right-click on the table **tbl_artists**;

2.3. In the menu, choose the **Copy** command:

2.4. In the database window, perform the menu command **File->New->Text Document**;

2.5. Right-click inside the text document;

2.6. In the menu, choose the **Paste** command;

2.7. In the dialogue box **Insert database Columns**, insert all fields in the **Table column(s)** pane:

2.8. Click **OK** in the dialogue box.

3. Save the text document as **PDF**:

3.1. In the **Writer** window, perform the menu command **File->Export as PDF**;

3.2. In the **PDF Options** dialogue box, confirm the default settings by clicking **Export**;

3.3. In the **Name** field, enter the filename **artists**;

3.4. Choose the **Documents** folder as the save location, if necessary:

3.4.1. Select the **Documents** folder in the **Place** pane of the **Save** dialogue box;

3.5. Click **Save**.

4. Close the **Writer** window:

4.1. Click the **Close** button in the title bar;

4.2. Click **Discard** in the dialogue box.

5. Copy the results of the database query **qry_artists** into a new **Writer** document:

5.1. In the **Database** pane, select the object **Queries**;

5.2. In the **Queries** pane, select the query **qry_artists**;

5.3. Perform the menu command **Edit->Copy**;

5.4. In the database window, perform the menu command **File->New->Text Document**;

5.5. In the **Writer** window, perform the menu command **Edit->Paste**;

5.6. In the dialogue box **Insert database Columns**, move the fields **Artist**, **Country**, **Notes** to the **Table Column(s)** pane:

5.7. Click **OK**.

6. Set page format A4:
6.1. Perform the menu command **Format→Page**;
6.2. Open the **Page** tab of the dialogue box by clicking on it;
6.3. In the **Paper format** menu, select page format **A4**;
6.4. Close the dialogue box by clicking **OK**.

7. **Save** the text document:
   7.1. Perform the menu command **File→Save**;
   7.2. In the **Save** dialogue box, select the **Documents** folder as the save location, if necessary;
   7.3. In the **Name** field, enter the filename **selected**;
   7.4. Press **Enter** on the keyboard;
   7.5. Close the **Writer** window.

8. Close the database without saving the changes:
   8.1. Click the **Close** button in the title bar;
   8.2. In the dialogue box, click **Discard**.

9. Open the file **artists.pdf**:
   9.1. Perform the menu command **Places→Documents**, if necessary;
   9.2. Double-click on the file **artists.pdf**.

**Additional Actions in the Application**

**Application Help**

**Base** has a built-in user manual with a search feature.

**To open the help feature of OpenOffice.org:**

Perform the command **Help→OpenOffice.org Help**

or

Press the function key **F1** on the keyboard
Contents – The table of contents of the OpenOffice.org help system; Index – Searchable index of topics; Find – Topic search feature; Bookmarks – User-created bookmarks

Image No.13 The dialogue box of the Help feature

The help system of Base opens by default, but, if necessary, it is easy to switch to the help of other applications of the OpenOffice.org suite. The window of the help system is divided in two sections – the selection pane and the text/search result area.

To bookmark a topic:

Click the button Add to Bookmarks.

Displaying and Hiding Toolbars

While working in the application, it is possible to accidentally close a necessary toolbar.

To open a Base toolbar:

1. Perform the menu command View→Toolbars;
2. Select the necessary toolbar in the menu.

In this module you learned:

- General understanding of databases;
- Actions in OpenOffice.org Base;
- Creation of a simple database;
Module 5

- Actions with database objects;
- Entry of information in a database;
- Selection of data;
- Export of records in a different file format;
- Preparation for printing.
Supplement 1

ECDL requirements for Module 5: Databases:

- Understand what a database is and how it is organized and operated;
- Create a simple database and view the database content in various modes;
- Create a table, define and modify fields and their properties; enter and edit data in a table;
- Sort and filter a table or form; create, modify and run queries to retrieve specific information from a database;
- Understand what a form is and create a form to enter, modify and delete records and data in records;
- Create routine reports and prepare outputs ready for distribution.

<table>
<thead>
<tr>
<th>Category</th>
<th>Skill set</th>
<th>Ref.</th>
<th>Task Item</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.1 Understanding Databases</td>
<td>5.1.1 Key Concepts</td>
<td>5.1.1.1</td>
<td>Understand what a database is.</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.1.1.2</td>
<td>Understand the difference between data and information.</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.1.1.3</td>
<td>Understand how a database is organized in terms of tables, records and fields.</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.1.1.4</td>
<td>Know some of the common uses of large-scale databases like: airline booking systems, government records, bank account records, hospital patient details.</td>
<td>Error! Bookmark not defined.</td>
</tr>
<tr>
<td></td>
<td>5.1.2 Database Organization</td>
<td>5.1.2.1</td>
<td>Understand that each table in a database should contain data related to a single subject type.</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.1.2.2</td>
<td>Understand that each field in a table should contain only one element of data.</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.1.2.3</td>
<td>Understand that field content is associated with an appropriate data type like: text, number, date/time, yes/no.</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.1.2.4</td>
<td>Understand that fields have associated field properties like: field size, format, default value.</td>
<td>Error! Bookmark not defined.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.1.2.5</td>
<td>Understand what a primary key is.</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.1.2.6</td>
<td>Understand what an index is. Understand how it allows for faster data access.</td>
<td>7</td>
</tr>
<tr>
<td>5.1.3 Relationships</td>
<td>5.1.3.1</td>
<td></td>
<td>Understand that the main purpose of relating tables in a database is to minimize duplication of data.</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td>5.1.3.2</td>
<td></td>
<td>Understand that a relationship is built by matching a unique field in one table with a field in another table.</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td>5.1.3.3</td>
<td></td>
<td>Understand the importance of maintaining the integrity of relationships between tables.</td>
<td>7</td>
</tr>
<tr>
<td>5.1.4 Operation</td>
<td>5.1.4.1</td>
<td></td>
<td>Know that professional databases are designed and created by database specialists.</td>
<td>Error! Bookmark not defined.</td>
</tr>
<tr>
<td></td>
<td>5.1.4.2</td>
<td></td>
<td>Know that data entry, data maintenance and information retrieval are carried out by users.</td>
<td>5</td>
</tr>
<tr>
<td>Module 5</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Category</strong></td>
<td><strong>Skill set</strong></td>
<td><strong>Ref.</strong></td>
<td><strong>Task item</strong></td>
<td><strong>Page</strong></td>
</tr>
<tr>
<td><strong>5.1.4.3</strong></td>
<td>Know that a database administrator provides access to specific data for appropriate users.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>5.1.4.4</strong></td>
<td>Know that the database administrator is responsible for recovery of a database after a crash or major errors.</td>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td><strong>5.2 Using the Application</strong></td>
<td><strong>5.2.1 Working with Databases</strong></td>
<td><strong>5.2.1.1</strong></td>
<td>Open, close a database application.</td>
<td>9</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.1.2</strong></td>
<td>Open, close a database.</td>
<td>19</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.1.3</strong></td>
<td>Create a new database and save to a location on a drive.</td>
<td>9</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.1.4</strong></td>
<td>Display, hide built-in toolbars. Restore, minimize the ribbon.</td>
<td>56</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.1.5</strong></td>
<td>Use available Help functions.</td>
<td>55</td>
</tr>
<tr>
<td></td>
<td><strong>5.2.3 Common Tasks</strong></td>
<td><strong>5.2.3.1</strong></td>
<td>Open, save and close a table, query, form, report.</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.3.2</strong></td>
<td>Switch between view modes in a table, query, form, report.</td>
<td>21</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.3.3</strong></td>
<td>Delete a table, query, form, report.</td>
<td>21</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.3.4</strong></td>
<td>Navigate between records in a table, query, form.</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.3.5</strong></td>
<td>Sort records in a table, form, query output in ascending, descending numeric, alphabetic order.</td>
<td>31</td>
</tr>
<tr>
<td><strong>5.3 Tables</strong></td>
<td><strong>5.3.1 Records</strong></td>
<td><strong>5.3.1.1</strong></td>
<td>Add, delete records in a table.</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.3.1.2</strong></td>
<td>Add, modify, delete data in a record.</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td><strong>5.3.2 Design</strong></td>
<td><strong>5.3.2.1</strong></td>
<td>Create and name a table and specify fields with their data types like: text, number, date/time, yes/no.</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.3.2.2</strong></td>
<td>Apply field property settings: field size, number format, date/time format, default value.</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.3.2.3</strong></td>
<td>Create a validation rule for number, date/time, currency.</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.3.2.4</strong></td>
<td>Understand consequences of changing data types, field properties in a table.</td>
<td>Not applicable to Base</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.3.2.5</strong></td>
<td>Set a field as a primary key.</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.3.2.6</strong></td>
<td>Index a field (with, without duplicates allowed).</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.3.2.7</strong></td>
<td>Add a field to an existing table.</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.3.2.8</strong></td>
<td>Change width of columns in a table.</td>
<td>18</td>
</tr>
<tr>
<td><strong>5.4 Retrieving Information</strong></td>
<td><strong>5.4.1 Main Operations</strong></td>
<td><strong>5.4.1.1</strong></td>
<td>Use the search command for a specific word, number, date in a field.</td>
<td>34</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.4.1.2</strong></td>
<td>Apply a filter to a table, form.</td>
<td>36</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.4.1.3</strong></td>
<td>Remove the application of a filter from a table, form.</td>
<td>37</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.4.2 Queries</strong></td>
<td><strong>5.4.2.1</strong></td>
<td>Understand that a query is used to extract and analyse data.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.4.2.2</strong></td>
<td>Create a named single table query using specific search criteria.</td>
<td>38</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.4.2.3</strong></td>
<td>Create a named two-table query using specific search criteria.</td>
<td>41</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.4.2.4</strong></td>
<td>Add criteria to a query using one or more of the following operators: = (Equal), &lt;&gt; (Not equal to), &lt; (Less than), &lt;= (Less than or equal to), &gt; (Greater than), &gt;= (Greater than or equal</td>
<td>37</td>
</tr>
<tr>
<td>Category</td>
<td>Skill set</td>
<td>Ref.</td>
<td>Task Item</td>
<td>Page</td>
</tr>
<tr>
<td>----------</td>
<td>-----------</td>
<td>------</td>
<td>-----------</td>
<td>------</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.4.2.5</td>
<td>Add criteria to a query using one or more of the following logical operators: AND, OR, NOT.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.4.2.6</td>
<td>Use a wildcard in a query, * or %, ? or __.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.4.2.7</td>
<td>Edit a query: add, modify, remove criteria.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.4.2.8</td>
<td>Edit a query: add, remove, move, hide, unhide fields.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.4.2.9</td>
<td>Run a query.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>5.5 Objects</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.5.1.1</td>
<td>Understand that a form is used to display and maintain records.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.5.1.2</td>
<td>Create and name a form.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.5.1.3</td>
<td>Use a form to insert new records.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.5.1.4</td>
<td>Use a form to delete records.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.5.1.5</td>
<td>Use a form to add, modify, delete data in a record.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.5.1.6</td>
<td>Add, modify text in headers, footers in a form.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>5.6 Outputs</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.1.1</td>
<td>Understand that a report is used to print selected information from a table or query.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.1.2</td>
<td>Create and name a report based on a table, query.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.1.3</td>
<td>Change arrangement of data fields and headings within a report layout.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.1.4</td>
<td>Present specific fields in a grouped report by sum, minimum, maximum, average, count, at appropriate break points.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.1.5</td>
<td>Add, modify text in headers, footers in a report.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.1.6</td>
<td>Export a table, query output in spreadsheet, text (.txt, .csv), XML format to a location on a drive.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>5.6.2 Printing</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.2.1</td>
<td>Change the orientation (portrait, landscape) of a table, form, query output, report. Change paper size.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.2.2</td>
<td>Print a page, selected record(s), complete table.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.2.3</td>
<td>Print all records using form layout, specific pages using form layout.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.2.4</td>
<td>Print the result of a query.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5.6.2.5</td>
<td>Print specific page(s) in a report, print complete report.</td>
</tr>
</tbody>
</table>
Task 5.10. Test your knowledge by completing the assignment

Notes:
The assignment includes 25 tasks, each of which is evaluated with points.
The work must be completed within 45 minutes.
Although there are instructions provided for completion of the tasks, it is also possible
to use other methods that are more convenient and familiar to you.
Try to complete the tasks on your own, without following the instructions.
The work has been completed successfully if the number of points obtained exceeds 24
(75% of the maximum possible 32).

1. Answer questions and enter the correct answer versions in a text file (7 points):
   1.1. Open the text file questions.odt:
      1.1.1. Perform the top panel menu command Places->Documents;
      1.1.2. Open the folder 5_databazes with a double left click;
      1.1.3. Open the folder 5.10_test with a double left click;
      1.1.4. Open the file questions.odt with a double left click.
   1.2. Open the text document file answers.odt:
      1.2.1. Open the folder 5.10_test by clicking the respective button in the bottom
              panel:
      1.2.2. Open the file answers.odt with a double left click.
   1.3. By switching between the windows of the text files, answer the questions and
        enter the letters of the correct answer versions in the document answers.odt;
   1.4. Save the changes in the document answers.odt:
      1.4.1. Click the Save button in the toolbar;
   1.5. Close both documents:
      1.5.1. Click the Close button in the title bar of the documents.
2. Open the database file music.odb (1 point):
   2.1. If necessary, open the window of the folder 5.10_test, similarly as in task 1;
   2.2. Perform a left click on the database file music.odb;
   2.3. Press the Enter key on the keyboard.
3. Create a new table called tbl_media in the database (1 point):

<table>
<thead>
<tr>
<th>Field name</th>
<th>Data type</th>
<th>Field properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media ID</td>
<td>Integer</td>
<td>AutoValue – Yes</td>
</tr>
<tr>
<td>Description</td>
<td>Text</td>
<td>Length 50</td>
</tr>
<tr>
<td>Date added</td>
<td>Date</td>
<td>MMM D, YY</td>
</tr>
</tbody>
</table>

3.1. In the Database pane of the application, select the object type Tables;
3.2. In the Tasks pane, click on the action Create Table in Design View;
3.3. In the Field Name field (first row), enter the field name Media ID;
3.4. In the Field type field, choose Integer;
3.5. Choose Yes in the AutoValue menu of the Field Properties pane:
3.6. In the next row, enter the name Description in the Field Name field;
3.7. Enter the number **50** in the Length field of the Field Properties pane, replacing the default value:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media ID</td>
<td>Integer</td>
</tr>
<tr>
<td>Description</td>
<td>Text</td>
</tr>
</tbody>
</table>

3.8. In the third row, enter the field name Date added in the Field Name field;
3.9. In the Field type field, choose the Date format;
3.10. In the Field Properties pane, click the browse button of the Format example field:

3.11. In the Format pane of the Field Format dialogue box, select the date format **MMM D, YY**:

3.12. Click OK in the dialogue box:
4. To continue, set the field **Media ID** as the primary key (1 point):

4.1. Check if **Base** has automatically set the field **Media ID** as the primary key:

4.2. Set the primary key, if necessary:

4.2.1. Perform a right click on the selection cell of the field **Media ID**;
4.2.2. In the right-click menu, choose **Primary Key**;

4.3. Save the table:

4.3.1. Click the **Save** button in the toolbar of the table window;
4.3.2. In the **Table Name** field of the **Save As** dialogue box, enter **tbl_media**;
4.3.3. Click **OK**.

4.4. Close the table:

4.4.1. Click the **Close** button in the title bar of the table window.

5. Add records to the table **tbl_media** (1 point):

<table>
<thead>
<tr>
<th>Media ID</th>
<th>Description</th>
<th>Date added</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Led Zeppelin – bootleg LP</td>
<td>Jun 13, 01</td>
</tr>
<tr>
<td>1</td>
<td>My experiments. Studio tape, 8 tracks</td>
<td>Dec 11, 09</td>
</tr>
<tr>
<td>2</td>
<td>Mike Oldfield’s first sessions recordings</td>
<td>Jan 23, 11</td>
</tr>
</tbody>
</table>

5.1. Open the table **tbl_media** for data entry:

5.1.1. In the **Database** pane, select the object type **Tables**;
5.1.2. In the **Tables** pane, select the table **tbl_media**;
5.1.3. Click the button **Open Database Object** in the toolbar:
5.2. Click inside the **Description** field of the first record;
5.3. Enter text as specified in the data table of the task;
5.4. Click inside the **Date added** field;
5.5. Enter the date added, observing the format;
5.6. Repeat the steps for the other records.

6. To continue, adjust the width of the **Description** field to make its entire content visible (1 point):
6.1. Position the mouse pointer between the field names **Description** and **Date added**;
6.2. Perform a double left click:
6.3. Close the table by clicking the **Close** button in the title bar of the table window.

7. Add a mandatory field to the existing table **tbl_artists** (1 point):

<table>
<thead>
<tr>
<th>Field name</th>
<th>Data type</th>
<th>Field properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Country</td>
<td>Text</td>
<td>Length 15,</td>
</tr>
</tbody>
</table>

7.1. If necessary, select the database object Tables in the Database pane;
7.2. In the Tables pane, select the table **tbl_artists**;
7.3. Click the **Edit** button in the toolbar:
7.4. Enter the field name **Country** in a new **Field Name** row of the table;
7.5. In the **Length** field of the **Field Properties** pane, enter **15**, replacing the default value.
7.6. Save the changes by clicking the **Save** button in the toolbar;
7.7. Close the table window by clicking the **Close** button in the title bar.

8. In the database table **tbl_albums**, set the **Artist** field as mandatory (1 point):
8.1. If necessary, select the database object Tables in the Database pane;
8.2. In the Tables pane, select the table **tbl_albums**;
8.3. Click the **Edit** button in the toolbar:
8.4. Click on the name of the **Artist** field;
8.5. In the **Entry required** menu of the **Field properties** pane, choose **Yes**.

9. Delete the **Comments** field (1 point):
9.1. Perform a right click on the selection cell of the **Comments** field;
9.2. In the right-click menu, choose **Delete**.

10. Change the currency symbol of the **Price** field to € (1 point):
10.1. Click on the name of the **Price** field;
10.2. In the **Field Properties** pane, click the browse button of the **Format example** field;
10.3. In the **Format** menu of the **Field Format** dialogue box, select EUR €
English (Eire):

![Currency Format](image)

10.4. Make sure that you have made the right selection in the **Format example** field:

![Format Example](image)

10.5. Click **OK** in the dialogue box;

11. Set up indexing that does not allow repeat records for the **Album** field (1 point):

11.1. Perform the table window menu command **Tools−Index Design**;

11.2. In the **Indexes** dialogue box, click the button **New Index**:

![New Index](image)

11.3. Change the default index record to **album**:

11.3.1. Enter the word **album** using the keyboard;

11.3.2. Press the **Enter** key on the keyboard:

![Index Record](image)

11.4. In the **Fields** pane, select the **Album** field;

11.5. Tick the **Unique** checkbox:

![Unique Checkbox](image)

11.6. Click the **Close** button in the **Indexes** dialogue box;

11.7. In the dialogue box, confirm saving the changes by clicking **Yes**;

11.8. Close the table window:

11.8.1. Click the **Close** button in the title bar;

11.8.2. Confirm saving the changes by clicking **Yes**.

**Tip:**

You can check if the index has been added and duplicate records are prohibited by attempting to create a new record in the table **tbl_albums** and trying to enter in the **Album** field an album name that already exists in the table.

12. In the table **tbl_albums**, set the width of the **Artist** column to 1.2 inches (3 cm) (1 point):
12.1. Open the table tbl_albums in data mode:

12.1.1. In the Tables pane, select the table tbl_albums;

12.1.2. Press the Enter key on the keyboard

12.2. Perform a right click on the name of the Artist column;

12.3. In the right-click menu, select the command Column Width:

12.4. In the Width field of the Column Width dialogue box, enter 1.2 (3);

12.5. Click OK;

12.6. Close the table by clicking the Close button in the title bar of the column window.

**Tip:**

OpenOffice.org Base does not provide the possibility to move data table fields. It can be done directly with the database commands. If a different arrangement of database table fields is needed, it is possible to create a view for a table or tables. A view does not change the actual order of table fields.

13. Create a view for the table tbl_artists where the Active field is immediately after the Artist field (1 point):

13.1. In the Database pane, select the database object Tables, if necessary;

13.2. In the Tasks pane, click on the task Create View;

13.3. In the Add Tables dialogue box, select the table tbl_artists;

13.4. Click Add;

13.5. Click Close;

13.6. In the Field row of the table, set the fields to be displayed in the order specified in the task:

<table>
<thead>
<tr>
<th>Field</th>
<th>Artist</th>
<th>Active</th>
<th>Year founded</th>
<th>Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alias</td>
<td>tbl_artists</td>
<td>tbl_artists</td>
<td>Artist</td>
<td>-</td>
</tr>
<tr>
<td>Table</td>
<td>tbl_artists</td>
<td>Year founded</td>
<td>tbl_artists</td>
<td>tbl_artists</td>
</tr>
<tr>
<td>Sort</td>
<td>Active</td>
<td>tbl_artists</td>
<td>tbl_artists</td>
<td>tbl_artists</td>
</tr>
</tbody>
</table>

13.7. Click the Save button in the toolbar;

13.8. In the Table name field of the Save As dialogue box, enter the view name custom_view;

13.9. Click OK;

13.10. Click the Close button in the title bar of the window.

14. Create a query called qry_after_81 that will select from the table tbl_albums all albums released after 1981 (1 point):

14.1. In the Database pane, select the object type Queries;

14.2. In the Tasks pane, click on the task Create Query in Design View;

14.3. In the dialogue box Add Table or Query, select the table tbl_albums;

14.4. Click Add;

14.5. Click Close;
14.6. In the Field row, sequentially select the fields from the table `tbl_albums` in the menus;
14.7. Tick the Visible checkbox for the first four selected table fields;
14.8. In the Criterion cell, create a record selection criterion for the Year field:
   14.8.1. Click inside the Criterion cell corresponding to the Year field;
   14.8.2. Enter >1981;
   14.8.3. Press the Enter key on the keyboard.

<table>
<thead>
<tr>
<th>Field</th>
<th>Artist</th>
<th>Album</th>
<th>Year</th>
<th>Format</th>
<th>Price</th>
<th>ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alias</td>
<td>tbl_albums</td>
<td>tbl_albums</td>
<td>tbl_albums</td>
<td>tbl_albums</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table</td>
<td>tbl_albums</td>
<td>tbl_albums</td>
<td>tbl_albums</td>
<td>tbl_albums</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sort</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Visible</td>
<td>☑</td>
<td>☑</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td></td>
<td></td>
<td>&gt;1981</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Criterion</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

14.9. Click the Save button in the toolbar of the query window;
14.10. In the respective field of the Save As dialogue box, enter the query name `qry_after_81`;
14.11. Click OK;
14.12. Click the Close button in the title bar of the query window.

Tip:
Test if the created query works by running it.

15. Create a query that displays the names and years founded of UK bands from the table `tbl_groups` and album names from the table `tbl_albums` (1 point):
15.1. In the Database pane, select the object type Queries, if necessary;
15.2. In the Tasks pane, click on the task Create Query in Design View;
15.3. In the dialogue box Add Table or Query, select the table `tbl_albums`;
15.4. Click Add;
15.5. In the dialogue box Add Table or Query, select the table `tbl_groups`;
15.6. Click Add;
15.7. Click Close;
15.8. In the Field row of the query table, sequentially select the fields Artist, Year founded and Country from the table `tbl_groups`;
15.9. In the Field row of the query table, select the Album field from the table `tbl_albums`;
15.10. Remove the tick from the Visible checkbox of the Country field;
15.11. Enter UK in the Country field of the Criterion cell;
15.12. Press the Enter key on the keyboard:
15.13. Save the query:
15.14. Click the Save button in the toolbar of the query window;
15.15. In the Query name field of the Save As dialogue box, enter qry_UK;
15.16. Click OK;
15.17. Close the query window by clicking the Close button in the title bar.

16. Change the record selection criterion LP OR CD to CD in the query qry_CD_LP (1 point):
16.1. Open the query qry_CD_LP in editing mode:
16.2. In the Database pane, select the database object Queries, if necessary;
16.3. In the Queries pane, select the query qry_CD_LP;
16.4. Click the Edit button in the toolbar:
16.5. In the Format column of the Criterion Or field, delete the text ‘LP’;
16.6. Close the query dialogue box by clicking the Close button in the title bar;
16.7. Confirm the changes by clicking Yes.

17. Create a simple form for input (output) of data of the database table tbl_groups (1 point):
17.1. In the Database pane, select the database object type Forms;
17.2. In the Tasks pane, click on Use Wizard to Create Form;
17.3. In the pane Select the fields of Your form of the Form Wizard dialogue box, select the table tbl_groups in the menu Tables or queries:
17.4. Add all fields:
17.4.1. Click the button to add all table fields:
17.5. Click **Next** in the **Form Wizard** dialogue box;
17.6. Click **Next** again;
17.7. Choose the form arrangement **In Blocks – Labels Above**:

![Arrangement of the main form](image)

17.8. Click **Next** in the **Form Wizard** dialogue box;
17.9. Click **Next** again;
17.10. Click **Next**;
17.11. In step eight **Set the name of the form**, enter the name **frm_groups** in the field **Name of the form**;
17.12. Click **Finish**;
17.13. Close the form window by clicking **Close** in the title bar.

18. Supplement the music collection by using the form **frm_collection** (1 point):

<table>
<thead>
<tr>
<th>Artist</th>
<th>Album</th>
<th>Format</th>
<th>Year</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Falco</td>
<td>Best Of</td>
<td>CD</td>
<td>1998</td>
<td>12</td>
</tr>
<tr>
<td>Madness</td>
<td>Wonderful</td>
<td>CD</td>
<td>1999</td>
<td>15</td>
</tr>
</tbody>
</table>

18.1. Select the form **frm_collection** in the **Forms** pane;
18.2. Press the **Enter** key on the keyboard;
18.3. Click the **New Record** button in the navigation bar of the form:

![New Record](image)

18.4. Enter data in the corresponding fields from the first record of the table provided in the task;
18.5. Repeat the steps for the second record.

19. Delete record 14 by using the form **frm_collection** (1 point):

19.1. In the **Record** navigation field of the form **frm_collection**, enter the number 14:

![Record navigation field](image)

19.2. Press **Enter** on the keyboard
19.3. Click the **Delete Record** button in the navigation bar:

![Delete Record](image)

19.4. Confirm deleting the record by clicking **Yes** in the warning dialogue box;
19.5. Close the form by clicking the **Close** button in the title bar of the form window.

**Tip:**

Make sure that the action was successful by activating the table **tbl_albums**:

![Table activation](image)
20. Create a report for the table `tbl_full`. Include the fields `Artist`, `Album`, `Year` (1 point):

20.1. In the **Database** pane, select object type **Reports**;
20.2. In the **Tasks** pane, click on **Use Wizard to Create Report**;
20.3. In the **Report Wizard** dialogue box:
   20.3.1. Select the table `tbl_full` in the menu **Tables or queries**:
   20.3.2. Select fields in the report:
   20.3.3. Click **Next**;
   20.3.4. Click **Next** again until the fifth step of the wizard;
   20.3.5. In step five, select **Portrait** orientation:
   20.3.6. Click **Next**;
   20.3.7. In the field **Title of report**, enter the name `rpt_albums`;
   20.3.8. Click **Finish**;
   20.4. Close the report window by clicking the **Close** button in the title bar.

21. Create a report for the table `tbl_groups`, including in the report all fields of the table and additionally grouping by country (1 point):

21.1. In the **Tasks** pane, click on **Use Wizard to Create Report**;
21.2. In the **Report Wizard** dialogue box:
   21.2.1. Select the table `tbl_groups` in the menu **Tables or queries**:
   21.2.2. Select all fields in the report:
   21.2.3. Click **Next**;
   21.2.4. Click **Next**;
21.2.5. In step three **Grouping**, select the **Country** field:

21.2.6. Click **Next**;
21.2.7. Click **Next** again;
21.2.8. In the **Layout of data** pane, choose layout type **Outline – Elegant**;
21.2.9. Choose **Portrait** orientation;
21.2.10. Click **Next**;
21.2.11. In the **Title of report** field, enter the name **rpt_grouped**;
21.2.12. Click **Finish**;

21.3. Close the report window by clicking the **Close** button in the title bar.

22. Delete a database object – the report **rpt_test** (1 point):

22.1. Select the report **rpt_test** in the **Reports** pane;
22.2. Press the **Delete** key on the keyboard;
22.3. In the dialogue box, confirm deleting by clicking **Delete**.

23. Assign the name **This is part of my collection** to the report **rpt_header** (1 point):

23.1. Select the report **rpt_header** in the **Reports** pane
23.2. Click the **Edit** button in the toolbar:

23.3. Perform a left click inside the header field Title;
23.4. Enter the text **This is part of my collection**;

24. Save the report **rpt_header** in **Adobe Acrobat** format (1 point):

24.1. Perform the report window menu command **File->Export as PDF**;
24.2. Confirm the default settings by clicking **Export**;
24.3. In the **Name** field of the **Export** dialogue box, enter **export**;
24.4. Click **Save**;
24.5. Click the **Close** button in the title bar;
24.6. In the dialogue box, confirm saving the changes by clicking **Save**.

25. Close the database (1 point):

25.1. Click the **Save** button in the toolbar of the application window;
25.2. Click the **Close** button in the title bar.