Table of Contents

Web Browsing and Communication ................................................. 4

Internet and Online Services ................................................... 4
  Internet ................................................................................. 4
  Services .............................................................................. 5

Web Browsing ............................................................................ 6
  Internet Connection .............................................................. 6
  Web Browser ......................................................................... 7
  Web Address ........................................................................ 7
  Browsing Web Pages ............................................................. 8

Additional Actions in a Browser .................................................... 13
  Deleting, Editing Information ................................................ 14
  Setting the Home Page ........................................................... 14
  Bookmarks .......................................................................... 15
  History ................................................................................ 17
  Toolbars .............................................................................. 18
  Help System ......................................................................... 18

Online Search ............................................................................. 23
  Search Engines ..................................................................... 23
  Searching in Specialized Web Resources ............................... 25

Forms in Web Pages .................................................................. 26

Using Web Resources ................................................................ 27
  Saving a Page ....................................................................... 27
  Printing a Page ..................................................................... 28
  Using Web Page Content ...................................................... 29
  Saving Files ......................................................................... 30

Security Online ......................................................................... 35
  Viruses ............................................................................... 35
  Phishing .............................................................................. 37
  Firewall .............................................................................. 37
  Username and Password ...................................................... 37
  Security Code ....................................................................... 37
  Digital Certificate ................................................................ 38
  Electronic Signature ............................................................ 39
  Additional Settings in Browsers ............................................. 39
  Blocking Pop-up Windows ..................................................... 40
  Blocking Cookies ................................................................. 41
  Publishing Information ......................................................... 42
  Parental Control ................................................................... 43

Electronic Mail .......................................................................... 47
  Prerequisites ....................................................................... 48
  How E-mail Works ............................................................... 49
  Evolution Mail ...................................................................... 51
  Sending a Message ............................................................... 52
  Receiving a Message ............................................................ 59
  Performing Actions with Messages ....................................... 60
E-mail Attachments ................................................................................. 61

Additional Actions in Evolution ......................................................... 62
  Message Priority .................................................................................. 63
  Copying Content into a Message ......................................................... 63
  Drafts .................................................................................................... 63
  Sorting Messages ................................................................................ 64
  Working with Folders ........................................................................ 66
  Deleting, Restoring a Message .......................................................... 67

Address Book ......................................................................................... 67
  Contacts .............................................................................................. 67
  Contact List ........................................................................................ 69

Other Forms of Electronic Communication ......................................... 73
  Instant Messaging .............................................................................. 73
  VoIP (Voice over Internet Protocol) ................................................... 73
  Virtual Communities .......................................................................... 73
  Text Messaging .................................................................................. 74
MODULE 7

WEB BROWSING AND COMMUNICATION

In this module you will learn how to:

- Understand various Internet services;
- Browse web pages;
- Search the web;
- Fill web-based forms;
- Use e-mail for communication;
- Attach files to e-mail messages;
- Be aware of other forms of electronic communication;
- Use the available help systems.

Internet and Online Services

Internet

The Internet is a global, worldwide computer network that interconnects a large number
of other smaller networks belonging to governments, companies and individuals.

The principal purpose of the Internet, like with any other computer network, is to allow
transfer of data between various types of computer systems. This is ensured by the
hardware connected to the global network – computer systems, servers, network hubs
and routers, wired and wireless communication channels, and software that controls the
operation of the hardware.

Data is transferred by transforming it into electrical signals and sending these signals
with a special method – by using one of the data transfer protocols. The Internet uses
the protocol TCP/IP (Transmission Control Protocol/Internet Protocol).

The Internet originated in the United States. The United States Department of Defense
funded research into the principles of development of a safe computer network,
resulting in the creation of an actual, operational network for the needs of the
government – the ARPANET (Advanced Research Projects Agency Network). Initially this
network interconnected four locations – the leading universities in the US.

The structure of this type of network is simple. All points interconnected on a single
network have an equal role and rights to create, transmit and receive information. If a
point is removed, the rest of the network will continue functioning regardless.

The global network does not have a centralized control system or a globally planned
development strategy.
Services

As the Internet is universally suited to transmission of various data, the possibilities of its usage are limited only by the transfer rates of communication channels and the development of software solutions.

World Wide Web

The World Wide Web is one of the most popular Internet services. It comprises interconnected web pages created on servers with the help of special software and made available to users. Today, web pages contain not only text, but also pictures and multimedia features.

Web documents are created with the help of special code – the HTML language. Pages are interlinked and placed on servers, thus forming a website.

FTP

The FTP service allows transferring files between computer systems through the Internet.

E-mail

A form of electronic communication on the Internet. Messages are quickly transmitted to anywhere in the world.

RSS

RSS – really simple syndication – is used to deliver to the user the content of a website in the form of a brief description (summary), with clickable links leading to the full content.

The user can view the content of an RSS feed in special applications or a web browser, creating a personalized list of RSS sites.

The availability of RSS content on a website is indicated by a special browser icon or graphical image on the site:

Podcast

Podcasting is listening to multimedia files available on the Internet or downloading them to a portable media player. Podcast audio or multimedia files are usually created and published as episodes in a show.

For example, audio files are specially prepared:
- The publisher creates an audio file (files) in MP3 format and publishes it on a server on the Internet;
- An RSS file is created, which is then published online. It contains basic information about the audio file – name, description, and link to its location on the web;
- The user checks the RSS information by refreshing it;
- The user plays the file with a client application or downloads it.

**Note!**
This material examines the browser Mozilla Firefox and e-mail client Evolution in the Gnome graphical environment of the operating system Linux Ubuntu 10.10.
The folder 7_internet with task templates must be copied into the user account folder Documents.

**Web Browsing**

Browsing web pages requires:
- An Internet connection;
- A computer system with a web browser;
- Knowing the address of a website.

**Internet Connection**

Today, computers are rarely used without a connection to a network. Browsing websites has become a part of our daily lives.

To use web-based services and browse web pages, an Internet connection is required.

The connection is usually provided by special companies – Internet Service Providers (ISP). ISPs ensure exchange of data between your computer and the Internet. Internet Service Providers have special technical equipment – communication channels, hardware; they can maintain additional network services to ensure the connection. Many ISPs offer additional services, such as free e-mail accounts, data storage space, website hosting.

Internet Service Providers use various technologies to ensure a connection, such as:
- Direct connection to the Internet;
- Mobile connection. Connection by using a mobile telephone network;
- Connection by using a public or private telecommunications network;
- Wireless connection.

Special devices called modems are often used for a connection.
Note!
An Internet connection is not just a communications channel and hardware set-up. An Internet Service Provider provides a range of different technological services to maintain the transmission of data.

Web Browser

If a computer is connected to the Internet, a web browser is required for browsing websites. The pages that comprise websites actually look similar to this:

They are documents written in special hypertext markup language that contain instructions to the web browser. By following these instructions, the browser generates and displays the web pages as we normally see them in the computer display.

There are various kinds of web browsers. Some of the most frequently used browser in Linux environment are:

- **Mozilla Firefox.** Installed on Linux Ubuntu by default;
- **Chrome.** A browser developed by Google;
- **Flock.** Developed for integration with social networking sites;
- **Opera.** A fast browser;
- **Sea Monkey.**

Web Address
To view a web page, it is necessary to know its address. Usually, a website consists of large number of interlinked pages. One of them is set as the main page and opens when the site’s address is entered in the browser.

The full website address also contains the networking protocol, and is called the Uniform Resource Locator (URL).

![Image No. 1. The URL of a website](A - Protocol; B - Site address)

The Uniform Resource Locator can also point to a specific web resource – a page on a site:


Web addresses are allocated and registered by special services that are part of the overall Internet information system; these functions can also be performed by an Internet Service Provider.

A special Domain Name System has been established. Parts of the address are separated with dots in site names. There are top-level domains registered at an international level, such as:

- .lv; .lt; .ee; .ie; .de – Latvia, Lithuania, Estonia, Ireland, Germany, respectively;
- .com – commercial sites;
- .eu – European Union.

A site owner can register his or her domain name by adding text to the top-level domain, for example, sitename.eu, followed by the computer name or the prefix www:

www.sitename.eu

**Browsing Web Pages**

Regardless of which web browser is used, it must first be launched. Let’s use the browser **Mozilla Firefox**, which is included in the default installation of Linux Ubuntu.

**To open a web browser:**

In the top panel menu, perform the command **Applications->Internet->Firefox Web Browser:**
Although the appearance and layout of different web browsers can differ, the main actions in browsers are similar.

To open a web page in a browser:

1. Left-click inside the address field of the browser;
2. Enter the address or Uniform Resource Locator of the site;
   Press the **Enter** key on the keyboard
   or
3. Click the **Go** button at the end of the address field:
When viewing a page, some parts of the text appear highlighted. When the mouse pointer is positioned over such text (or image), it changes its appearance to a hand with an outstretched index finger. These are hyperlinks to other web documents. When such a link is clicked, the browser will download and open the linked web page or other resource.

The content, appearance, layout and design of a web site depend on the choices of its developers. There is no point asking “why does it look like that?” about a site’s appearance. In most cases, the answer is “because the designer wanted it that way”.

The content of a web page can be changed only by its author, unless comments or other methods of posting text are enabled on the page.

**Navigation**

The user can go elsewhere from the current page by clicking a link.

**To go to a linked web page:**

1. Position the mouse pointer over the link;
2. See if the appearance of the mouse pointer changes:

   ![About ECDL Foundation](image)

   - About ECDL Foundation
   - Our Mission
   - Our Values
   - Our History

3. Perform a left mouse click.

In addition, it is possible to use the browser navigation buttons:

![Navigation in Mozilla Firefox](image)

A – Previous page; B – Return to next page; C – Refresh the page; D – Stop loading the page; E – Go back to the home page

Page refresh is used to reload the content of the page. It may be necessary for pages with dynamic, changing content, e.g., stock charts, or in cases of technical problems, when the page content is not loaded properly, e.g., there is outdated information displayed, images are missing.
The home page is the first page that opens upon activating the browser. The user can change this address in the browser settings. The default home page in Mozilla Firefox is the site of the Google search engine.

**Opening a Web Page in a New Tab**

It is often necessary to have multiple web pages open at the same time. Of course, it is possible to open several instances of the browser by launching it several times and working with different browser windows.

However, there is an easier solution. Most browsers support tabbing – multiple web pages can each be opened in its own tab within a single browser window:

1. Click the plus sign at the end of the tab bar;
   or
2. Perform the browser menu command **File→New Tab**;
3. Enter a website address or URL in the address field of the new tab;
4. Open the address by pressing the **Enter** key or clicking the **Go** button, usually at the end of the address bar.

**To switch between tabs:**

1. Hover the mouse pointer over a page tab;
2. Click the left mouse button.

**To close a tab:**

Click the cross sign in the tab.

**To open a link in a new tab:**

1. Click a link with the mouse wheel;
   or
2. Right-click a link;
2. In the right-click menu, perform the command **Open Link in New Tab**.

**Task 7.1. Open the website www.ecdl.com. Use links to browse the content of the site.**

**Open a link in a new tab**
1. Open the web browser **Mozilla Firefox**:
   1.1. Perform the menu command **Applications→Internet→Firefox Web Browser** in the top panel menu of the desktop.
2. Open the website **www.ecdl.com**:
   2.1. Hover the mouse pointer over the address bar;
   2.2. Double left-click to select the text in the address field;
   2.3. Enter the website address **www.ecdl.com**;
   2.4. Press the **Enter** key on the keyboard;
   2.5. See the change in the address field – the browser adds the protocol **http://** to the address.
3. Find and activate the link pointing to ECDL programmes:
   3.1. Position the mouse pointer on the link;
   3.2. Perform a left mouse click:

4. Open the link **ECDL/ICDL** in a new tab:
   4.1. Position the mouse pointer on the link;
   4.2. Perform a click with the mouse wheel.
   4.3. Open the new tab by clicking on its name.
5. Open the website address **www.bda.lv** in a new tab:
   5.1. Perform the menu command **File→New Tab**;
   5.2. Make sure that the insertion points is in the address bar – the text cursor is blinking;
   5.3. Enter the address **www.bda.lv**;
   5.4. Click the **Go** button at the end of the address bar:

6. Open the tab of the ECDL site:
   6.1. Position the mouse pointer on the first tab;
   6.2. Perform a left mouse click.
7. Refresh the current web page:
   7.1. Click the button **Reload current page**: 
8. Close the tab of the ECDL site:
   8.1. Click the Close Tab button:

9. Close the browser:
   9.1. Click the Close button in the title bar of the browser:
   9.2. In the dialogue box, confirm closing all open tabs by clicking Close tabs:

Additional Actions in a Browser

To better understand the operation of a browser, let’s look at the process of browsing a web page:

- The user enters the website address in the browser’s address field and activates it;
- The browser sends this information to a special Domain Name Service (DNS). The DNS translates this name into a corresponding Internet Protocol (IP) address of the website’s server. Computers communicate between themselves by using these IP addresses, which look like this: 192.168.3.234, for example. IP addresses are unique and unmistakably identify each computer on the Internet.
- Upon receiving the server’s IP address, the browser connects directly to the site’s server;
- The site’s server sends the page code, content, embedded and attached files to the web browser;
- The browser generates and displays the web page.

Web browsers store:

- Files from websites. Some of the files on websites remain in the browser’s temporary cache for repeated use. This is done to speed up browsing if the user reopen a previously visited site. The browser checks if the site’s content has changed and, if it has not, uses the files stored in the cache to ensure faster loading. This temporary storage is called Cache, Temporary Internet Files.
Web browsing and communication

- Browsing history. The browsing history is created automatically; it can be used to open sites that have already been visited more quickly – the full address does not have to be entered again. It is also possible to find the URL of a previously viewed web resource.
- **Cookies.** These are usually small text files stored by a website in the browser’s temporary data storage. Cookies are used for authentication or storing user settings (there are sites where the user may customize the appearance, layout and content), and they may contain private information, such as a username, e-mail address.

Web browsers may store:
- Usernames and passwords;
- Completion information of web forms.

**Deleting, Editing Information**

The information stored in a browser can be managed. It is possible to clear temporary data, history and other items in the Clear Recent History dialogue box.

**To delete data:**

1. Perform the Mozilla Firefox menu command Tools→Clear Recent History;
2. Select the Time range to clear;
3. Choose the items to be cleared by clicking Details;
4. Confirm the selection:

   ![Clear Recent History](image)

   *Image No. 4. Clearing data in Mozilla Firefox*

   - Browsing & Download History;
   - Form & Search History;
   - Cookies;
   - Cache – temporary files saved by the browser;
   - Active Logins;
   - Site Preferences.

**Setting the Home Page**
By default, when Mozilla Firefox is launched, it opens the main page of the Google search engine. This can be changed by setting a different home page.

To change the home page in Mozilla Firefox:

1. Perform the browser menu command Edit→Preferences;
2. In the General tab, enter the new home page address under Home Page;
3. Close the Firefox Preferences dialogue box:

![Firefox Preferences](image)

**Bookmarks**

A website’s URL can be very long and difficult to remember. For example, try to memorize this website address:

```
```

Writing the address down is not a solution, either, as the correct page won’t open if even a single character is entered incorrectly.

It is possible to use bookmarks in a browser for faster repeated visiting of known websites. In this case, it is enough to find the site’s bookmark in the Bookmarks menu and left-click on it.

To bookmark the current web page:

1. Perform the menu command Bookmarks→Bookmark This Page;
2. Perform additional actions in the dialogue box:
   2.1. Enter the name of the bookmark in the Name field;
   2.2. In the Folder menu, select the folder for the bookmarks;
   2.3. In Tags field, add tags to the bookmark, separating them with a comma.
3. Confirm adding the bookmark by clicking **Done**.

**Useful tip:**
If there is a large number of bookmarks, it is easier to organize them by placing them in folders on specific subjects, as well as by adding **Tags**.

Bookmarks in Mozilla Firefox are managed with the bookmark and browsing history library tool.

**To open the bookmark library:**

Perform the menu command **Bookmarks→Organize Bookmarks**:

![Bookmarks Library](image)

The window of the library pane is divided into two panes. The left pane displays the bookmark locations:

- **Bookmarks Toolbar**;
- **Bookmarks Menu**;
- **Unsorted Bookmarks** – unsorted bookmarks not added to the **Bookmarks** menu or placed in one of the themed folders.

The right pane displays the content of the folder selected in the left pane.

**To create a new themed folder in the Bookmarks menu:**

1. Open the dialogue box of the bookmarks and history library;
2. In the left pane, select the **Bookmarks Menu**;
3. Click the **Organize** button in the toolbar of the dialogue box;
4. Perform the menu command **New Folder**;

 ![Create New Folder](image)

5. In the **Name** field of the **New Folder** dialogue box, enter a name for the folder;
6. Click **Add**;
7. Close the **Library** dialogue box.

**To create a new folder while adding a bookmark:**
1. Perform the menu command **Bookmarks**->**Bookmark This Page**;

2. Perform additional actions in the dialogue box:
   2.1. In the Name field, enter a name for the bookmark;
   2.2. Click the button **Show all the bookmarks folders**;
   2.3. In the dialogue box, click the New Folder button;
   2.4. Enter a name for the folder;
   2.5. Click **Done**.

**To delete a bookmarks folder:**

1. Open the dialogue box of the bookmarks and history library;
2. In the left pane, select the **Bookmarks Menu**;
3. Select a bookmarks folder in the right pane;
4. Press the **Delete** key on the keyboard.

**To delete a bookmark:**

1. Open the dialogue box of the bookmarks and history library;
2. In the left pane, select the **Bookmarks Menu**;
3. In the right pane, expand the folder:
4. Select the folder containing the bookmark from the list;
5. In the right pane, select the bookmark to be deleted;
6. Press the **Delete** key on the keyboard.

**History**

The browser’s history is easy to use to reopen a resource that has already been visited

**To open a recently visited site by using the address bar:**

1. Perform a left click on the downward arrow at the end of the address bar;
2. Select the site from the list:

To open a web page stored in browsing history:

1. Open the dialogue box of the bookmark and history library with the menu command History→Show All History;
2. In the right pane of the Library dialogue box, double left click on the necessary day;
3. Perform a double click on the necessary URL in the list.

To delete an entry in browsing history:

1. Open the dialogue box of the bookmark and history library with the menu command History→Show All History;
2. In the right pane of the Library dialogue box, double left click on the necessary day;
3. Select an item in the browsing history;
4. Press the Delete key on the keyboard.

Toolbars

Mozilla Firefox uses two toolbars by default – the navigation toolbar and bookmarks toolbar. It is also possible to add the toolbars of various other applications, browser extensions and plug-ins. A toolbar is set to be displayed (or hidden) in a menu of the application window.

To show (hide) toolbars in Mozilla Firefox:

1. Perform the menu command View→Toolbars;
2. Select the toolbar to be shown (hidden):

Help System

Like other applications, Mozilla Firefox also has a built-in help system – a user manual.

To open the Mozilla Help system:
Perform the menu command **Help--->Firefox Help.**

The browser’s help system is presented online, as a website:

---

**Task 7.2. Set the site www.openoffice.org as the home page. Use history and bookmarks to open visited pages**

1. Open the web browser **Mozilla Firefox**:
   1.1. Perform the command **Applications--->Internet--->Firefox Web Browser** in the top panel menu
2. Set the site **www.openoffice.org** as the home page:
   2.1. Perform the menu command **Edit--->Preferences**;
   2.2. Open the **General** tab, if not already open, by clicking on its name;
   2.3. Enter the address **www.openoffice.org** in the **Home Page** field of the Firefox **Preferences** dialogue box:

   ![Firefox Preferences dialogue box]

   2.4. Close the dialogue box by clicking the **Close** button;
   2.5. Close the browser by clicking the **Close** button in its title bar.
3. Activate the web browser **Mozilla Firefox**:
   3.1. Perform the command **Applications--->Internet--->Firefox Web Browser** in the top panel menu.
4. Import bookmarks from a file:
   4.1. Perform the menu command **Bookmarks--->Organize Bookmarks**;
4.2. Press the Import and Backup button in the toolbar of the Library dialogue box;
4.3. In the menu, select the command Import HTML;

4.4. In the Import Wizard dialogue box, click Next;
4.5. In the Import Bookmarks File dialogue box:
   4.5.1. In the Places pane, select the Documents folder;
   4.5.2. Perform a double left click on the folder 7_internet in the right pane;
   4.5.3. Perform a double left click on the folder 7.2_bookmarks;
   4.5.4. Perform a double left click on the folder bookmarks.html;
   4.5.5. Close the Library dialogue box by clicking the Close button in the title bar.

5. Select the bookmark E-learning:
   5.1. Open the Bookmarks menu by left-clicking on its name;
   5.2. Click on the bookmark E-learning in the list.

6. Open the Ubuntu homepage in a new tab:
   6.1. Open the Bookmarks menu;
   6.2. Right-click on the bookmark Homepage | Ubuntu;
   6.3. In the right-click menu, perform the command Open in a New Tab:

7. Add the address www.bda.lv to the bookmarks folder ECDL:
   7.1. Open a new tab in the browser by clicking the button Open a new tab:
   7.2. In the address field, enter the site address www.bda.lv;
   7.3. Press Enter on the keyboard;
   7.4. Perform the menu command Bookmarks->Bookmark This Page;
   7.5. In the Name field of the Page Bookmarked dialogue box, enter Testing Centre;
   7.6. In the Folder menu, select the command Choose:
   7.7. Expand the folder Bookmarks Menu by left-clicking on the black triangle at the beginning of the entry;
   7.8. Select the folder ECDL:
7.9. Confirm adding the bookmark by clicking **Done**.

8. Delete the bookmark **Homepage | Ubuntu**;
   8.1. Open the **Bookmarks** menu;
   8.2. Perform a right click on the bookmark **Homepage | Ubuntu**;
   8.3. In the right-click menu, select the command **Delete**.

9. Delete the bookmarks folder **OOO**:
   9.1. Perform the menu command **Bookmarks→Organize Bookmarks**;
   9.2. In the left pane of the **Library** dialogue box, left-click on the **Bookmarks Menu**;
   9.3. In the right pane, select the folder **OOO**;
   9.4. Press **Delete** on the keyboard

10. Open the home page:
   10.1. Click the **Home** button in the browser toolbar:

11. Open the previous page:
   11.1. Click the button **Go back one page** in the toolbar:

12. Go forward again:
   12.1. Click the button **Go forward one page** in the toolbar:

13. Close the browser:
   13.1. Click the **Close** button in the toolbar;
   13.2. In the dialogue box, confirm closing all open tabs by clicking **Close tabs**.

14. Activate the web browser **Mozilla Firefox**:
   14.1. Perform the command **Applications→Internet→Firefox Web Browser**
       in the top panel menu.

15. Open the site **www.bda.lv** by using the history of the address field:
   15.1. Open the address field history menu by clicking on the triangle at the end of the address field:
   15.2. Select the site address **www.bda.lv** from the list:
16. Open the site Ubuntu from the browsing history:
   16.1. Perform the menu command History->Show All History;
   16.2. Perform a double left click on the item Today in the right pane;
   16.3. Select in the list Homepage | Ubuntu;
   16.4. Press Enter on the keyboard:

Task 7.3. Delete an address from browsing history. Delete all temporary files. Clear all browsing history. Hide and display toolbars

1. Activate the web browser Mozilla Firefox, if it’s not already open:
   1.1. Perform the command Applications->Internet->Firefox Web Browser in the top panel menu.
2. Delete the address of the Ubuntu website (or a different website, if the previous task was not completed):
   2.1. Perform the menu command History->Show All History;
   2.2. Perform a double left click on the item Today in the right pane;
   2.3. In the list, select Homepage | Ubuntu;
   2.4. Press Delete on the keyboard.
3. Delete all browsing data:
   3.1. Perform the menu command Tools->Clear Recent History;
   3.2. In the Clear Recent History dialogue box, under the menu Time range to clear, choose Everything;
   3.3. Expand the list of objects to be deleted by clicking on the Details button, if the list is not already visible;
   3.4. Make sure that everything is selected except Site Preferences;
   3.5. Click the button Clear Now:
4. Make sure that all browsing history has been deleted:
   4.1. Perform the menu command History→Show All History;
   4.2. Make sure that the panes of the Library dialogue box do not show the visited pages;
   4.3. Close the Library dialogue box by clicking the Close button in the title bar;
   4.4. Close the browser.

Useful tip:
If the user does not wish the browser to save the browsing data – history, temporary files, cookies – it is possible to use the browser’s private mode.
It is enabled in Mozilla Firefox with the menu command Tools→Start Private Browsing.

Online Search

The volume of information available online is very vast. The number of registered websites today exceeds 13.5 billion (www.worldwidewebsize.com). Naturally, it would not be possible to create a print catalogue of the web, and web content is dynamic and constantly changing – new sites are opened, existing ones are closed.

Search Engines

To be able to find information without knowing a site’s address, search engines are used. They allow finding information by keywords or specific topics.

Search engines operate automatically; they regularly crawl the web and register newfound sites in their databases, thus creating an electronic catalogue. For a user to use a search engine, he or she must connect to it by opening the engine’s website in a browser.

Some of the most popular search engines:
- **Google** – www.google.com. The search engine is available in different languages.
- **Yahoo!** – www.yahoo.com
- **Bing** – www.bing.com
- **Ask** – www.ask.com

**To find information online:**

1. Open the home page of a search engine;
2. Enter the keyword (keywords) in the search field;
3. Click the search button;
4. View the results;
5. Open the resource found.

**Useful tip:**

If it is necessary to find a specific phrase, it is placed inside quotation marks; e.g., the search results of the words *writer tips* and *“writer tips”* will be different.

Search results present a brief description of the website found and provide a link:

> "writer tips"

<table>
<thead>
<tr>
<th>34 Writing Tips That Will Make You a Better Writer</th>
</tr>
</thead>
<tbody>
<tr>
<td>59 posts - 52 hours - Last post: 11 Dec 2007</td>
</tr>
<tr>
<td>I feel I have listened to so many writer’s tips to write well. I’ll try using them from now to sharpen my writing. ...</td>
</tr>
<tr>
<td><a href="http://www.dailywritingtips.com/34-writing-tips-that-will-make-you-a-better-writer/">www.dailywritingtips.com/34-writing-tips-that-will-make-you-a-better-writer/</a> - Cached - Similar</td>
</tr>
</tbody>
</table>

**Useful tip:**

Avoid overly general keywords. For example, the keyword *auto* will return approximately 2.5 billion results.

Search engines offer advanced options for more accurate results. For example, it is possible to exclude pages containing a particular word, or search by date, language or file format.

**To use the advanced options of a search engine:**

1. Click the button (link) for advanced options on the search engine’s site;
2. Fill the relevant fields;
3. Click the search button.

The appearance and settings of this page can differ in various search engines. For example, the advanced search page of **Google**:

In this example, the search will be conducted for **PDF** documents in Estonian, containing the word **openoffice** or phrase **openoffice writer**, but not containing the words **calc**, **impress**,** base**, **draw**, and published online during the past month.

The same search could be performed by entering the following in the **Google keyword** field:

`openoffice OR "openoffice writer" ~calc, ~impress, ~base, ~draw filetype:pdf`

**Useful tip:**
There is also a built-in search window in the toolbar of **Mozilla Firefox**, allowing to choose the search engine:

**Searching in Specialized Web Resources**
A search feature is also available on many sites. In large sites, it is an invaluable tool for finding information. For example, browsing the popular site www.youtube.com would be hard to imagine without a search system. Searches are performed the same way as in search engines – enter a keyword (keywords), execute the search, and view the results:

![YouTube search results](image)

The same applies to web-based encyclopaedias and dictionaries. For example, one of the most popular online encyclopaedias www.wikipedia.org (Wikipedia, Wiki):

![Wikipedia search results](image)

**Forms in Web Pages**
Many websites allow not only browsing the information posted on their pages, but also receiving a service or posting your own information. For example, to use e-mail, shop online or submit data to a public authority, it is first necessary to register for the service – submit your user data. In web pages, this is usually done with the help of special forms. The user fills the fields and submits the form data.

For example, the user registration form of www.youtube.com:

![Image No. 5. User registration at www.youtube.com](image)

A – Radio button; B – Checkbox; C – Terms of service; D – Form submission button; E – Text field; F – Drop-down list

Using Web Resources

Saving a Page

Although a browser allows saving a web page for offline use, it is not always successful. Upon saving a web page, the browser will also try saving the pictures and other objects on the page. The possibilities of saving also depend on the page’s code and technological solutions.
A web page displayed in a browser consists of many elements, pictures, text, multimedia objects. Some of this information may not be located on the same web page, but rather be linked from other sites.

Links to other pages also will not work without an Internet connection.

**To save a web page in Mozilla Firefox:**

1. Perform the menu command `File->Save Page As`;
2. In the `Save as` dialogue box, specify the save location on the computer;
3. Confirm saving the page.

**Printing a Page**

Web pages are developed for viewing on a computer screen. They do not have a specific page format, unless the page is specially prepared for printing. Therefore, the appearance of a page on the display in a browser and the printed version can significantly differ. It is recommended to view a page preview before printing, and adjust the page settings: margins, orientation, page size.

**To preview a web page:**

Perform the menu command `File->Print Preview`.

To change the settings:

1. Perform the menu command `File->Page Setup`.
2. In the `Page Setup` dialogue box:
   2.1. In the `Format for` menu, select the printer;
   2.2. In the `Paper Size` menu, choose the page format;
   2.3. Choose the page orientation;
   2.4. Apply the changes by clicking `Apply`.

**Useful tip:**

Page settings can also be changed from the print preview, by clicking the `Page Setup` button.

**To print a web page (page selection, specific pages):**

1. Perform the menu command `File->Print`
2. In the **General** tab of the **Print** dialogue box, choose the print settings;
3. Print by clicking the **Print** button.

---

**Using Web Page Content**

The content of web pages – such as text and pictures – can be copied into other documents.

**Note!**

The content of a web page may be protected with copyrights even if this is not explicitly stated on the page. Before copying content, check the site’s terms & conditions and read the disclaimer, if available.

**To copy web page content:**

1. Select page content;
2. Perform the copy command with any of the available (known) methods;
3. Specify the paste location in another document;
4. Perform the paste command with any of the available (known) methods.

Copy commands:
Web browsing and communication

- Menu command **Edit->Copy**;
- Keyboard shortcut **Ctrl+C**;
- **Copy** command in the right mouse click menu, by right-clicking on the selection:

![Copy command](image)

Paste commands:
- Menu command **Edit->Paste**;
- Keyboard shortcut **Ctrl+V**;
- **Paste** command in the right mouse click menu:

![Paste command](image)

**Note!**
To copy images from a web page for pasting into another document, use the right-click menu command **Copy**.

**Saving Files**

Files published online can be saved by users on their computers. This process is called downloading. It can be done in various ways, depending on the methods used by the site’s developer. In some cases, it is enough to simply click a file icon or link; other times it is necessary to directly perform a save action or use a special **Download** command.

Download progress in **Mozilla Firefox** is displayed in a separate dialogue box.

**To save a file from a web page:**

1. Activate the download;
2. In the dialogue box, choose **Save File**:

![Save File dialogue](image)

3. Click **OK**.

**Note!**
By default, **Mozilla Firefox** saves downloaded files to the **Downloads** folder of the user account. This setting can be changed in the **General** tab of the preferences dialogue box. It can be opened with the command **Edit→Preferences**.

A – Save the files in the specified folder; B – Always ask where to save files; C – The save location on the computer’s file system; D – To choose a different folder

*Image No. 8. Changing file save settings in the **General** tab of the Firefox Preferences dialogue box*

**Task 7.4. Use a search engine to find information. Find and download a file. Use an online encyclopaedia. Copy information into another document. Save a web page**

1. Find information online about the operating system **Linux Ubuntu**:

   1.1. Activate the web browser **Mozilla Firefox**, if it is not already open:
      
      1.1.1. Perform the menu command **Applications→Internet→Firefox Web Browser** in the top panel menu.
   
   1.2. Open the search engine site **www.google.com**:
      
      1.2.1. In the address field of the browser, replace the existing text with the address **www.google.com**;
      
      1.2.2. Press **Enter** on the keyboard
   
   1.3. In the search field, enter the words „Linux Ubuntu” in inverted commas:

      "Linux Ubuntu"

   1.4. Click the **Google Search** button.
   
   1.5. Open the first website found:
      
      1.5.1. Position the mouse pointer over the link of the first result;
      
      1.5.2. Perform a left mouse click:

      **Homepage | Ubuntu**
      
      [Tulko šo lapu]
      
      Official site: Commercially sponsored Debian-derived Linux distribution that focuses on usability, a regular 6-month release cycle, and a commitment to support.
      
      Download - Ubuntu for you - Support - Why use Ubuntu?
      
      www.ubuntu.com/ - Sauglabātā kopija - Līdzīgs
   
2. Locate and save on the computer a document in **PDF** format about **OpenOffice.org Base**, excluding the other components of the suite – **Writer, Drawing, Impress, Calc**:

   2.1. Click the **Back** button in the browser’s toolbar twice to return to the **Google search home page**;
   
   2.2. Perform a left click on the **Advanced Search** link:

   **Advanced search**
   
   **Language tool**
   
   2.3. Complete the fields of the search form as shown in the image:
2.4. Activate the link **Date, usage rights, numeric range, and more** by left-clicking on it;

2.5. In the **Date** menu, choose **Past Week** under how recent the page is:

2.6. Click the **Advanced Search** button;

2.7. Click on the link of the first document found;

2.8. In the **Opening** dialogue box, choose **Save** File:

2.9. Click **OK** in the dialogue box;

2.10. Perform a double left click on the downloaded file in the **Downloads** dialogue box;

2.11. Close the document by clicking the **Close** button in its title bar;

2.12. Close the **Downloads** dialogue box by clicking the **Close** button in its title bar.

3. Find information about the ECDL programme on **Wikipedia**:

3.1. Open the **Wikipedia** homepage:

3.1.1. Perform a double left click in the browser’s address field;

3.1.2. Enter the site address **www.wikipedia.org**;

3.1.3. Press **Enter** on the keyboard.

3.2. Select the **English** version of the encyclopaedia:

3.3. In the **Search** field, enter **ECDL**:
3.4. Press **Enter** on the keyboard;
3.5. In the results, click the link European Computer Driving Licence:

**ECDL**

*From Wikipedia, the free encyclopedia*

**ECDL** is an acronym which may refer to:

- *El Canto del Loco*, a Spanish pop group
- **European Computer Driving Licence**, a computer literacy certification programme
- **European Conference on Digital Libraries**, an international conference series

4. Save the web page found:
4.1. In the menu of the browser, perform the command **File→Save Page As**;
4.2. In the **Places** pane of the **Save as** dialogue box, select the folder **Documents**;
4.3. Click **Save**.

5. View a print preview of the web page. Set page format **A4**:
5.1. Perform the menu command **File→Print Preview**;
5.2. In the preview window, click the **Page Setup** button;
5.3. In the **Paper Size** menu of the dialogue box, choose the **A4** format;
5.4. Click **Apply**;
5.5. Close the preview window by clicking the **Close** button in the toolbar:

6. Copy the first three paragraphs into a new text document:
6.1. Select the first three paragraphs of the main article:
6.1.1. Perform a left click at the end of the third paragraph;
6.1.2. While holding the mouse button, drag the pointer to the beginning of the first paragraph;
6.1.3. Release the mouse button.
European Computer Driving Licence
From Wikipedia, the free encyclopedia

The European Computer Driving Licence (ECDL), also known as International Computer Driving Licence (ICDL), is a computer literacy certification programme provided by the ECDL Foundation, a not-for-profit organization.

The ECDL/ICDL certification is a globally recognized information and communication technology (ICT) and digital literacy qualification. According to the ECDL Foundation, the ECDL/ICDL certification is recognized and supported by national governments, computer societies (such as the BCS and ICS), international organizations and private corporations.

In 1995, the ECDL certification programme was developed through a task force of the Council of European Professional Informatics Societies (CPEPS) and was recommended by the EU Commission High Level Group ESSID, to be a Europe-wide certification scheme. In addition, the project receives funding and is indirectly supported by the EU Commission through ESPRIT and the Leonardo da Vinci program.

6.2. Copy the selected text:
   6.2.1. Press Ctrl on the keyboard;
   6.2.2. While holding the key, also press C on the keyboard;
   6.2.3. Release the keys.

6.3. Create a new document:
   6.3.1. Perform the top panel menu command Applications→Office→OpenOffice.org Word Processor.

6.4. Paste the copied text in a document:
   6.4.1. Press Ctrl on the keyboard;
   6.4.2. While holding the key, also press V on the keyboard;
   6.4.3. Release the keys.

7. Copy the picture with the ECDL logo into the document:
   7.1. Switch to the browser window by using the button in the bottom panel:
   7.2. Perform a right click on the picture with the ECDL logo:
   7.3. In the right-click menu, perform the Copy command;
   7.4. Switch to the document window by using the button in the bottom panel;
   7.5. Paste the picture:
   7.5.1. Right-click below the text in the document;
   7.5.2. In the right-click menu, perform the Paste command;
8. Save the document:
   8.1. Click the **Save** button in the document’s toolbar;
   8.2. In the **Name** field of the **Save** dialogue box, enter the filename **ECDL**;
   8.3. Click **Save**;
   8.4. Close the document by clicking the **Close** button in the title bar.

**Online Security**

**Viruses**

A computer virus is a small programme or executable file designed to cause harm and operating without the user’s knowledge.

Computer viruses may damage files, slow down or freeze the operating system, acquire confidential information from the user’s computer and forward it to the author of the virus.

Computers today are often interconnected in networks and connected to the Internet. By taking advantage of vulnerabilities in operating systems, viruses can spread quickly. Websites can also be infected; they may have hidden executable files.

If, while browsing a page, a message appears on your screen, offering to check your computer for free or fix your computer system, or making any other offer to download a file, you must understand that this may be a virus, spyware, or other type of malware.

An example of malware posing as an antivirus:
A type of malware that blocks the desktop and encrypts the user’s files is also widespread. A payment is demanded from the user to restore access to the encrypted files.

Some examples of computer viruses:

- **Logic Bombs** – viruses that are set off on a specific time and date or by a remote command.
- **Trojans** – named by analogy to the tale from the history of Ancient Greece; a virus that opens a hole unauthorized by the user in the computer’s security system.
- **Worms** – worms spread in computer networks by using the vulnerabilities of operating systems.
- **Macro Viruses** – these infect the files of particular applications. Macro commands are small programmes that work within a document to automate an action. Macros are frequently used in word processors, spreadsheets, databases.

The largest number of viruses exist for the environment and files of Windows.

**Note!**

The default installation of the operating system **Linux Ubuntu** does not include an antivirus.

Protection of a computer against viruses requires:

- Not opening suspicious e-mail attachments;
- Avoiding unsafe websites;
• Installing an antivirus on the computer;
• Regularly updating the antivirus;
• Using a firewall.

**Phishing**

Phishing is a fraudulent way of attempting to acquire personal or financial information. A user may receive an e-mail message, purportedly from a financial (or other) institution, requesting the user to visit a particular site. This site is fake, but visually disguised to appear as the respective institution’s real site. If the user enters any confidential data on this site, such as his or her credit card number, Internet bank codes, password, or passport information, they are acquired by the phisher.

**Firewall**

As most computers today are connected, in one way or another, to a network with an Internet connection, there is risk of unauthorized outside access to information. One of the available security solutions is a firewall. It may be both a physical device and software. A firewall allows the browser to make queries online and receive responses to them, but blocks requests from the Internet (computer network) that are “unknown” to the firewall. Many operating systems include a firewall in their default installation.

**Username and Password**

To ensure authorized access to online services, usernames and passwords are used for identification. Only by entering the right combination of a username and password can you access, for example, your webmail account or profile on a social networking site.

When registering for an online service, choose the password carefully. A secure password contains at least eight characters – uppercase and lowercase letters, digits and symbols, in mixed order. Of course, such a password is difficult to remember, but it is possible to transform a common word, such as `mypassword`, into `Myp@s$w2rD`.

**Note!**

Passwords are case-sensitive. For example, the passwords `myp@s$w2rd` and `Myp@s$w2rD` are different.

Do not use easily guessable passwords, such as your car’s registration number, pet’s name, etc.

**Security Code**

It is possible to write a malicious programme that will automatically register many accounts for an online service. It can also attempt to guess the password of someone’s personal account or e-mail.
To limit repeated actions in a form or in password/username fields, a security code is used. It may be a sequence of letters unrecognizable by the malicious software, or a problem that must be solved by a person, such as a mathematical equation:

![](image)

**Digital Certificate**

A digital certificate attests the authenticity of a site and ensures a secure connection between the site and the user’s browser. Digital certificates are issued by authorized web service organizations, guaranteeing the genuineness of the site.

The presence of a digital certificate is indicated by the padlock symbol in the Mozilla Firefox status bar. The issuer of the certificate is displayed by hovering the mouse pointer over the symbol:

![Digital Certificate Image]

**To view the digital certificate data:**

1. Perform a left click on the padlock symbol in the browser’s status bar;
2. In the **Security** tab of the **Page Info** dialogue box, click **View Certificate**;
3. View the information included in the digital certificate:
A secure connection means that data are transmitted in encrypted form. If someone has illegally connected to the data stream or computer network, it will still be impossible to acquire the actual data – such as usernames, passwords, form data – or to modify them.

Encrypted connections are used, for example, for financial transactions online. An encrypted connection is easy to recognize by the transfer protocol `https://` in the address field:

![https://www.mybank.com/transactions/](https://www.mybank.com/transactions/)

**Electronic Signature**

The electronic signature is essentially a replacement of the regular signature in electronic environment. It is legally-binding, regulated by laws and regulations, and safer against forgeries that a typical signature on paper. The electronic signature is used in electronic document registration systems. Documents signed with an electronic signature can be e-mailed or published online.

Like websites, a person can obtain an authenticated digital certificate, confirming the person’s identity in the electronic environment. This digital certificate is used in the creation of the electronic signature.

**Additional Settings in Browsers**

Web browsers offer optional settings for customization to the user’s needs. The preferences of Mozilla Firefox in Linux can be changed in the dialogue box **Firefox Preferences**.

To open the dialogue box Firefox Preferences:

Perform the menu command **Edit→Preferences**.
Blocking Pop-up Windows

Pop-up windows are an element of web pages that opens in a separate window. They may also open automatically while browsing a website, if the developer of the site has allowed it. Pop-up windows usually display advertisements, survey forms, pictures, multimedia objects, offers to install software (malware) on the user’s computer. Often these pop-up windows make browsing difficult and are annoying. The opposite situation is also possible – when necessary pop-up windows are blocked and need to be allowed.

Most modern browsers allow blocking these pop-up windows. In Mozilla Firefox, the blocking of pop-up windows is enabled by default. This setting can be changed in the Contents tab of the Firefox Preferences dialogue box. It is also possible to set exceptions – sites where pop-up windows are allowed.

To disable (enable) blocking of pop-up windows:

1. Open the dialogue box Firefox Preferences;
2. Open the Content tab of the dialogue box;
3. Tick or un-tick the checkbox Block pop-up windows.

To add an address to the list of allowed sites:

1. Open the dialogue box Firefox Preferences;
2. Close the Content tab of the dialogue box;
3. Click the Exceptions button opposite to the checkbox Block pop-up Windows;
4. In the Address of web site field, enter the site address;
5. Click the Allow button;
6. Close the dialogue boxes:
To remove a site address from the list:

1. Open the dialogue box **Firefox Preferences**;
2. Open the **Content** tab of the dialogue box;
3. Click the **Exceptions** button opposite to the checkbox **Block pop-up Windows**;
4. In the dialogue box **Allowed Sites-Pop-ups**, select the site’s address;
5. Click the **Remove Site** button;
6. Close the dialogue boxes.

**Blocking Cookies**

Cookies may contain private information, and sites can use them for identification of a user and computer on the web. Spyware can “mark” the computer with the help of a cookie. Cookies are stored on the user’s computer. If this is not desired, it is possible to disable them in the browser.

To disable (allow) cookies:

1. Open the dialogue box **Firefox Preferences**;
2. Open the **Privacy** tab of the dialogue box;
3. In the **History** pane, under the **Firefox will** menu choose **Use custom settings for history**;
4. Remove the tick from the checkbox **Accept cookies from sites**;
5. Close the dialogue box **Firefox Preferences**.

**Note!**

Disabling cookies may affect the work of web pages, forms. In this case, a warning can appear on the site, such as this:

Cookies are currently **DISABLED** in your web browser, or you have Internet security software that is preventing them from reaching us. Please read the following instructions to enable them.

To disable or enable cookies for specific sites:
1. Open the dialogue box Firefox Preferences;
2. Open the Privacy tab of the dialogue box;
3. In the History pane, under the menu Firefox will, choose Use custom settings for history;
4. Click the Exceptions button opposite to the checkbox Accept cookies from sites;
5. In the Address of web site field, enter the site address;
6. Click the Allow button to allow using cookies from this site, Block – to block, Allow for Session – to allow using cookies only for the specific session;
7. Close the dialogue boxes:

Useful tip:
The cookies stored in the browser can be viewed by clicking the Show Cookies button in the cookie settings dialogue box:

Publishing Information

There is a large number of online services that allow users to post photos or videos – such as social networking sites. Websites also allow contacting other persons, and a user can pretend to be anybody. The only way of finding out more is looking at the information provided by this person in his or her user profile.

A user profile (account) contains the data that the user has posted about him- or herself.

Note!
Before publishing data in an online profile, think about their significance and importance. Profile data will be available to other users, and may also be found with search engines.

If possible, restrict the viewing of your profiles; allow your data to be accessed only by known users of the online service.
Parental Control

In modern operating systems, it is possible to automatically restrict Internet access times, block or allow viewing specific sites.

The software **Nanny Parental Control** is popular in Linux Ubuntu operating systems. The software can be added from the **Ubuntu Software Center**. Adding and removal of software is examined in Module 2 of the ECDL course – “Using the Computer and Managing Files”.

Limits are applied to user accounts; the settings are protected with the computer administrator’s password.

**Nanny** allows to:
- Restrict access time to the computer and Internet – specific days and hours;
- Limit the total time of use of the computer and Internet;
- Block specific site addresses;
- Allow specific site addresses;
- Set restrictions on using e-mail;
- Set restrictions on instant messaging.

**Task 7.5.** Check whether the site www.gmail.com has a digital certificate. Check the pop-up window blocker of the browser. Disable cookies. Restore the settings

1. Activate the web browser **Mozilla Firefox**, if it is not already open:
   1.1. Perform the command **Applications->Internet->Firefox Web Browser** in the top panel menu.
2. Open the site **www.gmail.com**:
   2.1. Select the text in the address field of the browser;
2.2. Enter the site address www.gmail.com;
2.3. Press Enter on the keyboard

3. Determine the identity of the site:
   3.1. Perform a double left click on the key symbol in the right side of the browser’s status bar:

   ![Authenticated by Thawte Consulting (Pty) Ltd.]

   3.2. Make sure that the Security tab is open in the Page Info dialogue box;
   3.3. View the site’s identity information:

   ![Page Info - https://www.google.com]

   3.4. Close the dialogue box by clicking the Close button in the title bar:

4. Make sure that a secure connection is being used for data transmission:
   4.1. View the networking protocol of the current page in the address bar:

   ![google.com https://www.google.com/accounts/]

5. Test the settings of the pop-up window blocker:
   5.1. Open the site popuptest.com:
      5.1.1. Perform a double left click inside the browser’s address bar;
      5.1.2. Enter the site address popuptest.com;
      5.1.3. Press Enter on the keyboard
   5.2. Activate the link Multi Pop–Up Test:

   ![Multi-Popup Test
This page launches 10 popup windows, using different techniques...]
   ![Multi-Popup Test #2
This page launches 4 popup windows, using different techniques...]

   5.2.1. Position the mouse pointer on the link;
   5.2.2. Click the left mouse button.
5.3. View the notice at the top of the current page;
5.4. View the prohibition symbol in the browser’s status bar:

6. Open one of the blocked pop-up windows on this page:
   6.1. Click the Preferences button in the upper right corner of the page’s tab;
   6.2. Click on the first pop-up window popup1.html:

6.3. Close the pop-up window by clicking the Close button in its title bar:

7. Disable the pop-up window blocker:
   7.1. Perform the menu command Edit→Preferences;
   7.2. In the Firefox Preferences dialogue box, open the Content tab by clicking on its name with the left mouse button;
7.3. Remove the tick from the checkbox **Block pop-up Windows** by left-clicking on it;
7.4. Close the dialogue box by clicking **Close**;
7.5. Click the button **Reload current page**:

![Reload current page](image)

7.6. Close all pop-up windows by clicking the **Close** button in their title bars;
7.7. Enable the pop-up window blocker again:
   7.7.1. Perform the menu command **Edit->Preferences**;
   7.7.2. In the Firefox **Preferences** dialogue box, open the **Content** tab, if it is not already open;
   7.7.3. Tick the checkbox **Block pop-up Windows** by left-clicking on it;
   7.7.4. Close the dialogue box of the setting by clicking **Close**.

8. Disable cookies:
8.1. Perform the menu command **Edit->Preferences**;
8.2. In the Firefox **Preferences** dialogue box, open the **Privacy** tab by clicking on its name;
8.3. In the Firefox will menu, select **Use custom settings for history**;
8.4. Remove the tick from the checkbox **Accept cookies from sites** by left-clicking on it;
8.5. Click the **Close** button to close the dialogue box;
8.6. Check the settings:
   8.6.1. Open the site **www.gmail.com**:
      8.6.1.1. Perform a double left click in the browser’s address bar;
      8.6.1.2. Enter the site address **www.gmail.com**;
      8.6.1.3. Press the **Enter** on the keyboard.
8.6.2. Click inside the **Google Account Username** field;
8.6.3. Enter the username **ecdtestuser**
8.6.4. Click inside the **Password** field;
8.6.5. Enter the password **P@$$word**;
8.6.6. Click **Sign in**:

![Sign in with your Google Account](image)

8.7. If cookies are disabled, a corresponding notice will appear:
8.8. Enable cookies:

8.8.1. Perform the menu command **Edit->Preferences**;
8.8.2. In the Firefox **Preferences** dialogue box, open the **Privacy** tab, if it is not already open;
8.8.3. In the Firefox **will** menu, choose **Use custom settings for history**;
8.8.4. Remove the tick from the checkbox **Accept cookies from sites** by left-clicking on it;
8.8.5. Click the **Close** button to close the dialogue box.

9. Find information about yourself online:

9.1. Click inside the built-in search field of **Mozilla Firefox**;
9.2. Enter your first and last name;
9.3. Press **Enter** on the keyboard;
9.4. View the search results.

**Note:**

Instances of other people with the same first and last name are possible.

---

**Electronic Mail**

Electronic mail uses the Internet and its framework for submission of messages. Messages are quickly delivered to anywhere in the world within seconds. Electronic post is described by rapid and low-cost operation. It is also possible to attach files to an e-mail message – photos, documents. A message can be submitted to a large number of recipients at the same time.

Unfortunately, these possibilities are also used by spam senders by distributing advertisements and malware files.

**Note!**

Evaluate the level of trustworthiness of unknown senders. In most cases they are fraudulent, and may contain viruses or malware in the attached files.

Users of electronic communications observe unwritten rules sometimes called “netiquette”:

- Make the content of the message clear and understandable, without ambiguities;
- Use the subject line;
- Observe the etiquette that applies to written text;
- Do not unnecessarily “pretty up” your message by overusing text in different colours, pictures, tables. It is better to send formatted documents as an attachment;
- Messages do not require paper;
• Messages can be received on mobile devices.

As the receiver and sender of electronic mail usually do not see one another, the emotional tone of a message can be conveyed with smilies, which are available in e-mail clients and webmail as graphical icons, or can be typed manually – e.g., :-)) or 😊 both express a smile.

It is recommended to spell-check an e-mail message before sending it.

**Prerequisites**

To use electronic mail, the user must have an e-mail inbox registered – must be a registered user of an e-mail system. Companies and organizations often maintain or lease their own e-mail system with technical support. E-mail accounts for employees are created by the company’s IT experts.

An e-mail account can also be created by one of the publically-available paid or free service providers. The e-mail service provider has a dedicated computer available – a server with the software necessary to manage e-mail. If this service is oriented toward public use, there will usually also be a website available for access the e-mail.

Some popular e-mail service providers:
- [www.gmail.com](http://www.gmail.com) – available in different languages;
- [mail.yahoo.com](http://mail.yahoo.com)
- [www.inbox.com](http://www.inbox.com)
- [www.inbox.lv](http://www.inbox.lv)
- [mail.com](http://mail.com)

By registering, the user obtains an e-mail account created on the service provider’s server on the Internet.

**Note!**

The content, layout and design of various websites can significantly differ. There can also be differences in the information required in new user registration forms.

**To register an online e-mail account:**

1. Choose a service provider;
2. Open the website of the e-mail service;
3. Click the button to register a new user (activate a link);
4. Complete the new user form by entering the required data:
   4.1. Choose a username;
   4.2. Choose a password;
   4.3. Enter the other required data;
   4.4. Approve the creation if your e-mail account.

**Note!**
The selected username may already be taken in the e-mail system. The system will not allow creating another user with the same username (e-mail address). There may be a minimum password length and other requirements in the registration system.

The service provider maintains the system, ensures interconnection with other e-mail service providers and the accounts of their clients. For an electronic mail system to function normally, the service provider registers a domain name in a domain name registry and gives a name to the server, so that it can be found on the Internet. This domain name forms the part of the e-mail address that cannot be changed or chosen by the user, such as:

```
gmail.com
```

Upon registering an e-mail account, the user typically chooses or is assigned a username, which forms the first part of the e-mail address. The username is separated from the domain name by the @ symbol, e.g.:

```
ecdltestuser@gmail.com
```

After registration, the user obtains:
- an electronic mail account on a mail server;
- an e-mail address corresponding to the account, which is unique and does not repeat anywhere on the Internet;
- a username and password for e-mail access;
- the Internet address of the server on which the account is stored. The user may not know this address if the e-mail account is accessed through a web page;
- a website address to access the e-mail account through a web browser, if offered by the service provider.

**How E-mail Works**
To access your e-mail account, use:
- a website, if offered by the e-mail service provider;
- a special application – an e-mail client.

A website can be easily accessed from any computer with an Internet connection. All messages are stored on the e-mail server. The mail is viewed and new messages are created in a web page.

**Note!**
Many e-mail service providers limit the maximum size of an e-mail account on the server. If the inbox is full, new messages are not accepted, and new messages cannot be mailed.

An e-mail client is installed on the user’s computer. Mail messages are downloaded and stored on the computer. They can be used even when an Internet connection is not available, and they do not have to be downloaded anew every time. E-mail clients are particularly suitable for larger amounts of electronic correspondence. A single client can work with multiple e-mail accounts. The client also provides a range of additional options, such as automatic message filtering and sorting, integration of an organization’s shared address book, or a possibility to work in offline mode.

It is possible to use a combination of both methods.

Popular e-mail clients:
- Evolution Mail;
- Mozilla Thunderbird;
Module 7

- KMail;
- Claws Mail;
- Outlook (for Windows systems).

Regardless of what method of access and software is used for electronic mail, the actions are performed very similarly.

**Note!**
This material examines the default e-mail client installed on Ubuntu Linux – Evolution Mail.
The sequence of actions and filling of fields is similar in other e-mail clients and web forms.

**Evolution Mail**

E-mail clients and webmail use folders for organization of messages.

The folders in **Evolution**:
- **Inbox** – incoming mails;
- **Drafts** – drafts, unfinished messages;
- **Junk** – undesirable e-mail. Clients usually have a built-in junk mail filter. The messages that the application determines to be junk are placed in this folder;
- **Outbox** – messages to be sent. If the Internet connection is available, this folder is usually empty – all messages have been successfully mailed;
- **Sent** – copies of sent messages;
- **Templates** – message templates;
- **Trash** – a folder for deleted e-mail messages.
The content of a selected folder can be viewed in the right pane.

The content of a selected message can be viewed in the message pane.

**To hide (display) elements of the application window:**

1. Perform the command **View→Layout**;
2. Choose the window elements:
   2.1. **Toolbar**;
   2.2. **Side Bar**;
   2.3. **Status Bar**.

**To use the application’s help system:**

1. Perform the menu command **Help→Contents**;
2. Click the necessary link;
   or
2. Use the **Search** tool:

![Evolution 2.30 User Guide](image)

**Sending a Message**

**To work with e-mail messages on the web page created by the service provider:**

1. Open the web browser;
2. Open the e-mail website;
3. Enter the username and password;
4. Open your e-mail account:

To use an e-mail client:

Open the e-mail client on the computer.

**Note!**

When an e-mail client is first launched, it must be prepared for use – the settings of the account must be entered: the incoming and outgoing mail server, mailbox type, display name that will be seen by recipients, username, password.
To send a new e-mail message:

1. Launch the e-mail client (open the web page and your account);
2. In *Evolution Mail*, click the button **New – Compose a new mail message**;
3. In the **Compose Message** dialogue box:
   3.1. In the **To** field, enter the full e-mail address of the recipient. If a message is mailed to several recipients, separate their e-mail addresses with a comma. Filling this field is mandatory in e-mail clients and webmail.
   3.2. In the **Cc** field, enter the e-mail address of the person who should receive a copy of the message, if any. The recipient will see that he or she has been mailed a copy of the original message. This field is usually used in e-mail correspondence when no response is expected from the recipient, and the message has an informative character. For example, a message about the commencement of a new project: in the **To** field, enter the address of the project manager, and notify the accounting department by entering the corresponding accounting address in the **Cc** field. This field is optional.
   3.3. The recipients entered in the **Bcc** field will not been seen by the other recipients of the message. Recipients whose addresses are entered in the fields **To** and **Cc**
also see all other recipients of the message, except those in the **Bcc** field. This field is optional.

**Note!**
This field is often hidden in e-mail clients and webmail. In webmail, it can be displayed by clicking a corresponding link.

In **Evolution**, it is opened in the menu **View→Bcc Field**:

3.4. The topic of the message is entered in the **Subject** line. Although this field is optional, filling it is highly recommended. Many e-mail systems consider messages without a subject to be junk and filter them. If the recipient receives a large number of messages, the subject line allows organizing them more easily.

3.5. In the message field, enter the main text. Actions with text are performed the same as in any other text input field. Two different message formats used:

- **Plain text.** A message in this format can only contain text. E-mail was initially developed for quick exchange of text-only messages.

- **HTML format.** Formatted messages with pictures, tables, highlighted text, background images, etc.

**Useful tip!**
Although modern e-mail clients allow working with rich HTML format messages, there are still many users that disable this functionality and prefer to receive plain-text messages.

In **Evolution**, the default message type is plain text. It can be changed in the **Editing Mode** menu:

4. After preparing the message, send it by clicking the **Send** button:

A copy of the sent letter is saved in the **Sent** folder.

**Spelling Check**

Before sending a message, it is recommended to check the spelling, if possible. Words that do not exist in the selected dictionary will be underlined with a red, wavy line.
To perform a spelling check in Evolution:

Press the function key **F7** in the first row of the keyboard, or perform the menu command **Edit−>Check Spelling**.

To select the spelling check language:

Perform the menu command **Edit−>Current Languages** and select the necessary language.

**Note:**
The operating system **Linux Ubuntu** needs to have dictionaries installed in the necessary languages. The spelling check in **Ubuntu** applications by default is performed by the software module **Aspell**.

To correct an underlined word:

1. Perform a right click on a word underlined in red;
   In the right-click menu, choose the right word from the dictionary.

**Note:**
While learning to work with an e-mail client or webmail, it is possible to send e-mail messages to your own address, without bothering other recipients with test messages.

**Task 7.6. Send a message with an e-mail client. Open the e-mail account in a web page**

**Note:**
When **Evolution** is first launched, it is prepared for work. The task uses a user account and data on **Google Mail**.

1. **Open Evolution**:
   1.1. Perform the top panel menu command **Applications−>Internet−>Evolution Mail**;
   1.2. In the **Evolution Setup Assistant** dialogue box, click **Forward**;
   1.3. Click **Forward** again, if necessary, to open the **Identity** window;
   1.4. In the **Full Name** field, enter the display name **ECDL Candidate**;
   1.5. In the **E−mail Address** field, enter the e-mail address **ecdltestuser@gmail.com**:

   ![Required Information](image.png)

   1.6. Click **Forward**;
   1.7. In the **Receiving Email** dialogue box:
   1.7.1. In the **Server Type** menu, choose **POP**;

**Useful tip:**
**POP** (Post Office Protocol) – an Internet protocol for retrieving messages from a mail server. After a message is read, it is usually deleted from the server and transferred to the e-mail client.

**IMAP** (Internet Message Access Protocol) – for access to electronic mail on a server with the help of an e-mail client. Copies of the messages are usually left on the mail server. This protocol provides greater functionality, e.g., working with messages both online on the server and locally with a client in offline mode; it is possible to view messages alongside one another in an e-mail client and a web page.

**SMTP** (Simple Mail Transfer Protocol) – an Internet protocol for sending e-mail messages.

1.7.2. In the **Server** field, enter the mail server address **pop.gmail.com**;
1.7.3. In the **Username** field, enter the full e-mail address **ecdlttestuser@gmail.com**;
1.7.4. In the menu **Use secure connection**, choose SSL;
1.7.5. Click **Forward**:

![Configuration settings](image)

1.8. Click **Forward**;
1.9. Click **Forward** again;
1.10. In the **Sending Mail** dialogue box:
1.10.1. Make sure that **SMTP** is chosen under **Server Type**;
1.10.2. In the **Server** field, enter the server address **smtp.gmail.com**;
1.10.3. In the **Use Secure Connection** menu, choose **SSL encryption**;
1.11. Click **Forward**;
1.12. In the **Name** field of the **Account Management** dialogue box, enter the e-mail account name **ECDL Training**;
1.13. Click **Forward**;
1.14. Click **Apply** in the next dialogue box.

2. Read the messages on the e-mail account:
2.1. Click the **Send/Receive** button in the toolbar;
2.2. In the **Enter Password** dialogue box, enter **P@$sword**
2.3. Tick the checkbox **Remember this password**;
2.4. Click **OK**.

3. Send a test message:
3.1. Click the **New** button in the toolbar;

3.2. Create the message:

3.3. Click the **Send** button;

3.4. In the **Enter Password** dialogue box, enter **P@$$word**

3.5. Tick the checkbox **Remember this password**;

3.6. Click **OK**.

3.7. Do not close the application window.

4. Open the e-mail account in a web page:

4.1. Open the web browser **Mozilla Firefox**, if it is not already open:

   4.1.1. Perform the command **Applications−>Internet−>Firefox Web Browser** in the top panel menu.

4.2. Open the site **www.gmail.com**:

   4.2.1. Select the text in the browser’s address field;

   4.2.2. Enter the site address **www.gmail.com**;

   4.2.3. Press **Enter** on the keyboard.

4.3. Enter **ecdlspecialist** in the **Username** field;

4.4. Enter **P@$$word** in the **Password** field;

4.5. Click **Sign In**.
4.6. In the message list, left-click on the message with the subject **Test message**:

4.7. Read the message;

4.8. End the work in the webmail account:
   4.8.1. Click on the user e-mail address in the upper right corner;
   4.8.2. In the menu, choose the command **Sign out**:

5. Close the web browser:
   5.1. Click the **Close** button in the title bar.

**Receiving a Message**

The message arrives at the outgoing e-mail server, and is then transferred to the server on which the recipient's account is located.

**To read e-mail:**

1. Open the e-mail client **Evolution** (or open your account on the service’s website);
2. Click on the **Inbox** folder, if it is not already selected;
3. Click on a new message;
4. Read the message. In **Evolution**, it is displayed in the bottom pane of the window.

**Useful tip:**

Upon launching an e-mail client, by default it checks the account on the server and downloads new messages to the **Inbox** folder.

To check the inbox in **Evolution** after the client is already open, click the **Send/Receive** button in the toolbar:
New, unread messages are usually bolded and marked with a closed envelope symbol:

The application then automatically changes the message’s status to “read”.

**Performing Actions with Messages**

**To print an e-mail message in Evolution:**

1. Select the message;
2. Perform the menu command **File→Print Preview**;
3. In the preview window, click the button **Print this document**:

   ![Print this document](image)

In this case, one copy of the message will be printed on the computer’s default printer.

**To choose the print settings for the selected message:**

1. Perform the menu command **File→Print**;
2. In the **Print** dialogue box:
   2.1. Select the print device from the list of available printers;
   2.2. Set the pages to be printed;
   2.3. Set the number of copies.

**To reply to the message’s sender:**

1. Select a message in the list;
2. Click the **Reply** button in the toolbar:

   ![Compose a reply to the sender of the selected message](image)

3. Enter the reply above the original message;
4. Send the message.

**Useful tip:**
To reply to all recipients of the original message:

Click the button **Reply to All** in the toolbar:

![Reply to All button](image)

To forward the message to a different recipient:

Click the **Forward** button in the toolbar:

![Forward button](image)

**E-mail Attachments**

It is possible to attach files to an e-mail message – formatted and prepared documents, pictures, presentations, applications.

**Note!**

Many e-mail systems limit the total attachment file size and may limit the file types that can be attached.

Attaching overly large files causes problems to both the sender and recipient.

To attach a file to an e-mail message:

1. In **Evolution**, write a new message (reply, forward);
2. At the bottom of the **Compose Message** dialogue box, click **Add Attachment**:

![Add Attachment button](image)

3. Select a file on the computer;
4. Confirm attaching the file.

The files attached to a message are displayed in a separate pane. There it is also possible to remove them, if the user has changed his or her mind or accidentally attached incorrect files.

Attachments in e-mail clients and webmail are marked with a paperclip:
To remove an attached file:

1. Select a file;
2. Press **Delete** on the keyboard:

![Attachment options](image)

To open an e-mail attachment in Evolution:

1. Select an e-mail message;
2. Click on the menu at the attachment icon;
3. Perform the command **Open With** ...

![Email attachment](image)

To save an e-mail attachment on the computer:

1. Select an e-mail message;
2. Click on the menu at the attachment icon;
3. Perform the command **Save As**;
4. Select the save location on the computer;
5. Confirm saving.

**Additional Actions in Evolution**
Message Priority

The sender can choose the level of priority of the message. It does not change anything about the preparation or sending of the message, but shows to the recipient that the sender considers the message important.

To set message priority:

1. Prepare (reply to, forward) a message;
2. In the menu of the message window, perform the command **Options→Prioritize Message**;
3. Send the message.

**Note!**

Not all e-mail clients and webmail forms support prioritizing the message list.

The recipient can also highlight a particularly important message by flagging it in the e-mail client. In a similar way, the status of a message can be changed to “unread”.

To flag a message:

1. Select a message in the list;
2. Click in the flag column before the sender information:

   ![Flagging a Message](image1)

   To remove the flag, click again.

To change the status of a message:

1. Select a message in the list;
2. Click in the status column on the envelope symbol before the sender information:

   ![Changing Status](image2)

   To cancel the status change, click again.

Copying Content into a Message

If the text (or a part thereof) to be included in the message already exists, it can be reused by copying.

To copy existing text into a message:
1. Select the text;
2. Copy the text using one of the available methods, e.g., the menu command Edit→Copy;
3. Specify the paste location in the e-mail message;
4. Perform the paste command using one of the available methods, e.g., the menu command Edit→Paste.

**Drafts**

It is possible to create a draft message that isn’t sent immediately.

**To save a message as a draft:**

1. Create a new e-mail message;
2. In the new message window of Evolution, perform the menu command File→Save as Draft.

The unsent message will be saved in the Drafts folder.

**Sorting Messages**

Messages in Evolution are sorted in a list. Their main information is arranged in columns with headings at the top. The columns and the amount of information displayed can be changed.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>A – Read? Unread message; B – Attachments; C – Flagged messages; D – Sender; E – Message subject; F – Date</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Image No. 13. Message list in Evolution*

**To sort messages in a specific order:**

1. Click on the heading of the selected column once to sort in ascending (alphabetical) order;
2. Click on the heading of the selected column again to sort in descending (reverse alphabetical) order.

The selected column and sorting order is indicated by a triangle at the top of the column:
Module 7

To add columns to the list view:

1. Perform a right click on the heading of a column;
2. Choose the command Add a Column;
3. Drag the chosen columns to the subject bar:

4. Close the Add a Column dialogue box.

To remove a column:

1. Perform a right click on the heading of a column;
2. Choose the command Remove This Column.

In Evolution, and usually also in webmail, the built-in search feature makes finding messages easier.

To search messages by subject or the sender’s e-mail address:

1. In the Evolution toolbar, enter the message’s full or partial subject (sender’s address, name);
2. Click the magnifying glass icon in the search field;
3. Choose where to search:
   3.1. Subject or Addresses contain;
   3.2. Subject contains;
   3.3. Body contains.
4. Press the Enter key on the keyboard:
To cancel a search:
Click the clear icon at the end of the search field:

Working with Folders
In cases where there is a very large amount of messages, the user can arrange them in different folders for convenience.

To create a new folder in Evolution:

1. In the Mail pane, perform a right click on the item On This Computer;
2. In the right-click menu, perform the command New Folder;
3. Enter a name for the folder;
4. In the Create Folder dialogue box, complete the action by clicking Create:

To delete a folder:

1. In the Mail pane, perform a right click on the folder;
2. In the right-click menu, perform the command Delete;
3. Confirm deleting the folder.

Note!
Upon deleting a folder, all messages contained in it will also be deleted.

To copy (move) a message to a specific folder:

1. In the message list, perform a right click on the message;
2. In the right-click menu, perform the command Copy to Folder (Move to Folder);
3. Select the target folder in the dialogue box;
4. Confirm the copy (move):
Deleting, Restoring a Message

Like in other applications, the messages deleted in Evolution are placed in the application’s Trash folder, from which they can still be restored.

To delete a message:
1. Select a message in the list;
2. Press the Delete key on the keyboard.

To restore a message:
1. Select the Trash folder;
2. Perform a right click on a message;
3. In the right-click menu, choose the command Undelete Message.

To empty Trash:
1. Perform a right click on the Trash folder;
2. In the right-click menu, choose the command Empty Trash.

Address Book

A built-in address book makes saving contacts and sending e-mails easier.

Contacts

In Evolution, the address book is in the left pane:

To add a new contact:
1. Open the address book by clicking the Contacts button;
2. Perform the menu command File→New→Contact;
3. In the Contact Editor dialogue box, enter the known information in the fields;
4. Save the contact:

![Contact Editor - Sanders, A.](image)

**To add a sender to the address book:**

1. Select an e-mail message in the list;
2. Perform a right click on the sender’s e-mail address in the message pane;
3. In the right-click menu, choose the command **Add to Address Book**:

![Add to Address Book](image)

4. In the dialogue box **Contact Quick-Add**:
   4.1. Click OK;
   or
   4.1. Click **Edit Full** to add more data about the contact:

![Contact Quick-Add](image)

**To edit data:**

1. Open the address book by clicking the **Contacts** button;
2. Perform a right click on a contact;
3. In the right-click menu, perform the command **Open Contact**.

**To delete a contact:**
1. Open the address book by clicking the **Contacts** button;
2. Perform a right click on a contact;
3. In the right-click menu, perform the command **Delete**;
4. Confirm deleting the contact.

**Contact List**

A contact list combines a number of recipients under a single name to allow sending a message to them all at the same time. The result of using a contact list is similar to entering multiple addresses in the **To** field, only much simpler.

**To create a new contact list in Evolution:**

1. Open the address book by clicking the **Contacts** button;
2. Perform the menu command **File**−**New**−**Contact List**;
3. In the **List name** field of the **Contact List Editor** dialogue box, enter a name for the contact list;
4. In the field of the **Members** pane, enter a recipient’s e-mail address;
5. Click **Add**;
6. Repeat the steps for the other contacts to be included in the list;
7. Confirm creating the list:

![Contact List Editor](image)

A contact list is displayed with a special icon in the address book:

![Contact List in Address Book](image)

A contact list is edited in a similar way as a single contact.

**Task 7.7. Receive e-mail messages. Reply to a message by adding an attachment. Add a contact to the address book**
Web browsing and communication

Note:

To perform this task, task 7.6 must have been completed – the client must be configured and a test message must have been sent.

1. Launch Evolution, if it is not already open:
   1.1. Perform the top panel menu command **Applications--Internet--Evolution Mail**.
2. Check the messages;
   2.1. Click the button **Send/Receive** in the toolbar.
3. Reply to the message with the subject **Test message**:
   3.1. Select the message with the subject **Test message** in the message list;
   3.2. Click **Reply** in the toolbar;
   3.3. Add a picture as an attachment:
      3.3.1. In the message’s dialogue box, click **Add Attachment**;
      3.3.2. In the **Add Attachment** dialogue box, select the Documents folder in the Places pane;
      3.3.3. Perform a double left click on the folder 7_internet in the right pane;
      3.3.4. Perform a double left click on the folder 7.7_manage;
      3.3.5. Select the picture file mountain.jpg;
      3.3.6. Click the **Attach** button.
   3.4. Send the message:
      3.4.1. Click **Send**.
4. Check the e-mail messages:
   4.1. Wait 10 seconds. Click the button **Send/Receive**.
5. Sort the messages in alphabetical order by subject:
   5.1. Click the button at the top of the **Subject** column:

6. Find the message with the subject **Test message**. Add the recipient of this message to the contacts in the address book:
   6.1. Select the message with the subject **Test message** in the message list:
   6.2. Right-click on the recipient’s address **To**;
   6.3. In the right-click menu, perform the command **Add to Address Book**:
   6.4. In the **Contact Quick-Add** dialogue box, name the contact **Trainer**;
   6.5. Click **OK**:
7. Flag this message:
   7.1. Perform a left-click inside the flag column in the message’s line:

8. View a print preview of the message:
   8.1. Perform the menu command File→Print Preview;
   8.2. Close the print preview window by clicking Close in the title bar.

9. Delete the message:
   9.1. Press Delete on the keyboard.
   9.2. Restore the message:
      9.2.1. Select the Trash folder in the left pane;
      9.2.2. Select the message with the subject Test message in the list;
      9.2.3. Perform the menu command Edit→Undelete Message.

10. Create a draft message. Copy text from the file text.odt into the body of the message:
    10.1. Open the file text.odt:
       10.1.1. In the top panel menu, perform the command Places→Documents;
       10.1.2. Perform a double left click on the folder 7_internet in the right pane;
       10.1.3. Perform a double left click on the folder 7.7_manage;
       10.1.4. Select the file text.odt;
       10.1.5. Press Enter on the keyboard.
    10.2. Select text in the document:
       10.2.1. Perform the menu command Edit→Select All;
       10.2.2. Perform the menu command Edit→Copy;
    10.3. Switch to the Evolution window by using the button in the bottom panel:
    10.4. Click the New button;
    10.5. Click inside the message’s body;
    10.6. Perform the menu command Edit→Paste;
    10.7. Perform a spelling check:
       10.7.1. Press the function key F7 on the keyboard
       10.7.2. In the Replace dialogue box, select the right word sample;
       10.7.3. Click Replace:
10.8. Perform the menu command File -> Save As Draft;
10.9. Close the box by clicking the Close button in the title bar.

11. Create a new folder called Project:
   11.1. Perform the menu command File -> New -> Mail Folder;
   11.2. In the Create Folder dialogue box, enter Project in the Folder Name field;
   11.3. In the folder list pane, choose On This Computer;
   11.4. Click Create:

12. Move a message to the newly-created file Project:
   12.1. In the folders list, select the folder Inbox;
   12.2. In the message list, select the message with the subject Test message;
   12.3. Perform the menu command Message -> Move to Folder;
   12.4. In the Move to Folder dialogue box, select the folder Project;
   12.5. Click Move.

13. Create a contact list:
   13.1. In Evolution, perform the menu command File -> New -> Contact List;
   13.2. In the Contact List editor dialogue box, name the contact list ECDL;
   13.3. In the field Type an mail address..., enter the e-mail address ecdlspecialist@gmail.com;
   13.4. Click Add;
   13.5. Repeat the steps for the address ecdlguru@gmail.com;
   13.6. Click OK:
14. Close Evolution:

14.1. Click the Close button in the title bar.

Other Forms of Electronic Communication

Instant Messaging

Instant messaging differs from e-mail in that the former is real-time online communication between two or more users. Usually, special clients are used, or an instant messaging feature on a site. It is possible to send files as attachments. Instant messaging systems show the actual or selected online status of a person (whether or not the person is online).

VoIP (Voice over Internet Protocol)

The VoIP technology has been developed to provide voice telephony services in computer networks and on the Internet, replacing the use of public telecommunication networks. Although there were initially problems with communication quality, the situation has improved along with the growing stability and speed of Internet connections and the development of software.

The technology can currently be used not just between computers, but also with special phones. There are companies offering to replace the regular phones and phone lines with VoIP. The technology offers low-cost calls to both mobile phones and landlines through existing Internet connections.

Virtual Communities

A virtual community is a public (social) online network created by using the Internet environment and technologies. To use these services, it is usually necessary to register on the respective site.

Some examples of communication in virtual communities:

- Internet message boards for exchange of thoughts and discussions;
- Online chat;
- Online multiplayer games;
- Social networking sites with branching possibilities. Users can post information about themselves, upload videos, photos.

**Note!**

Publishing personal information on the Internet may make it available to other users of the respective service; it may also be indexed by Internet search engines!

**Text Messaging**

Text messaging or SMS (Short Message Service) is a way to exchange short text messages between mobile devices, send messages from special web pages to a mobile device, and vice versa. A message is usually up to 160 characters long.

Text messages have also been successfully integrated in social networking sites, such as [twitter.com](http://twitter.com). A registered user of this site can post messages from a mobile device and receive them on the phone, as well.

**Task 7.8. Test your knowledge by completing a practical assignment**

**Explanations:**

The assignment includes 31 tasks; the performance of each task is graded with points. The assignment must be completed in 45 minutes. Although the steps of completion are provided under the tasks, other methods that the user finds easier or more convenient can also be used. Try to complete the tasks on your own, without looking at the instructions. The assignment is successfully passed if the number of points obtained exceeds 24 (75% of the maximum number of 32).

The assignment uses configured e-mail client **Evolution**:

- E-mail address: ecdltestuser@gmail.com
- Username in the client settings: ecdltestuser@gmail.com
- Password: P@$word
- Display name: ECDL Candidate
- POP server: pop.gmail.com with SSL encryption
- SMTP server: smtp.gmail.com with SSL encryption
- E-mail accounts with webmail access:
  - Webmail service: [www.gmail.com](http://www.gmail.com)
  - Username and Password:
    - ecdlspecialist P@$word
    - ecddlgu.ru P@$word
Tasks 25–31 use messages prepared and submitted in advance. A suitable attachment for the tasks can be found in the user account folder Documents/7_Internet/7.8_test/trainerfiles. Copies of submitted messages are stored in the Sent folder of the account ecdlspecialist.

Useful tip:
Ask someone to help with the completion of the e-mail tasks, either locally or remotely.

1. Open the text document answers.odt in which to enter the answers (1 point):
   1.1. Perform the top panel menu command Places→Documents;
   1.2. Perform a double left click on the folder 7_internet;
   1.3. Perform a double left click on the folder 7.8_test;
   1.4. Select the text file answers.odt;
   1.5. Press the Enter key on the keyboard.

2. Which of these is a global, publicly-accessible system of interconnected computer networks? Hear and hereafter, enter the letter of the correct answer in the file answers.odt (1 point):
   A. World Wide Web (WWW);
   B. Internet;
   C. Intercontinental network;
   D. Public communications network.

3. Who establishes and maintains the Internet connections of organizations, companies, individuals, public authorities (1 point):
   A. Universal Resource Locator (URL);
   B. Internet Service Provider;
   C. The organization’s IT service;
   D. Firewall.

4. Which part of the universal resource locator http://ww.ecdl.org represents the top-level domain (1 point):
   A. http://
   B. www.
   C. ecdl
   D. .org

5. Which of these are multimedia files distributed online for download and later playback on a computer or portable media player (1 point):
   A. RSS feeds;
   B. Podcasts;
   C. MP3 audio files;
   D. Downloads.

6. What is a digital certificate (1 point):
   A. A confirmation that there are no viruses on the site;
B. The site’s version number;
C. The electronic signature of the site’s designer or developer;
D. An electronic document confirming the site’s authenticity and used to ensure a secure connection with the site.

7. Which of these is best for safe access to an online service (1 point):
   A. An encrypted connection is used;
   B. A username and password is used to login to the computer with the Internet connection;
   C. The service is available only to paid users;
   D. The website of the service ensures protection against viruses.

8. What is most likely to infect a computer with a virus while browsing the web (1 point):
   A. Downloading files from websites;
   B. Disabling cookies;
   C. Opening multiple web pages at the same time;
   D. Viewing videos online.

9. Open the website with the following url: http://www.ecdl.org/m7sampletestv5 (1 point):
   9.1. Open the web browser Mozilla Firefox:
       9.1.1. Perform the command Applications→Internet→Firefox Web Browser in the top panel menu.
   9.2. Select the text in the address field of the browser;
   9.3. Enter the address www.ecdl.org/m7sampletestv5 in the address field
   9.4. Press the Enter key on the keyboard.

10. Activate the link Social Networking on the page opened in the previous task (1 point):
    10.1. Position the mouse pointer over the text Social Networking;
    10.2. Perform a left click;

11. In the opened social networking site, add a comment by completing a form (1 point):
    11.1. Scroll down the page to see the comments form;
    11.2. Left-click inside the Username field;
    11.3. Enter the username AR_Jones;
    11.4. In the E-mail field, enter the address arjones@infaxa.com;
    11.5. In the Mood menu, choose Happy;
    11.6. In the Comment field, enter: Thanks for the fly tips. I caught a nice brown trout:
11.7. Submit the form data by clicking Post; do not close the web page.

12. Copy the last three sentences with the posted message’s control number into the field intended for the answer in the document answers.odt (1 point):
   12.1. Select the text in the web page;
   12.2. Perform a right click on the selection;
   12.3. In the right-click menu, perform the Copy command:

   ![Copy Command]

   12.4. Switch to the document answers.odt by using the button in the bottom panel;
   12.5. Position the cursor in the answer field;
   12.6. Perform the menu command Edit->Paste;
   12.7. Save the changes in the document by clicking the Save button in the toolbar.

13. Find information online by using the keyword trout (1 point):
   13.1. Switch to the search engine window by using the button in the bottom panel;
   13.2. Open a new tab in the browser:
       13.2.1. Perform the menu command File->New Tab.
   13.3. In the address field, enter the search engine address www.google.com;
   13.4. Enter the word trout in the search field of the search engine;
   13.5. Press Enter on the keyboard.

14. Open one of the pages found and save it on the computer (1 point):
   14.1. In the list of search results, click the link of one of the results:

   ![Search Result]

   14.2. Perform the menu command File->Save Page As;
14.3. In the Save as dialogue box, select the Documents folder in the Places pane;

14.4. Click Save.

15. Refine the search by using the phrase brown trout (1 point):

15.1. Open the search engine site:
15.1.1. View the recently visited pages by opening the History menu;
15.1.2. In the list of pages visited, select the address of the search engine www.google.com:

15.2. In the browser field, enter the phrase brown trout, placing it in quotation marks:

"brown trout"

15.3. Click the Google Search button;

15.4. Open one website from the results found;
15.4.1. Click on a site link in the search results.

16. Print the first three paragraphs of the current web page (1 point):

16.1. Perform the menu command File→Page Setup;

16.2. In the Page Setup dialogue box:
16.2.1. In the Paper size menu, choose the page format A4;
16.2.2. Click Apply.

16.3. On the web page, select content spanning approximately the first three paragraphs;

16.4. Perform the menu command File→Print;

16.5. In the Print dialogue box, select the available printer;

16.6. Choose Selection in the Range pane:

16.7. Click Print.

17. Which of these answers best describes the difference between the fields Cc and Bcc in e-mail clients? Here and hereafter, enter the letter of the correct answer in the file answers.odt (1 point):

A. There is no difference between the fields Cc and Bcc;
B. The addresses of recipients in the Bcc field are visible to all recipients of the message;
C. The addresses of recipients in the Bcc field are not visible to all recipients of the message;
D. The addresses of recipients in the Cc field are not visible to all recipients of the message.

18. Which of these does not conform to network etiquette (netiquette) (1 point):
A. Checking the spelling of a message before sending it;
B. Compressing files before attaching them to e-mail messages;
C. Only responding to messages marked as high-priority;
D. Entering the subject of the message in the Subject field.

19. Which of these actions is the most likely to cause a computer to become infected with a virus (1 point):
A. Copying text from an e-mail message into a text document;
B. Opening the attachment of a message from an unknown sender;
C. Adding a sender’s address to the contact book;
D. Saving an e-mail attachment in a folder on the computer.

20. Which of these methods of electronic communication shows whether a contact is currently online (1 point):
A. Really simple syndication (RSS);
B. Text messaging (SMS);
C. Instant messaging (IM);
D. The contact’s URL.

21. Create an e-mail message for the recipient ecdlspecialist@gmail.com (1 point):
21.1. Save the changes in the document answers.odt:
   21.1.1. Click the Save button in the toolbar.
21.2. Close the document answers.odt by clicking the Close button in the title bar.
21.3. Launch an e-mail client:
   21.3.1. Perform the top panel menu command Applications−>Internet→Evolution Mail.
21.4. In the toolbar of the client’s window, click New:
   ![New button](image)
21.5. Create a message:
   21.5.1. In the To field, enter the recipient’s e-mail address ecdlspecialist@gmail.com
   21.5.2. In the Subject field, enter the message subject About testing;
   21.5.3. Enter the text of the message (pictured):
22. Send a copy of the message to the recipient ecdlguru@gmail.com (1 point):
   22.1. In the Cc field, enter the address ecdlguru@gmail.com.

23. Attach the file answers.odt to the message (1 point):
   23.1. Click the button Add Attachment in the message window;
   23.2. In the dialogue box Add Attachment, select the Documents folder in the Places pane;
   23.3. Perform a double left click on the folder 7_internet in the right pane;
   23.4. Perform a double left click on the folder 7.8_test;
   23.5. Select the file answers.odt;
   23.6. Click Attach.

24. Send a high-priority message (1 point):
   24.1. In the message window, perform the menu command Options-->Prioritize Message;
   24.2. Click the Send button in the toolbar of the message window.

25. By using the search tool, find a message in the inbox with the subject Testing (1 point):
   25.1. Check your e-mail messages:
   25.1.1. Click the Send/Receive button in the Evolution window;
   25.1.2. Make sure that the Inbox folder has been selected.
   25.2. In the search field, enter the subject Testing;
   25.3. Press Enter on the keyboard.

26. Open a message (1 point):
   26.1. In the list of search results, open the message with the subject Testing from the sender ECDL Trainer;
26.2. View the content of the message.

27. Open the attachment of the message (1 point):
   27.1. Expand the attachment pane:
      27.1.1. Click on the attachment item:

      ![Attachment Icon]

   27.2. Perform a double left click on the attachment icon:

      ![Attachment Icon]

28. Copy the first paragraph of the opened document (after the title) into the response, without keeping the original message (2 points):
   28.1. Select the text in the first paragraph of the document;
      28.1.1. Perform a left click at the end of the paragraph, after the word providers;
      28.1.2. While holding the mouse button, drag the mouse pointer to the beginning of the first paragraph, and position it before the word ECDL:

      ![Document Text]

   28.2. Perform the command Edit->Copy in the menu of the word processor;
   28.3. Switch to the window of the e-mail client by using the button in the bottom panel:

      ![Email Client Window]

   28.4. Click the Reply button in the window of the e-mail client;
   28.5. Select the entire text of the message:
      28.5.1. Perform a left click inside the message’s body;
      28.5.2. Perform the menu command Edit->Select All in the message window.
   28.6. Perform the menu command Edit->Paste in the message window;
   28.7. Click Send.

29. Save the attachment of the message in the Documents folder (1 point):
   29.1. Click the Save As button next to the attachment;
   29.2. In the dialogue box Save Attachment, select the Documents folder in the Places pane;
29.3. Click **Save**;
29.4. Remove the current search results:
   29.4.1. Click the clear button in the search window;

30. Forward a message with the subject **Forward** to the e-mail address **ecdlguru@gmail.com** (1 point):
   30.1. Check your e-mail:
      30.1.1. Click the **Send/Receive** button in the **Evolution** window;
      30.1.2. Make sure that the **Inbox** folder has been selected.
   30.2. In the message list, select the message with the subject **Forward**;
   30.3. Click the **Forward** button in the toolbar:
   30.4. In the message field, enter the recipient’s address **ecdlguru@gmail.com**;
   30.5. Click **Send**.
31. Print the message on the default printer (if possible) (1 point):
   31.1. Perform the menu command **File→Print**;
   31.2. In the **Print** dialogue box, click the **Print** button.
Supplement 1

ECDL requirements for Module 7: Web Browsing and Communication.

Web browsing:
- Understand what the Internet is and common terms associated with it. Be aware of some security considerations when using the Internet.
- Accomplish everyday web browsing tasks including changing browser settings.
- Search for information and complete and submit web-based forms.
- Save web pages and download files from the web. Copy web content into a document.

Communication:
- Understand what e-mail is and know some advantages and disadvantages of its use. Be aware of other communication options.
- Be aware of network etiquette and security considerations when using e-mail.
- Create, spell check and send e-mail. Reply to and forward e-mail, handle file attachments and print an e-mail.
- Be aware of ways to enhance productivity when working with e-mail software. Organize and manage e-mail.

<table>
<thead>
<tr>
<th>Category</th>
<th>Skill set</th>
<th>No.</th>
<th>Task item</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.1 Internet</td>
<td>7.1.1 Concepts/Terms</td>
<td>7.1.1.1</td>
<td>Understand what the Internet is.</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.1.2</td>
<td>Understand what the World Wide Web (WWW) is.</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.1.3</td>
<td>Define and understand the terms: Internet Service Provider (ISP), Uniform Resource Locator (URL), hyperlink.</td>
<td>6, 8, 10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.1.4</td>
<td>Understand the make-up and structure of a web address.</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.1.5</td>
<td>Understand what a web browser is and name different web browsers.</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.1.6</td>
<td>Know what a search engine is.</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.1.7</td>
<td>Understand the term Really Simple Syndication (RSS) feed. Understand the purpose of subscribing to an RSS feed.</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.1.8</td>
<td>Understand the term podcast. Understand the purpose of subscribing to a podcast.</td>
<td>5</td>
</tr>
<tr>
<td>7.1.2 Security</td>
<td>7.1.2.1</td>
<td>7.1.2.1</td>
<td>Know how to identify a secure website: https, lock symbol.</td>
<td>Error! Bookmark not defined.</td>
</tr>
<tr>
<td>Considerations</td>
<td></td>
<td>7.1.2.2</td>
<td>Know what a digital certificate for a website is.</td>
<td>38</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.2.3</td>
<td>Understand the term encryption.</td>
<td>39</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.2.4</td>
<td>Know about security threats from websites like: viruses, worms, trojan horses, spyware. Understand the term malware.</td>
<td>36</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.1.2.5</td>
<td>Understand that regularly updated anti-virus software helps to protect the</td>
<td>36</td>
</tr>
<tr>
<td>Category</td>
<td>Skill set</td>
<td>No.</td>
<td>Task item</td>
<td>Page</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------</td>
<td>-----</td>
<td>---------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>computer against security threats.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>7.1.2.6</td>
<td></td>
<td>Understand that a firewall helps to protect the computer against intrusion.</td>
<td>37</td>
</tr>
<tr>
<td></td>
<td>7.1.2.7</td>
<td></td>
<td>Know that networks should be secured by user names and passwords.</td>
<td>37</td>
</tr>
<tr>
<td></td>
<td>7.1.2.8</td>
<td></td>
<td>Identify some risks associated with online activity like: unintentional disclosure of personal information, bullying or harassment, targeting of users by predators.</td>
<td>42</td>
</tr>
<tr>
<td></td>
<td>7.1.2.9</td>
<td></td>
<td>Identify parental control options like: supervision, web browsing restrictions, computer games restrictions, computer usage time limits.</td>
<td>43</td>
</tr>
<tr>
<td>7.2 Using the Browser</td>
<td>7.2.1 Basic Browsing</td>
<td></td>
<td>Open, close a web browsing application.</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>7.2.1.2</td>
<td></td>
<td>Enter a URL in the address bar and go to the URL.</td>
<td>9</td>
</tr>
<tr>
<td></td>
<td>7.2.1.3</td>
<td></td>
<td>Display a web page in a new window, tab.</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>7.2.1.4</td>
<td></td>
<td>Stop a web page from downloading.</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>7.2.1.5</td>
<td></td>
<td>Refresh a web page.</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>7.2.1.6</td>
<td></td>
<td>Use available Help functions.</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>7.2.2 Settings</td>
<td></td>
<td>Set the web browser Home Page/Startpage.</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>7.2.2.2</td>
<td></td>
<td>Delete part, all browsing history.</td>
<td>14, 18</td>
</tr>
<tr>
<td></td>
<td>7.2.2.3</td>
<td></td>
<td>Allow, block pop-ups.</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td>7.2.2.4</td>
<td></td>
<td>Allow, block cookies.</td>
<td>41</td>
</tr>
<tr>
<td></td>
<td>7.2.2.5</td>
<td></td>
<td>Delete cache/temporary Internet files.</td>
<td>14</td>
</tr>
<tr>
<td></td>
<td>7.2.2.6</td>
<td></td>
<td>Display, hide built-in toolbars.</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>7.2.3 Navigation</td>
<td></td>
<td>Activate a hyperlink.</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>7.2.3.2</td>
<td></td>
<td>Navigate backwards and forwards between previously visited web pages.</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>7.2.3.3</td>
<td></td>
<td>Navigate to the Home page.</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>7.2.3.4</td>
<td></td>
<td>Display previously visited URLs using the browser address bar, history.</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>7.2.4 Bookmarks</td>
<td></td>
<td>Bookmark a web page. Delete a bookmark.</td>
<td>15, 17</td>
</tr>
<tr>
<td></td>
<td>7.2.4.2</td>
<td></td>
<td>Display a bookmarked web page.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>7.2.4.3</td>
<td></td>
<td>Create, delete a bookmark folder.</td>
<td>16, 17</td>
</tr>
<tr>
<td></td>
<td>7.2.4.4</td>
<td></td>
<td>Add web pages to a bookmark folder.</td>
<td>15</td>
</tr>
<tr>
<td>7.3 Using the Web</td>
<td>7.3.1 Forms</td>
<td></td>
<td>Complete a web-based form using: text boxes, drop-down menus, list boxes, check boxes, radio buttons.</td>
<td>84</td>
</tr>
<tr>
<td></td>
<td>7.3.1.1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>7.3.1.2</td>
<td></td>
<td>Submit, reset a web-based form.</td>
<td>27</td>
</tr>
<tr>
<td></td>
<td>7.3.2 Searching</td>
<td></td>
<td>Select a specific search engine.</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td>7.3.2.2</td>
<td></td>
<td>Carry out a search for specific information using a keyword, phrase.</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>7.3.2.3</td>
<td></td>
<td>Use advanced search features to refine a search: by exact phrase, by excluding words, by date, by file</td>
<td>24</td>
</tr>
<tr>
<td>Category</td>
<td>Skill set</td>
<td>No.</td>
<td>Task Item</td>
<td>Page</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------</td>
<td>-------</td>
<td>--------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>7.4 Web Outputs</td>
<td>7.4.1 Saving Files</td>
<td>7.4.1.1</td>
<td>Save a web page to a location on a drive.</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.4.1.2</td>
<td>Download files from a web page to a location on a drive.</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.4.1.3</td>
<td>Copy text, image, URL from a web page to a document.</td>
<td>29</td>
</tr>
<tr>
<td></td>
<td>7.4.2 Prepare and</td>
<td>7.4.2.1</td>
<td>Prepare a web page for printing: change printed page orientation,</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>Print</td>
<td></td>
<td>paper size, printed page margins.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.4.2.2</td>
<td>Preview a web page.</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.4.2.3</td>
<td>Choose web page print output options like: entire web page, specific</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>page(s), selected text, number of copies and print.</td>
<td></td>
</tr>
<tr>
<td>7.5 Electronic</td>
<td>7.5.1 Concepts/Terms</td>
<td>7.5.1.1</td>
<td>Understand the term e-mail and know its main uses.</td>
<td>5</td>
</tr>
<tr>
<td>Communication</td>
<td></td>
<td>7.5.1.2</td>
<td>Understand the make-up and structure of an e-mail address.</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.1.3</td>
<td>Understand the term short message service (SMS).</td>
<td>74</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.1.4</td>
<td>Understand the term Voice over Internet Protocol (VoIP) and know its</td>
<td>73</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>main benefits.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.1.5</td>
<td>Understand the main benefits of instant messaging (IM) like: real-time</td>
<td>73</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>communication, knowing whether contacts are online, low cost, ability</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>to transfer files.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.1.6</td>
<td>Understand the concept of an online (virtual) community. Recognize</td>
<td>73</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>examples like: social networking websites, Internet forums, chat</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>rooms, online computer games.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>7.5.2 Security</td>
<td>7.5.2.1</td>
<td>Be aware of the possibility of receiving fraudulent and unsolicited</td>
<td>47</td>
</tr>
<tr>
<td></td>
<td>Considerations</td>
<td></td>
<td>email.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.2.2</td>
<td>Understand the term phishing. Recognize attempted phishing.</td>
<td>37</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.2.3</td>
<td>Be aware of the danger of infecting the computer with a virus by opening</td>
<td>36</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>an unrecognized e-mail message, by opening an attachment.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.2.4</td>
<td>Understand what a digital signature is.</td>
<td>39</td>
</tr>
<tr>
<td></td>
<td>7.5.3 E-mail Theory</td>
<td>7.5.3.1</td>
<td>Understand the advantages of e-mail systems like: speed of delivery, low</td>
<td>47</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>cost, flexibility of using a web-based e-mail account in different</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>locations.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.3.2</td>
<td>Understand the importance of network etiquette (netiquette) like: using</td>
<td>47</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>accurate and brief descriptions in e-mail message subject fields,</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>brevity in e-mail responses, spell checking outgoing e-mail.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.5.3.3</td>
<td>Be aware of possible problems when sending file attachments like: file</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>size limits, file type restrictions.</td>
<td></td>
</tr>
<tr>
<td>Category</td>
<td>Skill set</td>
<td>No.</td>
<td>Task item</td>
<td>Page</td>
</tr>
<tr>
<td>----------</td>
<td>-----------</td>
<td>-----</td>
<td>-----------</td>
<td>------</td>
</tr>
<tr>
<td>Web browsing and communication</td>
<td>example, executable files).</td>
<td>7.5.3.4</td>
<td>Understand the difference between the To, Copy (Cc), Blind copy (Bcc) fields.</td>
<td>54</td>
</tr>
<tr>
<td>7.6 Using e-mail</td>
<td></td>
<td>7.6.1 Send an e-mail</td>
<td>7.6.1.1</td>
<td>Open, close an e-mail application. Open, close an e-mail.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.1.2</td>
<td>Create a new e-mail.</td>
<td>54</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.1.3</td>
<td>Enter an e-mail address in the To, Copy (Cc), Blind copy (Bcc) fields.</td>
<td>54</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.1.4</td>
<td>Enter a title in the Subject field.</td>
<td>55</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.1.5</td>
<td>Copy text from another source into an e-mail.</td>
<td>63</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.1.6</td>
<td>Insert, remove a file attachment.</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.1.7</td>
<td>Save a draft of an e-mail.</td>
<td>64</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.1.8</td>
<td>Use a spell checking tool and correct spelling errors.</td>
<td>55</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.1.9</td>
<td>Send an e-mail, send an e-mail with a low, high priority.</td>
<td>55, 63</td>
</tr>
<tr>
<td>7.6.2 Receiving e-mail</td>
<td></td>
<td>7.6.2.1</td>
<td>Use the reply, reply to all function.</td>
<td>60</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.2.2</td>
<td>Forward an e-mail.</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.2.3</td>
<td>Save a file attachment to a location on a drive and open the file.</td>
<td>62</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.2.4</td>
<td>Preview, print a message using available printing options.</td>
<td>60</td>
</tr>
<tr>
<td>7.6.3 Enhancing Productivity</td>
<td></td>
<td>7.6.3.1</td>
<td>Add, remove message inbox headings like: sender, subject, date received.</td>
<td>65</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.3.2</td>
<td>Apply a setting to reply with, without original message insertion.</td>
<td>60</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.3.3</td>
<td>Flag an e-mail. Remove a flag mark from an e-mail.</td>
<td>63</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.3.4</td>
<td>Identify an e-mail as read, unread. Mark an e-mail as unread, read.</td>
<td>63</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.3.5</td>
<td>Display, hide built-in toolbars. Restore, minimize the ribbon.</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.6.3.6</td>
<td>Use available Help functions.</td>
<td>52</td>
</tr>
<tr>
<td>7.7 E-mail Management</td>
<td></td>
<td>7.7.1 Organize</td>
<td>7.7.1.1</td>
<td>Search for an e-mail by sender, subject, e-mail content.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.1.2</td>
<td>Sort e-mails by name, by date, by size.</td>
<td>64</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.1.3</td>
<td>Create, delete an e-mail folder.</td>
<td>66</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.1.4</td>
<td>Move e-mails to an e-mail folder.</td>
<td>66</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.1.5</td>
<td>Delete an e-mail.</td>
<td>67</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.1.6</td>
<td>Restore a deleted e-mail.</td>
<td>67</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.1.7</td>
<td>Empty the e-mail bin/deleted items/trash folder.</td>
<td>67</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.2 Address Book</td>
<td>7.7.2.1</td>
<td>Add contact details to an address book. Delete contact details from an address book.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.2.2</td>
<td>Update an address book from incoming e-mail.</td>
<td>68</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7.7.2.3</td>
<td>Create, update a distribution list/mailing list.</td>
<td>69</td>
</tr>
</tbody>
</table>